PDA

View Full Version : Warty Backport: Firestarter 1.0.3



jdong
February 17th, 2005, 10:07 PM
Synopsis
User request for newer Firestarter (1.0.0 was in Backports previously)

Backporting Process
The source archive directly came from Hoary. I was able to meet all dependencies.

One modification: I modified the desktop shortcut to use gksudo instead of gksu. :)

Packaging Status:
i386 -- Staging at revision 49
amd64 -- Not packaged
ppc -- Not packaged

Beta tester notes:

jdong
February 17th, 2005, 10:08 PM
firestarter: Depends: iptables (>= 1.2.11) but 1.2.9-10ubuntu0.1 is to be installed



Hmm, investigating...

jdong
February 17th, 2005, 10:13 PM
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=271078

looks bad

Nano
February 27th, 2005, 03:06 PM
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=271078

looks bad
Running Firestarter 1.0.3 without problems.
Just installed the Debian package

jdong
February 27th, 2005, 03:10 PM
Here's the deal:

Some new Firestarter 1.0.3 features require new IPTables features that the Warty version of IPTables doesn't offer. You may get "Invalid Argument" errors at bootup, and you certainly won't get that protection you specified.


If that's O.K. with you guys, I'll continue and mark it stable. I don't want to backport IPTables, as that's too critical a system component.