PDA

View Full Version : [ubuntu] Odd crash on 10.04 VM hosted on Windows HyperV



danielhedley
October 1st, 2010, 02:02 PM
For no apparent reason an Ubuntu 10.04 server VM hosted on Windows HyperV just ground to a complete halt the other day; the console was completely unresponsive and only a "hard" reset brought it back to life.

In /var/log/messages are lots of entries at the time of the crash along the lines of:


Sep 28 06:59:02 vJustisKB kernel: [512997.483280] BLKVSC_DRV: CHS (41610, 16, 63)
Sep 28 06:59:02 vJustisKB kernel: [512997.483392] BLKVSC_DRV: CHS (41610, 16, 63)
Sep 28 06:59:02 vJustisKB kernel: [512997.483401] BLKVSC_DRV: CHS (41610, 16, 63)

I've been Googling around and have not been able to find a useful explanation of what's going on.

Am I missing something? Any Ubuntu Gods able to shed light?

Many thanks for your help.

abix_adam_pl
October 1st, 2010, 02:19 PM
CHS (41610, 16, 63)

That looks like a Cylinder , Head, Sector in disk. Maybe something with SATA/SCSI Subsystem ?

Adam

danielhedley
October 1st, 2010, 02:25 PM
That was my thought too, although of course being a VM there is no physical disk.

fsck checks out too. Hmmm.

Inigo Montoya
May 26th, 2011, 01:13 PM
any news on this topic? i seem to have a same/similar problem.
my setup:
Hyper-V 2008 R2 SP1
Ubuntu Server 11.04 (but had the same issue with 10.04 LTS)

stevellion
July 22nd, 2011, 11:43 AM
Me too - same problem.

stevellion
July 22nd, 2011, 12:15 PM
Anyone think it is related to this?

http://ns3.spinics.net/lists/linux-virtualization/msg12861.html