PDA

View Full Version : [ubuntu] PDO OCI driver exception



Andrewdps
September 21st, 2010, 04:52 PM
Hi all,

I get the following error when installing PDO_OCI.
Fatal error: PDO: driver oci requires PDO API version 20060409; this is PDO version 20060511 in Unknown on line 0

When I tried to check the php version,I got an error showing
# php --version
PHP Fatal error: PDO: driver oci requires PDO API version 20060409; this is PDO version 20060511 in Unknown on line 0
PHP 5.2.6-1+lenny9 with Suhosin-Patch 0.9.6.2 (cli) (built: Aug 4 2010 06:06:53)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies



And phpinfo().php doesn't show me PDO sections...it's likePDO PDO supportenabled PDO drivers no value
PDO_OCI

PDO Driver for OCI 8 and laterenabled
Can anyone point me in the right direction.

Thanks.