PDA

View Full Version : [ubuntu] Ubuntu Freezing



comp_007
September 21st, 2010, 09:25 AM
Just installed ubuntu yesterday and it does not work !

Whenever I log-in after a few seconds ubuntu freezes !

I am using ubuntu 10.04.1 .

I am able to run it in failsafe mode and low graphics mode without any problem.

The internet hasn't been configured yet. .

So right now I am posting through Win 7.

Please Help:confused:

P.S :- I am a beginner !

comp_007
September 22nd, 2010, 06:43 AM
No replies ?

comp_007
September 22nd, 2010, 06:51 AM
P.S -- I managed to connect internet in ubuntu. So ryt now I am using failsafe Mode which doesn't support any graphics !!

sikander3786
September 22nd, 2010, 07:03 AM
Which graphics card are you using? Did you activate drivers for your card?

Also have you installed all the updates from the update manager?

comp_007
September 22nd, 2010, 07:08 AM
I am using Intel 82945G/GZ Integrated Graphics Controller.

How to activate drivers ?

And yes, I have installed all the updates.

sikander3786
September 22nd, 2010, 07:15 AM
You don't need to activate drivers for Intel Graphics. I think it is a problem related to compiz, try deactivating it for a moment and see if the freezes are gone. On the login screen press Ctrl + Alt + F1, login using your credentials in the console and type the following command.



sudo chmod a-x /usr/bin/compiz


Then hit Ctrl + Alt + F7 and login to the Ubuntu desktop and see if it still freezes.

comp_007
September 22nd, 2010, 07:53 AM
Ubuntu crashed while performing the above operation.

Now I am getting this message when i enter username password in Ctrl+Alt+ F1 screen


unable to cd to '/home/username'

Now I am unable to log into ubuntu any any means !!!

sikander3786
September 22nd, 2010, 08:04 AM
Are you sure you typed the above command as stated there. I think you accidentally changed permissions on the home directory. What is the output of



ls -la /home


and



ls -la /

comp_007
September 22nd, 2010, 08:05 AM
Are you sure you typed the above command as stated there. I think you accidently changed permission of the home directory. What is the output of



ls -la /home


and



ls -la /


Where do I type these commands ?

sikander3786
September 22nd, 2010, 08:14 AM
By hitting Ctrl + Alt + F1 at login screen. You'd have to post the output. Not easy typing all that stuff. Ok instead try to change permissions on your home directory regardless of what they actually are for now.



chmod 755 /home


Then restart by



shutdown -r now


And try to login when it reboots.

comp_007
September 22nd, 2010, 08:44 AM
Sorry ,but I feel everything is going from over my head now !

Can you give a bit more detailed explaination please !!

Already I messed out my first step now don't want to mess up further.

comp_007
September 22nd, 2010, 08:49 AM
By hitting Ctrl + Alt + F1 at login screen.

This prompts for username/password which ultimately gives the above mentioned error !
And the loop username/password loop is repeated again & again !!



You'd have to post the output. Not easy typing all that stuff

If I reach there I would definitely do it !


Ok instead try to change permissions on your home directory regardless of what they actually are for now.



chmod 755 /home


Then restart by



shutdown -r now


And try to login when it reboots.

So that means I don't have to type the above commands which you mentioned in your previous post ?

And the same question goes.
Where to type this ?
Since Ctrl+Alt+F1 screen requires username / password.

sikander3786
September 22nd, 2010, 09:00 AM
Sorry. Boot into recovery mode by pressing and holding down the shift key as soon as your computer gets past the Bios screen. Select recovery option probably the second one on the list. Select Drop to root shell and type chmod 755 /home there, then restart.

comp_007
September 22nd, 2010, 09:15 AM
Got into the recovery mode.
Selected Drop Root shell

Typed chmod 755 /home
and then restarted

After restarting ubuntu got stuck at the loading screen. I tried Ctrl+Alt +F1.
Typed username/password

But it still gave the same error *unable to cd to '/home/username'*

Pressed Ctrl+Alt+F7 to get back to the loading screen and then finally switched of the compter using power button from the CPU.

What should I do now ?

sikander3786
September 23rd, 2010, 06:57 AM
Here is a similar thread and the OP unfortunately had to re-install.

http://ubuntuforums.org/showthread.php?t=354643

comp_007
September 23rd, 2010, 11:32 AM
Yes.

I reinstalled it yesterday only.Since it was a fresh installation I didn't mind it.

But the initital problem (Freezing one) still exists.

Is there another way to uninstall Compiz without risking much ?

comp_007
September 23rd, 2010, 01:33 PM
I removed compiz packages using synaptic package manager.
That fixed the problem. I am able to run ubuntu in normal mode !

But,I want to install compiz also.
Is there a way to install compiz and run ubuntu normally ?

sikander3786
September 23rd, 2010, 05:06 PM
Intel graphic chips have some history of problems with compiz. I used compiz on my dell gx280 with intel 915 chip 2 years back and it used to work well. Some intel chips have been on the compiz black list for some time. If it is not a critical/production machine, you can keep on testing otherwise I will advise to stay away if it is causing problems.

http://ubuntuforums.org/showthread.php?t=1474759

comp_007
September 23rd, 2010, 07:27 PM
Well , thanks for solving all my quries.

And that means that I won't be able to run compiz desktop effects :(.
BTW , how do I know which intel graphic cards have been blacklisted by compiz ?

sikander3786
September 23rd, 2010, 07:33 PM
The list for currently black listed cards is here.

http://wiki.compiz.org/Hardware/Blacklist

Your card is not currently on the list but I'm pretty sure it has been there for some time.

The link is not opening here for now, it used to. I can only see a cached copy in Chrome.

comp_007
September 23rd, 2010, 08:05 PM
Okey,Thanks for the link.

Its opening at my place perfectly !

Maybe after upgrading to ubuntu 10.10 this problem is solved !