PDA

View Full Version : [SOLVED] Screen Resolution- nVidia GeForce 7100



Thomas_Bates
September 16th, 2010, 12:46 PM
I am stuck at 1024x768 in Ubuntu 10.04 with the nVidia GeForce 7100. I installed the drivers suggested by nVidia on their website, but it doesn't seem to heighten my resolution any. 1024x768 is the highest which appears in nVidia X Server Settings.

Xorg.conf:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 256.53 (buildmeister@builder101) Fri Aug 27 21:34:01 PDT 2010


Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Configured Keyboard" "CoreKeyboard"
InputDevice "Configured Mouse"
EndSection

Section "Module"

# Load "type1"
# Load "freetype"
# Load "dbe"
Load "glx"
# Load "extmod"
EndSection

Section "InputDevice"
Identifier "Configured Keyboard"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "Maxdata"
ModelName "1905 S1"
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 75.0
Gamma 1
Option "DPMS"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
BoardName "GeForce 7100"
EndSection

Section "Screen"

# Busid "PCI:0:1:0"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "NoLogo" "True"
SubSection "Display"
Virtual 1024 768
Depth 24
Modes "1024x768" "800x600"
EndSubSection
EndSection



Is there a way to fix this without having to buy a new card? I've read that the GeForce 7100 is pretty crappy, but I've got no money to space at the moment.

Thanks!

cascade9
September 16th, 2010, 02:04 PM
Try this-

gksudo nvidia-settings

Then go to the monitor area in nvidia-settings (on mine is DFP-1, I forget what it has for a CRT monitor) then hit the "Acquire EDID" button. Info on EDID here-

http://en.wikipedia.org/wiki/Extended_display_identification_data

That should work and give you a mode higher than 1024x768, hopefully 1280x1024 that (As far as I can tell) is your monitors native resolution. If it doesnt, you might have to manually enter the mode data.

ST3ALTHPSYCH0
September 16th, 2010, 02:13 PM
If you can't get anything else to work, try my workaround. That was a last resort to get above a much lower resolution than you're experiencing, BTW.

Thomas_Bates
September 16th, 2010, 11:11 PM
Yep, the workaround didn't work for me, but I tried it on a 10.04 liveCD (which still read my resolution as 1024x768.

So, I decided to grow some and edit the file myself, stupid thing to do probably. I increased the virtual to 12--x1024, which actually worked. Sort of. It left my "screen" alone, and added a bunch of dead white space which I had to move my mouse to the edge to navigate. I kept messing with it until I got a message from my monitor (which is a 22' Dynex TV Screen) saying "Not Supported." It took me a lot of tty work to straighten this out, as the xorg.conf.bak was also messed up. It is fine now, but back to the normal resolution :|

cascade9
September 17th, 2010, 12:24 AM
1280x1024 might have been totaly wrong then. I was basing that in this bit of your xorg.conf file-

Section "Monitor"
Identifier "Configured Monitor"
VendorName "Maxdata"
ModelName "1905 S1"

If its a 22'' TV, its likely that that resolution is totally different- 1280x720, 1280x768, 1280x800 are all possible (and that is just the 1280xXXX rsolutions, there are more possibilities).

What model is it?

Thomas_Bates
September 17th, 2010, 03:13 AM
It is a Dynex, I guess a lesser known brand, but it is quite nice. I don't know a specific model number. I'm not sure where I would even find that aside from the box, which is no longer here.

ST3ALTHPSYCH0
September 17th, 2010, 03:37 AM
Should have the info on a tag on the back... Dynex is a Best Buy house brand, correct?

Thomas_Bates
September 17th, 2010, 09:30 PM
Should have the info on a tag on the back... Dynex is a Best Buy house brand, correct?

There are a few tags on the back, none of them mention resolution or display (such as 1080i).

Temüjin
September 17th, 2010, 10:14 PM
You should add "1280x1024" to the Modes line. It might help with the dead space. ;)

Thomas_Bates
September 18th, 2010, 12:47 AM
Didn't work :/

ST3ALTHPSYCH0
September 18th, 2010, 03:37 AM
No, I was saying that you could get model number off the tags.... From there you should be able to get the manual as a .PDF from their site. That will have the info you need.

cascade9
September 18th, 2010, 07:48 AM
No, I was saying that you could get model number off the tags.... From there you should be able to get the manual as a .PDF from their site. That will have the info you need.

You probably wouldnt even need to d/l the manual. Normally, just putting the model number into a search engine (with "native resolution" as well) gets me the info I need.

Thomas_Bates
September 19th, 2010, 10:55 PM
Sorry, wedding, was gone all weekend.

http://www.productwiki.com/dynex-dx-ldvd22-10a/

This says the native resolution is 1366 x 768. I added that to Modes, and after restarting xserver, it is still not in the resolution dropdown box in nvidia-config.

current xorg.conf:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 256.53 (buildmeister@builder101) Fri Aug 27 21:34:01 PDT 2010

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Configured Keyboard" "CoreKeyboard"
InputDevice "Configured Mouse"
EndSection

Section "Module"

# Load "extmod"
# Load "type1"
# Load "freetype"
Load "glx"
# Load "dbe"
EndSection

Section "InputDevice"
Identifier "Configured Keyboard"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "Maxdata"
ModelName "1905 S1"
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 75.0
Gamma 1
Option "DPMS"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
BoardName "GeForce 7100"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "NoLogo" "True"
# Busid "PCI:0:1:0"
SubSection "Display"
Virtual 1024 768
Depth 24
Modes "1366x768" "1024x768" "800x600"
EndSubSection
EndSection

Thomas_Bates
September 19th, 2010, 11:04 PM
Upon changing "Virtual" to 1366 768, my screen looks like this:

(Pic Removed, redundant)

When my mouse goes to either the left or right, the screen "follows" the pointer, as before.

EDIT (while I'm still posting original message lol):

I went into nvidia-config and looked, and Resolution was still set to 1024x768. So I clicked, and it has a mode of 1360x768. It is lacking 6 pixels, but that is quite irrelevant, it is MUCH better!

I think this means it is solved, so I'm going to mark it so. If anyone sees an error, however, I'll keep watch over this for awhile.


Thanks!