PDA

View Full Version : [ubuntu] Triple boot Ubuntu Backtrack and windows 7



tanush
September 8th, 2010, 03:36 PM
Guys,
Im really copping up with linux and have learned quite much in linux field and now i tried triple booting Ubuntu,Backtrack and windows 7.

I have installed ubuntu through wubi but can install seperately also

How should i proceed?
Can someone please help?

I have been scared of grub and i wanna overcome it.

plz help guys....

uRock
September 8th, 2010, 03:39 PM
You are wanting to remove the wubi and install to a partition and install Back|Track or you already have BT installed?

What is your current partitioning scheme?

tanush
September 8th, 2010, 03:56 PM
I tried installing all 3 but dont knw how to configure..

what i did was

i installed 7
then ubuntu using wubi

and then backtrack..

now i cant log in into windows 7 and there is no grub entry for backtrack :(

mohansathish
September 8th, 2010, 04:10 PM
Just try updating the grub.
Goto terminal and type sudo update-grub.
I think that will list backtrack

uRock
September 8th, 2010, 06:13 PM
Tanush, Did the updating of grub fix the problem?

mohansathish
September 8th, 2010, 06:16 PM
Our kind request Is, If you get your problem solved, please do inform us so that we will be much more happy to hear that

tanush
September 9th, 2010, 03:14 AM
sorry for the late reply..

I didnt touch the grub.

I have installed the operating systems only.

And I cannot boot into windows.

I could boot only till boot splash screen.

mohansathish
September 9th, 2010, 03:20 AM
I think installing grub alone will solve your problem. The reason is that the BOOT.INI file in windows might malfunction. so, Installing grub will help you. Install it by using Live CD and Internet.

Good luck

tanush
September 9th, 2010, 09:31 AM
Alrite This is what happened now..


I updated the grub but no use..


I see 4 entries named Ubuntu but two of them opens up backtrack and other 2 hangs.


Windows 7 is working perfectly... BT is working perfectly but I cannot boot into ubuntu....


update grub was completed successfully but nothing has changed...

what should i do now ?

tanush
September 9th, 2010, 09:37 AM
plz see the pic attached

the highlighted entry does not work..

Mark Phelps
September 9th, 2010, 04:56 PM
I think installing grub alone will solve your problem. The reason is that the BOOT.INI file in windows might malfunction. so, Installing grub will help you. Install it by using Live CD and Internet.

Good luck

Been a while since I checked, but AFAIK, Wubi installs do not use GRUB; instead, they use something known as GRUB4DOS -- because they install it to an NTFS partition. So, telling the OP to install GRUB is not only wasting their time, it's possibly damaging their system.

As to boot.ini -- good grief folks! That hasn't been used since Vista came out YEARS ago. If you're going to offer MS Windows advice, then at least take the time to research the problem.

uRock
September 9th, 2010, 05:07 PM
Mark, the OP should have grub via the Back|Track install.:D

tanush
September 11th, 2010, 01:17 PM
Just try updating the grub.
Goto terminal and type sudo update-grub.
I think that will list backtrack

This worked..

but i had to install ubuntu again without using wubi..

thnx a ton...

uRock
September 11th, 2010, 02:49 PM
I bet ubuntu will run even better for you now. It may take some initial tweaking, but it will be good.

mohansathish
September 11th, 2010, 04:09 PM
Rock and roll with separate install tanush ;)