PDA

View Full Version : [xubuntu] Dual monitor issue



M0GEJ
August 21st, 2010, 05:17 PM
Have just installed a second monitor (not the same type as the first). What is appearing on the new monitor is exactly the same as on the other one.

On the display settings there is only one screen listed. I also get the following error message:

"You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

Any ideas?

dino99
August 21st, 2010, 06:11 PM
install this ppa to synaptic repo tab:

https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

remove xorg.conf: sudo rm -f /etc/X11/xorg.conf

update and install the needed packages (nvidia-current, ....)

then reboot and check driver activation: system admin hardware driver, nvidia-current might be activated

then run nvidia-xconfig: system admin nvidia x settings, if it cant set the good settings (for each monitor), then you need to tweak the new xorg.conf created

M0GEJ
August 21st, 2010, 06:35 PM
Tried doing that but encountered a few problems

then reboot and check driver activation: system admin hardware driver, nvidia-current might be activated
Here there was no change to the installed drivers


then run nvidia-xconfig: system admin nvidia x settings, if it cant set the good settings (for each monitor), then you need to tweak the new xorg.conf created
The nvidia option has now disappeared from the menu:(

Am currently trying to figure out where I made the mistake...