PDA

View Full Version : Integrated webcam on Hannspree SN10E2



riprydah
August 21st, 2010, 05:04 AM
I just installed Ubuntu Netbook 10.04 on my Hannspree netbook. I tried using the integrated webcam via Cheese but I get an error message that says "No Device Found".

I'm a first time Ubuntu (or Linux) user, so any help would be appreciated. Thanks.

lukeiamyourfather
August 21st, 2010, 05:12 AM
If the camera is Video4Linux 2 capable then it should show up in /dev as video0, video1, etc. If you don't see any video items in /dev then the camera might not work with Linux. In a terminal run this to see what's in /dev.


ls /dev | grep video

riprydah
August 21st, 2010, 05:18 AM
I entered that code and had no result. Guess it's not compatible w/ Linux then?

Any other suggestions or should I call it quits in trying to resolve this issue? Thanks!

lukeiamyourfather
August 22nd, 2010, 08:38 AM
I entered that code and had no result. Guess it's not compatible w/ Linux then?

Any other suggestions or should I call it quits in trying to resolve this issue? Thanks!

As far as I know that's the end of the road for it. Either look for a camera that uses that API or just don't use a camera.

http://www.ideasonboard.org/uvc/

Note there are some cameras that will work that are not on that list, but the list is a good starting place.

Lucky2BeHere
November 18th, 2011, 07:31 PM
I'd like to know if there are any updates on camera and mic support for the Hannspree SN10E2. I'm running 11.04 Natty and neither works. Just trying to get Skype in order!

Lucky2BeHere
November 18th, 2011, 08:06 PM
Am upgrading to 11.10 today. Will see if that helps. The notes claim plug-and-play with cameras...