PDA

View Full Version : [ubuntu] Zabbix email notification



Thyagaraj
August 19th, 2010, 12:37 PM
I've installed zabbix monitoring tool of ver 1.6.x. I got stuck with configuring email notification that notifies to my gmail account and I have only postfix installed.
Plz could anyone help giving step by step guide to sort out this issue.

Thanks all!

Thyagaraj
September 6th, 2010, 10:34 AM
I've installed zabbix version 1.8.3. The following media settings worked fine on my local machine and got mail notification. But the same settings failed on real servers.

Here is my zabbix media settings

Media
Description:
Type E-mail
SMTP server: localhost
SMTP helo: localhost
SMTP email: zabbix@localhost


Zabbix E-mail notification error(audit->actions):

Cannot connect to SMTP server [localhost] [gethost() failed for address 'localhost' [Success]]
http://www.zabbix.com/forum/images/misc/progress.gif

Thyagaraj
September 8th, 2010, 07:26 AM
Here are my settings.


/etc/hosts:

127.0.0.1 localhost.localdomain localhost
<my-ip-here> station1.lab.mycompany.com station1



/etc/zabbix/zabbix_agentd.conf:

# Default:
# Server=

Server=127.0.0.1

### Option: Hostname
# Unique, case sensitive hostname.
# Required for active checks and must match hostname as configured on the server.
#
# Default:
# Hostname=system.uname

Hostname=Zabbix server

### Option: ListenPort
# Agent will listen on this port for connections from the server.
#
# Mandatory: no
# Range: 1024-32767
# Default:
# ListenPort=10050



/etc/zabbix/zabbix_agent.conf:

# This is a config file for zabbix_agent
# To get more information about Zabbix visit http://www.zabbix.com (http://www.zabbix.com/)

### Option: Server
# IP address of Zabbix server
# Connections from other hosts will be denied
# If IPv6 support is enabled then '127.0.0.1', '::127.0.0.1', '::ffff:127.0.0.1' are treated equally.
#
# Mandatory: yes
# Default:
# Server=

Server=127.0.0.1

### Option: Timeout
# Spend no more than Timeout seconds on processing
#
# Mandatory: no
# Range: 1-30
# Default:
# Timeout=3




Hostname:
root@station1:~#hostname
station1.lab.mycompany.com

Thyagaraj
September 13th, 2010, 05:42 AM
Any tricks or tips from any one.

Thyagaraj
September 14th, 2010, 01:31 PM
logs of /var/log/mail.log

Sep 14 05:46:32 station1 postfix/smtpd[490]: connect from localhost.localdomain[127.0.0.1]
Sep 14 05:46:32 station1 postfix/smtpd[490]: disconnect from localhost.localdomain[127.0.0.1]
Sep 14 05:47:31 station1 postfix/smtpd[490]: connect from localhost.localdomain[127.0.0.1]
Sep 14 05:47:31 station1 postfix/smtpd[490]: disconnect from localhost.localdomain[127.0.0.1]
Sep 14 05:48:31 station1 postfix/smtpd[490]: connect from localhost.localdomain[127.0.0.1]
Sep 14 05:48:31 station1 postfix/smtpd[490]: disconnect from localhost.localdomain[127.0.0.1]



Please any help:cry:

Thyagaraj
September 16th, 2010, 01:17 PM
Some how I got it working):P