View Full Version : [ubuntu] Can't Boot or even load Ubuntu Dell Latitude 10.04

August 13th, 2010, 02:26 PM
Got a free CD with Ubuntu on it using the Ship-it.

The disc is fine I have installed using the CD on an Acer Laptop without any trouble what so ever. However now I need to install it on a Dell Latitude D505.

It was detected and started the disc and show Ubuntu with the five dots loading screen. And then it goes black, with the laptop on. The menu with options like Install, defect test etc. can't be seen.

In response to this I installed it inside Windows and that seemed to be ok, so I restarted the laptop and selected Ubuntu from the boot menu and does the dot loading screen and then black.

I have searched Google and it is just threads that end up dead. I know I should take a hint, but is there any solution?

Cheers in advance. :KS

August 13th, 2010, 02:35 PM
please post the specs. for the Dell Latitude D505, especially the graphics card.

August 13th, 2010, 03:07 PM
Intel 82852/82855 GM/GME Grpahics Controller.
40 GB Hard Drive.

August 13th, 2010, 03:38 PM
Intel 82852/82855 GM/GME Grpahics Controller

Take a look here for possible fixes/workarounds:


To get you started:

Hope this helps.

August 13th, 2010, 04:00 PM
Thanks, but I can't even get into a log menu, let alone get into Terminal.

Thanks again.

August 13th, 2010, 04:07 PM
Maybe you're cd is damaged. Try it in another computer to see if it works there.

August 13th, 2010, 04:27 PM
The CD is fine. Tried the i915.modeset=1 and done a lot of CLI inits.

It's a puzzling one, might just stick with Acers, if there is no fix.

August 14th, 2010, 02:01 PM
Exactly the same problem here.

Dell Latitude D505, gets to the dot loading screen, then just blank screen. Left it for ages but nothing.

Tried netbook version & full desktop version, multiple copies, both usb & cd.

August 16th, 2010, 06:38 PM
I'm having exactly the same problem: dell latitude D505, 1.25GB RAM. After the dot screen, something flashes very briefly and then - nothing. Says the display adapter is an Intel 82852/82855 GM/GME. Using 10.4 from an USB thumb drive.

September 2nd, 2010, 08:39 PM
I don't use it as my main laptop (by far not), I got in 2nd hand anyway, my proof adds to my theory that no one should ever by a Dell or Fujisu Simens computers.

September 6th, 2010, 12:22 PM
I tried to install Ubuntu Netbook 10.04 on my Dell Latitude D505 and had the same problem with a blank screen after a short while. Using the i915.modeset=1 boot option worked for me though and I now have a working system. (My next problem is getting DVDs to play as X seems to crash - still investigating this one).

September 7th, 2010, 08:13 AM
Update: For anyone interested, I have found that reverting back to kernel version 2.6.31 has fixed my being unable to play DVDs.