PDA

View Full Version : [ubuntu] Toshiba laptop speakers not working



noseshark
August 4th, 2010, 03:09 AM
I just installed Ubuntu 10.4 on my old Toshiba Satellite A20 (PSA20C - 0C04D).
My speakers or headphones are not working :( I checked all the volume controls ect. everything is on.
I googled how to try to fix it but none of it made sence to me :/
I just want to listen to some music,

Please help.
thanks.

wesleybailey
August 4th, 2010, 03:31 AM
I did a search for your laptop and could not find the actual hardware it uses PSA20C-0C04D (http://www.toshiba.ca/web/product.grp?lg=en&section=1&group=223&product=1912&part=1992#spectop)

All it mentions is this
Stereo speakers, Full duplex 16bit stereo. Direct 3D sound. External mic and headphone port. Line-in, Volume Control dial.

The first thing I would do to troubleshoot audio, is ensure that the audio card is being picked up.

In a terminal excute this command.

lspci

That will list that hardware that is recognized, ensure that something in that list mentions audio.

If you have an audio device listed there, then try playing around with alsamixer

sudo alsamixer

This program allows you to check the various audio sources and outputs.
1. Check if the sliders are all the way up.
2. Make sure all of the channels are unmuted (00) <- should be highlighted green.

Let me know

Wes

noseshark
August 4th, 2010, 04:02 AM
some are muted :O
How do I unmute them?
I am pressing the up key but it still says MM

edit: I figured out to press M, but now they are all unmuted,all turned up and its still not working :(

beesyell
July 10th, 2011, 06:48 AM
Hi, my speakers aren't working as well but I can hear sounds when I use headphones/earphones. I have followed every instruction for the alsa mixer. all the sliders are up and there's a 00 highlighted in green above the <Master>. But still the speakers aren't working. :( What do you think is happening here? :(