PDA

View Full Version : [ubuntu] Nvidia Twinview and games.



Nocturnus
July 12th, 2010, 03:05 PM
I know this has to do with something in my xorg.conf file. Primary screen is running 1920x1080, secondary is 1280x960. When I try to load World of Warcraft via Wine, it loads the game with a resolution of 3200x1080 on my primary screen only. Going to video config inside the game it lists 3200x1080 as my only resolution. I did see that there were some flags you could pass to WOW via command line, and I tried those to change the screen size but didn't work.

I am running Ubuntu 10.04. Thanks for any help.


My xorg.conf file

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@yellow) Fri Apr 9 11:51:21 UTC 2010


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "ViewSonic PS775-2"
HorizSync 30.0 - 95.0
VertRefresh 50.0 - 180.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Acer X233H"
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 76.0
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8800 GTS"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8800 GTS"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT: 1280x960 +1920+0, DFP: nvidia-auto-select +0+0"
# Removed Option "TwinView" "1"
# Removed Option "metamodes" "CRT: 1280x960 +1920+0, DFP: 1920x1080 +0+0"
# Removed Option "TwinView" "0"
# Removed Option "metamodes" "CRT: 1280x960 +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinViewXineramaInfoOrder" "DFP-1"
Option "TwinView" "1"
Option "metamodes" "CRT: 1280x960 +1920+0, DFP: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "DFP-1"
Option "metamodes" "DFP: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

dakkar9999
July 12th, 2010, 04:23 PM
I'm also experiencing difficulties with games and twinview. Instead of being onto only one of the screen, it appears half and half and is unplayable (ex. world of goo)

Suggestions?

cj.surrusco
July 12th, 2010, 07:35 PM
I'm also experiencing difficulties with games and twinview. Instead of being onto only one of the screen, it appears half and half and is unplayable (ex. world of goo)

Suggestions?

Same here.

WinterRain
July 12th, 2010, 09:47 PM
As a workaround, I just go to system>administration>nvidia x server settings and temporarily change it so that the second monitor is disabled. Then put it back after playing. This is temporary, so you don't have to hit "save to x configuration file", just hit apply. It only takes a few seconds to do this, and should be no big deal.

Actually, it won't let you save to xorg.conf because you are running nvidia-settings as a regular user, and not root.

cj.surrusco
July 12th, 2010, 10:00 PM
As a workaround, I just go to system>administration>nvidia x server settings and temporarily change it so that the second monitor is disabled. Then put it back after playing. This is temporary, so you don't have to hit "save to x configuration file", just hit apply. It only takes a few seconds to do this, and should be no big deal.

Actually, it won't let you save to xorg.conf because you are running nvidia-settings as a regular user, and not root.

I've done this, but that doesn't really cut it for me. I really want to be able to sill use the other monitor.

Nocturnus
July 14th, 2010, 08:32 PM
I ended up fixing this under Wine. Went to the Wine config, then to Graphics and forced it to 1920x1080. Fired up WOW and the game worked fine and had full access to 2nd monitor. Now I just need to get Steam working.