PDA

View Full Version : [SOLVED] Converting m4a videos with ffmpeg?



mahela007
July 11th, 2010, 03:29 PM
I've seen posts with similar titles on these forums, but I know nothing about the plethora of codes out there and all those thread seem to be way over my head.
I've installed ffmpeg (an unrestricted version) but I can't convert m4a audio files to mp3 audio files. I installed a package called 'libavcodec52' from synaptic because it came up in the search results for 'm4a' and its description said something about m4a and ffmpeg but still no luck..

ron999
July 11th, 2010, 03:58 PM
What command did you use?

mahela007
July 11th, 2010, 03:59 PM
ffmpeg -i inputfile.m4a outputfile.mp3

ron999
July 11th, 2010, 04:36 PM
There's a program named WinFF.
It's a gui for ffmpeg.
Maybe it will be easier to use.

mahela007
July 11th, 2010, 04:42 PM
I wouldn't mind using the command line.. now that I've gotten a bit used to using it on Linux. Why doesn't ffmpeg recognize the m4a format?

mahela007
July 12th, 2010, 02:28 PM
could someone show me the command I should use?

andrew.46
July 13th, 2010, 08:46 AM
Hi mahela,


could someone show me the command I should use?

Can I suggest you first have a quick look at this guide to make sure you have optimised your copy of FFmpeg:

HOWTO: Easily enable MP3, MPEG4, AAC, and other restricted encoding in FFmpeg
http://ubuntuforums.org/showthread.php?t=1117283

and once you have followed Fakeoutdoorsman's advice could you post the full command you have used and the full terminal output produced by FFmpeg?

All the best,

Andrew

shantiq
July 13th, 2010, 09:24 AM
soundconverter in your synaptic does m4a to mp3

info on command line here (http://ubuntuforums.org/showthread.php?t=1500430)

mahela007
July 13th, 2010, 09:47 AM
Hi mahela,



Can I suggest you first have a quick look at this guide to make sure you have optimised your copy of FFmpeg:

HOWTO: Easily enable MP3, MPEG4, AAC, and other restricted encoding in FFmpeg
http://ubuntuforums.org/showthread.php?t=1117283

and once you have followed Fakeoutdoorsman's advice could you post the full command you have used and the full terminal output produced by FFmpeg?

All the best,

Andrew
I followed that guide to set up ffmpeg. I chose to enable the medibuntu repository and installed the libavcodec-extra-52 package. I didn't use the 'huge' command provided in that post. Instead, I manually added the medibuntu repository, updated the package list and then installed the required package.

Unfortunately, I uninstalled ffmpeg on my desktop because I wanted to try an build it myself so I can't post the exact output of ffmpeg.

However, I'd still like to know why it didn't work.

Here is the exact command I used to try to convert the file

ffmpeg -i inputfile.m4a outputfile.mp3
Ofcourse, I did this from inside the same directory that had my audio files.

The output wasn't that long.. on the last line it said 'unknown format....'

PS:
Andrew, your avatar looks remarkably like the logo of the kingfisher group.. ;-)

andrew.46
July 13th, 2010, 11:22 AM
Hi mahela,


Unfortunately, I uninstalled ffmpeg on my desktop because I wanted to try an build it myself so I can't post the exact output of ffmpeg.

However, I'd still like to know why it didn't work.

Unfortunately the best way to give you some guidance is to see the complete and uncut FFmpeg output. This gives information about the version and makeup of the copy you are using as well as details of the codecs of the input file and any errors while transcoding...

Andrew

mahela007
July 13th, 2010, 11:35 AM
Oops.. Well, then, I'll install is back the same way and see if I still have the problem and post back.

mahela007
July 23rd, 2010, 11:42 AM
Reinstalled ffmpeg and this cleared up the problem.