PDA

View Full Version : [ubuntu] Upgrading Mesa Software Rasterizer



biubidboy
July 9th, 2010, 10:56 AM
Hello all.
Having upgraded to the most recent Wine (1.2-rc6), I have discovered that I can no longer run games in 16bpp. Whenever I do, I get the following error:


X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 1 (X_CreateWindow)
Serial number of failed request: 1067
Current serial number in output stream: 1071I have read that, in most cases, re-installing or upgrading video drivers fixes this problem. I, however, am using the Mesa software drivers included with Ubuntu by default. Would upgrading my installation of Mesa help me out and, if so, how would I go about doing this?

Thanks,
Michael.

biubidboy
July 12th, 2010, 12:07 PM
Bump (sorry guys, but it would be really great to find a solution)

Temüjin
July 13th, 2010, 02:53 AM
It would be helpful to post your /var/log/Xorg.0.log and /etc/X11/xorg.conf (if you have one).

biubidboy
July 14th, 2010, 05:03 PM
Hi.
Because I have no xorg.conf file, I usually use "startx -- :1 -depth 16" to use games that require 16bpp. Would you like me to post my "Xorg.1.log" file rather than "Xorg.0.log"?
Thank you
Michael.