PDA

View Full Version : [ubuntu] TOR + Polipo = Connection refused



TabbyB
July 2nd, 2010, 10:05 PM
I have never set up a proxy before. I'm brand new to Ubuntu. I am trying to use Polipo and TOR withe Firefox.
I am running Ubuntu 10.04 with Firefox 3.6.6.
I have installed TOR and Polipo and set them up per http://www.torproject.org/docs/debian.html.en

Whenever I try to use TOR, thru torbutton in Firefox I get the following error when trying to visit a website:

504 Connect to www.somewebsite.com:80 failed: Connection refused
The following error occurred while trying to access http://www.somewebsite.com/:
504 Connect to www.somewebsite.com:80 failed: Connection refused
___________________________________

Generated Fri, 02 Jul 2010 14:45:00 by Polipo on localhost:8118


I've done a little tinkering and reading FAQs for a few hours but I'm at a loss. Any guidance on how to get TOR + Polipo up and running would be appreciated. Thanks!

mkvnmtr
July 2nd, 2010, 10:28 PM
I seem to remember that I had to restart to get everything to work.

TabbyB
July 2nd, 2010, 11:49 PM
thanks, reboot, system power down/up, log off and back on....all with no luck.

bodhi.zazen
July 3rd, 2010, 12:01 AM
thanks, reboot, system power down/up, log off and back on....all with no luck.

I can not determin the problem from what you posted.

Is polipo running ?

How did you configure polipo ?

Honestly, the easiest way to "install" TOR, IMO, is to use the bundle:

http://www.torproject.org/torbrowser/

Download the lniux bundle. It is sweet =)

stevenwscott
June 12th, 2011, 02:42 AM
If you built/installed TOR manually, you need to start it manually or put it in the system startup ssequence/rc list.
just run tor to get it going.