PDA

View Full Version : [SOLVED] Rhythmbox Desktop Art Plugin error on boot



cement_head
July 2nd, 2010, 05:36 PM
Hello,

I'm using the desktop art plugin in rhythymbox, which requires compiz. Every time I boot (or login), I get an error that says, "You are not running under a composited desktop-environment. The Desktop Art Plugin cannot work without one."

The problem is that rhythmbox is starting before compiz loads. How can I delay the start of rhythmbox?

Thanks,
CH

P.S. I tried delay scripts and they don't (didn't) work.

stinkeye
July 2nd, 2010, 05:49 PM
Hello,

I'm using the desktop art plugin in rhythymbox, which requires compiz. Every time I boot (or login), I get an error that says, "You are not running under a composited desktop-environment. The Desktop Art Plugin cannot work without one."

The problem is that rhythmbox is starting before compiz loads. How can I delay the start of rhythmbox?

Thanks,
CH

P.S. I tried delay scripts and they don't (didn't) work.


Save this as start_rhythmbox. You must enable the Dbus plugin in ccsm.

#! /bin/bash
until [ "$done" = "true" ]
do
if [ $(dbus-send --print-reply --type=method_call --dest=org.freedesktop.compiz /org/freedesktop/compiz/dbus/screen0 org.freedesktop.compiz.list | wc -l) != 0 ]
then
DISPLAY=:0.0 rhythmbox >/dev/null 2>&1 &


done="true";
else
echo "rhythmbox is waiting"
done="false"
sleep 5;
fi
done
exit 0
Make executable...right click >properties > permissions > execute
Link to it as the command in startup applications.
This will check for compiz and won't start rhythmbox until compiz is loaded.

cement_head
July 2nd, 2010, 10:48 PM
@stinkeye

Thanks! That did it. Love the signature, how'd you do the upside down writing?

- CH

stinkeye
July 3rd, 2010, 10:01 AM
@stinkeye

Thanks! That did it. Love the signature, how'd you do the upside down writing?

- CH

No problem. Numerous sites will flip text.
Eg http://www.fliptext.org/
http://img821.imageshack.us/img821/2325/eek1.png

TheDexter1111
September 29th, 2010, 01:19 PM
hey guys, sorry to revive this thread.. but i got the same problem but that script didnt work for me...

i'M running Ubuntu 10.04 with compiz

I even stopped rhythmbox from auto starting altogether but still messes around with my DE.

here is my thread http://ubuntuforums.org/showthread.php?p=9903445#post9903445

cement_head
October 5th, 2011, 02:06 AM
Hi,

You're implementing the script incorrectly.:

Here's how to use the script:

1) Download the script and make it executable.

2) Put it in your home directory. I called it ".rhythmbox_check.sh"

3) Close rhythmbox

4) System>Preferences>Startup Applications. Choose the "Options tab". Uncheck the "Automatically remember running applications when logging out". Then click on the "Remember Currently Running Application"

5) Go back to the Startup Programs TAB.

6) Make a new entry. Call it "Rhythmbox Start check" or anything that makes sense to you. For the Command, browse to your ".rhythmbox_check.sh" script. Save & close

Logout and this should work.

- CH :guitar: