PDA

View Full Version : [ubuntu] Jack refuses to start



dragonfrog
June 17th, 2010, 11:57 PM
When I start QJackctl in Lucid, I get an error message advising me to make changes that are, in fact, already in place.

The messages I get from Jackctl are:


16:36:44.188 JACK is starting...
16:36:44.188 /usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2
16:36:44.223 JACK was started with PID=5056.
16:36:44.229 JACK was stopped with exit status=255.
16:36:44.229 Post-shutdown script...
16:36:44.230 killall jackd
jackd 0.118.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK is running in realtime mode, but you are not allowed to use realtime scheduling.
Please check your /etc/security/limits.conf for the following lines
and correct/add them:
@audio - rtprio 100
@audio - nice -10
After applying these changes, please re-login in order for them to take effect.
You don't appear to have a sane system configuration. It is very likely that you
encounter xruns. Please apply all the above mentioned changes and start jack again!
jackd: no process found
16:36:44.639 Post-shutdown script terminated with exit status=256.
So, having a look at /etc/security/limits.d/audio.conf, we see:


# generated by jackd's postinst.
#
# Do not edit this file by hand, use
#
# dpkg-reconfigure -p high jackd
#
# instead.
@audio - rtprio 99
@audio - memlock 764384
@audio - nice -10(The last two lines were initially present in the file as:
@audio - memlock unlimited
#@audio - nice -19

but I've since changed them in attempting to find a workaround to the problem.

Any help greatly appreciated, thanks!

ivankaramazov
June 18th, 2010, 08:04 AM
is your account part of the @audio group?

- go to system/administration
- choose users settings
- click manage groups button (bottom right)
- select audio from the list in window that just opened. click proprieties and make sure you are checked off

if this doesn't work.

open terminal

type: whoami
this will give your user name

type: sudo gedit /etc/security/limits.conf
this opens up the file in question. sudo is necessary because you need root privileges to save

change @audio to your user name. here's what my lines look like

ivan - rtprio 99
ivan - memlock unlimited
ivan - nice -10

of course, you would not use ivan but your user name (remember the whoami command).

also, watch this video -- it's something that i found helpful.

http://www.youtube.com/watch?v=w2gPqH6kNJU

you could stop reading here, the rest is just other stuff to think about ...

according the video, he claims that you do not need the linux-rt package (which is the realtime kernel) to for realtime. it should work with the newer generic kernels according to this video. anyway, i'm still toying with the 2.6.32-22 generic vs linux-rt idea. if someone's got more insight on this, let me know. if you decide to download the linux-rt package, you will need to install startup manager to switch back and forth between kernels.

now jack, its another can of worms i'm trying to crack. the promises of jack are very appealing. i like being able to wire an application to another application, i don't like all the buffer underflows it keeps giving me -- really configuring jack, that's next week's headache :)

side note: if you're wanting to set up sound in rosegarden. timidity works well without jack. as does zynaddsubfx, but zynadd is its own synth, and does not use the general midi patch set.

cchhrriiss121212
June 18th, 2010, 09:13 AM
according the video, he claims that you do not need the linux-rt package (which is the realtime kernel) to for realtime. it should work with the newer generic kernels according to this video. anyway, i'm still toying with the 2.6.32-22 generic vs linux-rt idea. if someone's got more insight on this, let me know. if you decide to download the linux-rt package, you will need to install startup manager to switch back and forth between kernels.
This is correct about the rt jack issue. In my own experience it is still worth using the rt kernel, as it gives greater stability and allows me to cut my latency by about 5ms. You also do not need to switch back and forth between rt and generic, if the system works with the rt then you can use it all the time for everything.

AutoStatic
June 18th, 2010, 01:57 PM
type: sudo gedit /etc/security/limits.conf
this opens up the file in question. sudo is necessary because you need root privileges to saveFYI: in 10.04 you should configure your realtime priorities in /etc/security/limits.d/audio.conf and not in /etc/security/limits.conf.

ivankaramazov
June 20th, 2010, 01:39 AM
@dragonfrog
i had to make a modification to my limits.conf file. i upped the realtime priority to 100, and changed memlock to a number suggested by jack's message box.

ivan - rtprio 100
ivan - memlock 757170
ivan - nice -10

jack didn't care for the 'memlock unlimited' setting i had before

@autostatic
odd, i run lucid and my /etc/security/limits.d directory is empty. mind you, i setup the realtime parameters before i installed jack. perhaps the package manager didn't create the file because the parameters were already set.

@bootsy/chris
i'm noticing the realtime kernel makes quite a difference when i use my electric piano. do you get the mount: mounting none on /dev failed: No such device message? it occurs when the screen is still in 80x24 textmode, before it switches to hi-res.

cchhrriiss121212
June 20th, 2010, 12:08 PM
Yes I do get that error when I use the rt kernel in karmic, but so far (3 months of use) it has not caused me any issues.

AutoStatic
June 22nd, 2010, 09:43 AM
@autostatic
odd, i run lucid and my /etc/security/limits.d directory is empty. mind you, i setup the realtime parameters before i installed jack. perhaps the package manager didn't create the file because the parameters were already set.Could be, haven't checked the debconf scripts of the jackd packages in depth.

dragonfrog
June 24th, 2010, 06:58 PM
I was already in the audio group, so that shouldn't have been the issue.

Ivan, I took your suggestion and added the permissions for my account specifically, directly to limits.conf rather than limits.d/audio.conf, and I also installed the RT kernel. Jack is working fine now.

Which of those three things made the difference, I don't know, and I guess I might try to roll the changes back one at a time until Jack fails again, but for now I'm happy!

Thanks for your help everyone.