PDA

View Full Version : [ubuntu] Keyboard layout switching problem with vaio



feedbee
June 11th, 2010, 07:27 PM
I set my system to switch KB layout with Alt+Shift combination.

But in reality I press Shift button before Alt. And with my Sony Vaio VPCEB1S1E no action happens after Shift+Alt was pressed. In case of Alt+Shift (Alt pressed before Shift) layout switches correctly.

Is any way to get Shift+Alt working properly?

simosx
June 12th, 2010, 05:43 PM
I set my system to switch KB layout with Alt+Shift combination.

But in reality I press Shift button before Alt. And with my Sony Vaio VPCEB1S1E no action happens after Shift+Alt was pressed. In case of Alt+Shift (Alt pressed before Shift) layout switches correctly.

Is any way to get Shift+Alt working properly?

Both Shift+Alt and Alt+Shift should work. I just verified.
There might be something different with your settings.
Could you run the following in a terminal window and report back?

gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

feedbee
June 13th, 2010, 04:34 PM
$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
layouts = [us,ru]
options = [grp grp:alts_toggle,grp grp:alt_shift_toggle,grp grp:lwin_toggle,grp grp:rwin_toggle,lv3 lv3:ralt_switch,compat misc:typo,keypad keypad:oss,terminate terminate:ctrl_alt_bksp]
model = pc105

Both combinations works well on my second laptop (HP). But not on Vaio. By the way, both combinations works well on the same (Vaio) laptop in Windows.

Thanks for trying to help.

simosx
June 14th, 2010, 09:35 AM
$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
layouts = [us,ru]
options = [grp grp:alts_toggle,grp grp:alt_shift_toggle,grp grp:lwin_toggle,grp grp:rwin_toggle,lv3 lv3:ralt_switch,compat misc:typo,keypad keypad:oss,terminate terminate:ctrl_alt_bksp]
model = pc105

Both combinations works well on my second laptop (HP). But not on Vaio. By the way, both combinations works well on the same (Vaio) laptop in Windows.


What I see is that you have quite a few things enabled in the 'options':
options = [grp grp:alts_toggle,grp grp:alt_shift_toggle,grp grp:lwin_toggle,grp grp:rwin_toggle,lv3 lv3:ralt_switch,compat misc:typo,keypad keypad:oss,terminate terminate:ctrl_alt_bksp]

The proper setting for Alt+Shift switching layouts is 'grp:alt_shift_toggle'. In your case you have 'grp:alt_shift_toggle,grp' with a ',grp' appended. In addition, you have 'grp:alts_toggle,grp' which is 'Both Alt keys switch layout'. These two may conflict.

I suggest that you start over with the Layout Options, with initial settings:


layouts = [us,ru]
options = [grp grp:alt_shift_toggle]
model = pc105


Then, you can add one by one those additional settings you have until to find which new setting messed up with Alt+Shift/Shift+Alt. When you set a shortcut in Layout Options and click Close, the setting is enabled at once so you can run 'gconftool-2' to verify and press keys to check.

feedbee
June 14th, 2010, 06:23 PM
Big thanks! You was right: "Both ALT keys" and "Alt+Shift" keys are incompatible. My problem was gone when I disabled "Both ALT keys" combination.