PDA

View Full Version : [ubuntu] No proprietary drivers are in use on this system



geko6
June 9th, 2010, 09:56 AM
When I go to System | Administration | Hardware Drivers I get the message "No proprietary drivers are in use on this system". I noticed on this thread http://www.uluga.ubuntuforums.org/showthread.php?t=1291058 that others have solved this problem by installing nvidia-modaliases. However, I already have installed (at least it shows in Synaptic Package Manager) nvidia-173-modaliases. But I still get the "No proprietary drivers" message.

I'm runnning Ubuntu 10.4 (64 bit) on an Acer Aspire 5720. I believe it has the Intel GM965 chipset.

TechnikAlsace
June 9th, 2010, 11:40 AM
If you have an Intel graphics chipset, the drivers/modules are intgrated in the kernel. So there is NO need for aliases and proprietary drivers and you can be happy.

Proprietary drivers are only required where the "community drivers" are not sufficient or if the vendor of a component made drivers especially for linux.

As long as you have kernel support for all your system components just rejoice!

geko6
June 13th, 2010, 04:14 AM
Thanks TechnikAlsace. I understand now that this screen does not show Kernel integrated drivers. Do you know if there's a way to view ALL drivers (whether integrated in the kernel or not)?

LoloftheRings
June 13th, 2010, 01:21 PM
Go to terminal and enter:


lsmod

This wil show the drives loaded on the right column.