PDA

View Full Version : [SOLVED] HP Deskjet 3420 problems



Ad1217
June 7th, 2010, 12:44 AM
I am having problems with a four year old hp deskjet 3420 I just got second hand. The printer goes through all of the motions of printing(the print heads move and the paper feeds), but no ink comes out. I am using the HPLIP driver/application. Am I doing something wrong or is the printer broken/too old?

Midnighter
June 7th, 2010, 08:57 AM
Don't feel alone, I've seen multiple threads of similar topic. I have a HP deskjet 1660 that worked fine under previous versions, and is working fine under Fedora 13 right now. Ubuntu saw the printer, and set it up fine, but any attempt to print to it results ion nothing printing, tho the print queue suggests it has been printed. Something is not working in this release thatb was before.

Very annoying, finally got my housemate to accept linux (Ubuntu), had her on Mint 8 previously, but the wireless broadband connection would not always connect properly, but works fine in new version, and in ubuntu 10.04 (same base, so expected), but for same reason, printer not working under either. She went and bought the same printer asd me since i told her mine worked flawlessly, now I look like a knob as it does nothing of the kind, at least not anymore.

Just about everything else seems fine, but printing is broken somewhere, and none of the threads I've researched have proven fruitful. Most seem to be pretending it doesn't happen is what i'm beginning to think. **** like this is what makes it hard to get others to take linux seriously. And before some clown whines "But it's free, so you can't complain!", yes, it I can complain. Just as many of you do that more people don't use linux. And this **** is why. FFS. I use linux 95%+ of the time, prefer it, but backwards steps like this will NOT be tolerated by those that just want something to work. :(

Ad1217
June 18th, 2010, 04:12 PM
I have used a Windows computer to determine that the linux driver is the one at fault, but I do not know how to resolve the issue.

spaceshipguy
June 21st, 2010, 09:22 PM
This worked for me --> http://ubuntuforums.org/showthread.php?t=1467179
Took a while for the HP app to download and overwrite my old setup though.

Ad1217
June 23rd, 2010, 08:26 PM
I just tried that twice with the same results... No errors are shown, but the ink still does not come out.

Ad1217
October 26th, 2010, 02:16 PM
Yay! after updating to 10.10, my printer works!

Ad1217
December 2nd, 2010, 10:49 PM
However, this printer is horrible... it just recently broke on me..... there is a little flimsy plastic piece that breaks... rendering the whole printer junk...:( However, it was nice while it lasted!;)