PDA

View Full Version : [ubuntu] horrible screen tearing?



insanity99
June 3rd, 2010, 07:45 PM
i have a radeon HD4870 and use the proprietary drivers, i also but windows manager on metacity put the screen tearing while watching videos is unbearable, is there anything i can do?

insanity99
June 3rd, 2010, 10:45 PM
bump

rizzeh
June 3rd, 2010, 11:51 PM
nvidia video drivers have Vsync for video playback option, it usually helps with tearing, have a look in ati drivers for a similar option.

insanity99
June 4th, 2010, 12:32 AM
all i can see is V-Sync for 3D apps.

rizzeh
June 4th, 2010, 01:02 AM
have you tried this?

sudo aticonfig --sync-video=on

insanity99
June 4th, 2010, 09:41 AM
sorry i really suck with terminal currently, i am reading a book now though.

i got this error


neil@neil-desktop:~$ sudo aticonfig --sync-video=on
No layout section was found in the file: '/etc/X11/xorg.conf'.
Please run 'aticonfig --initial' first or modify your configurationfile manually and run aticonfig again.
aticonfig: parsing the command-line failed.
neil@neil-desktop:~$ aticonfig --initial
Found fglrx primary device section
Unable to find any supported Screen sections
neil@neil-desktop:~$

rizzeh
June 4th, 2010, 07:02 PM
i haven't got an ati card to test out commands, try

sudo aticonfig --initial -f

sixstringmonk
June 4th, 2010, 07:11 PM
I've got this issue too with a 5850. It seems like vsync is off on 2d rendering. I've successfully run both console commands mentioned in this thread, but it did not fix the problem.

rizzeh
June 4th, 2010, 07:31 PM
sorry, without ati card i can't test much, but quick google search brings few hits -like this (http://thelinuxexperiment.com/guinea-pigs/tyler-b/fix-ati-vsync-video-tearing-issue-once-and-for-all/):
sudo aticonfig –sync-video=on –vs=on

personally i buy nvidia cards only cuz thier drivers in linux are good... or errm, better than ati's... not perfect though.

emergence
June 5th, 2010, 08:59 AM
It seems VSync is off in the catalyst drivers. This looks like a bug! I'm also experiencing tearing with HD5850.

Here's something you can try:
In compiz setting manager, enable the benchmark plugin and uncheck "Disable limiter". Does that fix tearing? It did for me. Of course, I don't want a benchmarking tool running all the time... but proves that VSync is not working.

insanity99
June 5th, 2010, 10:32 AM
It seems VSync is off in the catalyst drivers. This looks like a bug! I'm also experiencing tearing with HD5850.

Here's something you can try:
In compiz setting manager, enable the benchmark plugin and uncheck "Disable limiter". Does that fix tearing? It did for me. Of course, I don't want a benchmarking tool running all the time... but proves that VSync is not working.


hey that did fix it thanks, only problem is theres a huge FPS counter in the way of the videos, is there a way to disable this? then im all set.

emergence
June 5th, 2010, 12:20 PM
Yes, in the same window, uncheck Enable under Screen Output. But you really don't want to do this. I don't want to do this.

What does this tell us about the issue?

Who is responsible to fix this? Ubuntu, Compiz, ATI?

Is there another option we can play with to perform the same effect?

VSync in the ATI settings and in the Compiz settings do not help... Someone please help us!

insanity99
June 5th, 2010, 12:55 PM
it's a real annoyance, i just managed to convince my brother linux is better than windows when he realises he cant even watch videos because the screen tearing is so awful.

i dont care whose fault it is but this is holding Linux back a lot and needs to be fixed

robincawser
July 22nd, 2010, 06:08 PM
Who is responsible to fix this? Ubuntu, Compiz, ATI?

Is there another option we can play with to perform the same effect?

VSync in the ATI settings and in the Compiz settings do not help... Someone please help us!

I want to bring this thread back to life. I have a 5850 and ubuntu is suffering from tearing on the desktop and in videos.

Surely if we can get vsync working using CCSM by enabling benchmarking then there must be a setting/ conf file that we could change to enable vsync all the time?

Maybe the next ati driver will sort us out.

step5
August 26th, 2010, 07:29 PM
still same effect here using catalyst 10.8 driver

must be a compiz bug

i'm not the best in searching bugtrackers, maybe there's a bug report for this problem already // if not may some kind sir put one up :)

step5
August 26th, 2010, 07:51 PM
...

gonintendo
October 12th, 2010, 10:31 PM
bump. same problem with my 5850 on 10.10

Azazel
October 24th, 2010, 06:51 PM
bump. same problem with my 5850 on 10.10

Ubuntu 10.10 or Catalyst 10.10?

I have the FGLRX drivers installed from repositories and am downloading CCC 10.10 from AMD right now to see if it helps

SeePU
October 24th, 2010, 11:35 PM
Ubuntu 10.10 or Catalyst 10.10?

I have the FGLRX drivers installed from repositories and am downloading CCC 10.10 from AMD right now to see if it helpsDoes it? CCC 10.10 on Ubuntu Maverick 10.10 is supposed to be improved or so I've been told (and read).

Of course, you can't use xv-video output yet or there's tearing. You need v-sync on, I think.

Test on: VLC, MPlayer, Kaffeine.... see if there's any differences in performance/output.