PDA

View Full Version : [ubuntu] Enna on 10.04



alrod
May 30th, 2010, 08:25 PM
Hey guys,
I'm running ubuntu 10.04 and I'm wanting to install Enna, but when I try to get it by the Ubuntu Software Center, it gets an error that the sources aren't trustful, I've tried by Synaptic (.deb file) and directly by the terminal, both installed Enna, but when I click on it doesn't open, typing enna on the terminal I get the message:

~$ enna
enna: error while loading shared libraries: libeina-ver-svn-05.so.0: cannot open shared object file: No such file or directory
then I tried:

~$ sudo apt-get install libeina-dev
nothing, then I entered in /usr/lib/ , there I found libeina-ver-pre-svn-05.so.0.9.9, but I can't rename it.
At last I tried to compile the program, but the terminal can't find the make file.


I'm wondering some help, Rodrigo :(

Jeroensum
June 1st, 2010, 12:27 PM
First remove the current enna:
sudo dpkg -r (package name)
If youŕe not sure abount the packagename run:
sudo dpkg -l | grep -i enna

Enna is in the default repositories and those authentication keys should be preinstalled and give you no problems what so ever.
My guess here is that you added the geekbox repositories to your sources.list and didn't add their key (if they have one?).
The easiest way to fix this, is to remove the line you added to your sources.list, run sudo apt-get update and sudo apt-get install enna
This should install enna from the default Ubuntu repo's and work just fine :)

Oh, by the way...
Renaming library files is a bad thing to do. It's better to create a symlink to it with the desired name so other programs can still find the original library by it's rightfull name, if you rename it you might be breaking alot of other stuff ;)

brazz43
June 17th, 2010, 06:39 PM
Elrod hello! Do you have solved your problem, because I have exactly the same, I uninstalled properly as indicated by Jeroensum, but I always exactly the same mistake :mad:

brazz43
June 17th, 2010, 08:11 PM
Ah OK ! In fact, it is also necessary to first remove libeina-ver-svn-05.so.0 and libembryo.so.0 and then reinstall enna, and after everything works ... :p