View Full Version : [ubuntu] USB Drive not found?

May 27th, 2010, 07:44 PM
I've always used a Seagate external drive (USB) for backup of data.

Now, for whatever reason, the drive isn't recognized/found/seen/appear.

For that matter- none of the USB stick memories I connect are recognized either on any of the USB ports I hook them into.

All of the USB stuff works perfectly in Windows.

This hasn't happened before.

Any idea how to fix it?

May 27th, 2010, 11:37 PM

May 28th, 2010, 12:09 AM
Run gparted and see if there are errors on that device.

May 29th, 2010, 03:50 AM
Iḿ having the same problem. But, I can mount my USB if I start my laptop with the usb plugged in. Ive been searching for a solution for the past few hours and not found anything that works. Anybody else have ideas?

May 29th, 2010, 03:53 AM
I fixed it-

Use Synaptic to get USBMOUNT

Now, that fixed the mounting of a USB drive but DISMOUNTING a drive....I haven't figure that out yet. I used to use "safely remove....." but that's not a choice that's available.

May 29th, 2010, 04:17 AM
Look in configuration editor and go to Apps then to nautilus to preferences and then make
sure media_automount is checked.

Mine is install_mime_activation, media_automount,media_automount_open all checked.

At command line: Give your USB drive a label in disk utility or gparted. Lets say it is flash for this. And in "sudo fdisk -l" (that is small L) it is sdb1
Make directory (one time thing)

sudo mkdir /media/flashMount drive

sudo mount /dev/sdb1 /media/flashUnmount not a typo

sudo umount /media/flashAlways have way to mount at command line and unmount at command line.
Makes life easier.
If need configuration editor, will come up under system tools.

sudo apt-get install gconf-editor

May 29th, 2010, 06:44 AM
Now, that fixed the mounting of a USB drive but DISMOUNTING a drive....I haven't figure that out yet. I used to use "safely remove....." but that's not a choice that's available.
Right click on mounted drive....now left click "unmount volume"

May 29th, 2010, 02:14 PM
The "unmount" option available on right click doesn't provide any results.

Here's the error message that's returned-

Unable to unmount usb0

umount: /media/usb0 is not in the fstab (and you are not root)

May 29th, 2010, 03:47 PM
Under System > Administration > Users and Groups, Advanced Settings > User Privileges, does the user you are running as have permission to "Access external storage devices automatically"?

May 29th, 2010, 05:48 PM

June 3rd, 2010, 03:44 AM
I'm still plagued by this one. The crazy thing is that I have two nearly identical laptops. There are only two known differences:
1) one has a newer faster larger hard drive
2) one uses a wireless card and the other a wireless usb

The laptop with the older hard drive uses the wireless usb. The laptop with the newer hard drive and the wireless card (it's older than the usb wireless) is able to consistently mount a usb flash drive.

The "problem" laptop sometimes mounts the flash drive and I will continue to trouble shoot to try to figure out when it works vs. when it won't. Having automount on or off doesn't make a difference. Connecting to the internet using the wireless usb rather than the cable might. I'll try it tomorrow.

Also disabling the non-existing floppy from bios does not make a difference either.

June 3rd, 2010, 11:39 PM

The USB flash drive won't show up if I'm using the USB wireless connection.

Argh :(

At least now I know why...Any ideas on a work around?

June 7th, 2010, 03:56 PM
Threads merged.