PDA

View Full Version : [ubuntu] Black screen after upgrating to 10.04



davoudi
May 26th, 2010, 09:22 PM
So I just upgrate my Ubunutn to 10.04 from 9.10 and it seems I have problem with graphic card. I added div file extracted from windows in the previous Ubuntu release and things were fine but now I have a black screen. This is the output of lspci




lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation GT218 [GeForce 310M] (rev a2) (http://www.futureshop.ca/en-CA/product/-/b9000613.aspx?path=61ea50e77f116b6b0a379bdd8abb533 5en02)



Thanks for you time.

davidmohammed
May 26th, 2010, 09:51 PM
try booting with nomodeset in your grub...

press shift on boot to display grub
press e to edit

add nomodeset before quiet splash

davoudi
May 26th, 2010, 11:13 PM
That is how my grub look like



GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""


So should I add nomodeset to GRUB_CMDLINE_LINUX and then move the line up?

And should I rename xorg file?

davidmohammed
May 26th, 2010, 11:22 PM
in lucid you dont need /etc/X11/xorg.conf for most graphics cards. Suggest rename the file, boot with nomodeset and see if your desktop appears.

Since you have nvidia graphics, there should be some drivers in administrator - hardware drivers to install. Once installed, you will not need to boot with nomodeset.

davoudi
May 26th, 2010, 11:46 PM
My desktop is on now. I run the hardware drivers but it couldn't find any driver! I can install one nVidia driver using SMP if I know the version.

WinRiddance
May 27th, 2010, 12:40 AM
My desktop is on now. I run the hardware drivers but it couldn't find any driver! I can install one nVidia driver using SMP if I know the version.

You might not need any additional drivers if Lucid recognized everything properly. If you right click somewhere on your desktop, click on change desktop background which will open the place where you can change themes and so on. There are some tabs at the very top when you first open that window. Click on the last one to the right, the one for desktop or visual effects. There should be at least 3, possibly 4 different options there on the left. See if you can click on the third one from the top to enable all of your 3D graphic settings. If you can, then all's well and you don't need any other drivers. Hope this helps ...

davoudi
May 27th, 2010, 12:55 AM
You might not need any additional drivers if Lucid recognized everything properly. If you right click somewhere on your desktop, click on change desktop background which will open the place where you can change themes and so on. There are some tabs at the very top when you first open that window. Click on the last one to the right, the one for desktop or visual effects. There should be at least 3, possibly 4 different options there on the left. See if you can click on the third one from the top to enable all of your 3D graphic settings. If you can, then all's well and you don't need any other drivers. Hope this helps ...
I have laready tried that but no luck. I get the following message: Desktop effect could no be enabled.

davoudi
May 28th, 2010, 03:38 AM
I also tried the follwoing solution :http://ubuntuforums.org/showthread.php?t=1467074 but no result.

davoudi
May 29th, 2010, 10:44 PM
Has anybody tried this?: https://launchpad.net/~xorg-edgers/+archive/ppa

davoudi
June 2nd, 2010, 03:10 AM
Solved here: http://ubuntuforums.org/showthread.php?t=1470822