PDA

View Full Version : [ubuntu] [10.04] Can't read from Windows partition



Coh3n
May 24th, 2010, 03:23 PM
Hey guys,

I've already looked around the net for this issue, and asked on IRC, but I've had no luck. I recently updated to 10.04 and ever since, Songbird can't read from my Windows partition (where I store all my music because of iTunes). I also can't download music via Transmission to that partition. I keep getting permission errors.

I would get that error when I had 9.04, but that was always fixed my simply mounting the partition (after entering the correct password). Now, when I go Places > 82GB File System, it mounts the drive without asking for a password. I can browse the files fine, but Songbird/Transmission still don't work.

Also, when I right click on the drive and go to Properties > Permissions it says "Permissions could not be determined", if that helps in any way.

All help is appreciated.

Thanks,
Coh3n

Coh3n
May 24th, 2010, 03:51 PM
Not sure if you're supposed to bump in these forums, but it's better then creating a new thread. ;)

rob-ward
May 24th, 2010, 04:10 PM
is there any reason that you arn't having the partition mounted on boot and are mounting it dynamically??

the problem seems to be that the drive is mounted with the wrong permissions what do you get if you run


sudo fdisk -l

and


mount

Coh3n
May 24th, 2010, 04:15 PM
is there any reason that you arn't having the partition mounted on boot and are mounting it dynamically??

Because I don't know how to set it to mount on boot. :p




sudo fdisk -l


Disk /dev/sda: 250.0 GB, 250000000000 bytes
255 heads, 63 sectors/track, 30394 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x08000000

Device Boot Start End Blocks Id System
/dev/sda1 1 6 48163+ de Dell Utility
/dev/sda2 7 1312 10490445 7 HPFS/NTFS
/dev/sda3 * 1313 11272 80003700 7 HPFS/NTFS
/dev/sda4 11273 30394 153597465 5 Extended
/dev/sda5 11273 29613 147324051 83 Linux
/dev/sda6 29614 30394 6273351 82 Linux swap / Solaris



mount


/dev/sda5 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/cohen/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=cohen)
/dev/sda3 on /media/36127FDB127F9E95_ type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_ permissions)
Not a clue what any of it means.

rob-ward
May 24th, 2010, 04:48 PM
OK, well if you want to make the partition mount on startup(which should also fix your problem of been able to write) there is a guide here http://www.psychocats.net/ubuntu/mountwindows that should take you through the process of making an NTFS partition mount every time and be able to write(the key bit for writing is towards the end of the article as you have to tell it that you want to be able to write files). I've not used this guide before i've always done it through the commandline and manually edited files on the few occasions that I have needed to mount NTFS partitions however that guide seems really easy to follow and will definetly be a better than me writing loads of text [it has pictures :) ].

Coh3n
May 24th, 2010, 04:50 PM
OK, well if you want to make the partition mount on startup(which should also fix your problem of been able to write) there is a guide here http://www.psychocats.net/ubuntu/mountwindows that should take you through the process of making an NTFS partition mount every time and be able to write(the key bit for writing is towards the end of the article as you have to tell it that you want to be able to write files). I've not used this guide before i've always done it through the commandline and manually edited files on the few occasions that I have needed to mount NTFS partitions however that guide seems really easy to follow and will definetly be a better than me writing loads of text [it has pictures :) ].
Haha alright right on. Thanks, I'll try this and edit back when I'm finished.

Coh3n
May 24th, 2010, 06:45 PM
I tried it, but it didn't seem to do anything.

sandyd
May 24th, 2010, 06:49 PM
use ntfs-config (apt:/ntfs-config)
after installing, run


sudo ntfs-config
in the terminal.

oh, and you can just click the link above to install it.

Coh3n
May 24th, 2010, 06:50 PM
use ntfs-config (apt:/ntfs-config)
after installing, run


sudo ntfs-configin the terminal.

oh, and you can just click the link above to install it.
I've done that. It mounts on start up now, but I still get the permissions error. =\

I even checked the box that's suppose to give write access. This was all working just fine before I updated to 10.04, so I don't know if the install may have messed up or what.

sandyd
May 24th, 2010, 06:55 PM
I've done that. It mounts on start up now, but I still get the permissions error. =\

I even checked the box that's suppose to give write access. This was all working just fine before I updated to 10.04, so I don't know if the install may have messed up or what.
can you do


cat /etc/fstab?
Its just a minor change that we need to do to get it writable.

Coh3n
May 24th, 2010, 06:57 PM
can you do


cat /etc/fstab?
Its just a minor change that we need to do to get it writable.


# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
#Entry for /dev/sda5 :
UUID=6c0b777a-eac2-4da4-92bb-f8259e650787 / ext4 errors=remount-ro 0 1
#Entry for /dev/sda3 :
UUID=36127FDB127F9E95 /media/36127FDB127F9E95_ ntfs-3g defaults,nosuid,nodev,locale=en_US.utf8 0 0
#Entry for /dev/sda6 :
UUID=a3813016-40c1-4db7-8868-6fe521fddd29 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

sandyd
May 24th, 2010, 07:04 PM
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
#Entry for /dev/sda5 :
UUID=6c0b777a-eac2-4da4-92bb-f8259e650787 / ext4 errors=remount-ro 0 1
#Entry for /dev/sda3 :
UUID=36127FDB127F9E95 /media/36127FDB127F9E95_ ntfs-3g defaults,nls=utf8,umask=0774 0 0
#Entry for /dev/sda6 :
UUID=a3813016-40c1-4db7-8868-6fe521fddd29 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0Note that you cannot write into a directory that is not your own.
So, try


sudo chmod 777 /media/36127FDB127F9E95_
before replacing your current fstab with the above..

Coh3n
May 24th, 2010, 07:06 PM
Everything on this computer should be mine. =\ I'm the only user.

I ran that, but nothing happened after I entered my password. It just went back the $.

sandyd
May 24th, 2010, 07:08 PM
Everything on this computer should be mine. =\ I'm the only user.
no, by default files belong to the user root (other than the files in your home folder)

I ran that, but nothing happened after I entered my password. It just went back the $.
shouldn't give an ouput, see if it works.

.

Coh3n
May 24th, 2010, 07:10 PM
Nope, didn't work. :(

sandyd
May 24th, 2010, 07:16 PM
Nope, didn't work. :(
alright..
did you restart beforetesting?

if you did, then use this...


# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
#Entry for /dev/sda5 :
UUID=6c0b777a-eac2-4da4-92bb-f8259e650787 / ext4 errors=remount-ro 0 1
#Entry for /dev/sda3 :
UUID=36127FDB127F9E95 /home/your_username_here/windows ntfs-3g defaults,nls=utf8,umask=0222 0 0
#Entry for /dev/sda6 :
UUID=a3813016-40c1-4db7-8868-6fe521fddd29 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
Just create a directory in your home folder called windows, and replace your_username_here with your username

Coh3n
May 24th, 2010, 07:18 PM
alright..
did you restart beforetesting?

if you did, then use this...


# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
#Entry for /dev/sda5 :
UUID=6c0b777a-eac2-4da4-92bb-f8259e650787 / ext4 errors=remount-ro 0 1
#Entry for /dev/sda3 :
UUID=36127FDB127F9E95 /home/your_username_here/windows ntfs-3g defaults,nls=utf8,umask=0222 0 0
#Entry for /dev/sda6 :
UUID=a3813016-40c1-4db7-8868-6fe521fddd29 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0Just create a directory in your home folder called windows, and replace your_username_here with your username
No, I didn't try restarting, but I will first.

Sorry, but what do I do with that? I create a directory, but what am I suppose to do with the text?

rob-ward
May 24th, 2010, 07:21 PM
The quoted text needs to replace what is currently in your /etc/fstab

once you have done that I think you will need to run the command


sudo mount -a

Coh3n
May 24th, 2010, 07:28 PM
The quoted text needs to replace what is currently in your /etc/fstab

once you have done that I think you will need to run the command


sudo mount -a
I couldn't replace the files. It yet again is giving permissions denied errors.

I can't even unmount drives anymore. It says that "only root can unmount". It's saying I can't view the root folder because I don't have permission. Is it possible that my user got completely messed up in the update?

sandyd
May 24th, 2010, 07:48 PM
I couldn't replace the files. It yet again is giving permissions denied errors.

I can't even unmount drives anymore. It says that "only root can unmount". It's saying I can't view the root folder because I don't have permission. Is it possible that my user got completely messed up in the update?
try


gksudo /etc/fstab

and no, by default, you can't unmount unless your root
add "sudo" in front of the command.

the first time, you were running everything with the user "root" which is why you didnd;t have permission problems

Coh3n
May 24th, 2010, 07:54 PM
try


gksudo /etc/fstaband no, by default, you can't unmount unless your root
add "sudo" in front of the command.

the first time, you were running everything with the user "root" which is why you didnd;t have permission problems
Okay, should I try replacing fstab again?

Before, it was always cohen as the user. I've never once seen anything to do with root until I updated yesterday.

E: Still couldn't replace the file.

Coh3n
May 24th, 2010, 08:13 PM
How would I go about running everything as the root user then? If that's what I was doing before, I would like to keep it that way. :D

Coh3n
May 24th, 2010, 08:42 PM
I've tried changing permissions on the drive and on my user, and no luck. :(

rob-ward
May 24th, 2010, 08:44 PM
try

gksudo gedit /etc/fstab

that should open a text editor where you can paste the text that carlee gave you over the stuff that is already there.

Before you do that however it might be an idea to take a copy of the fstab as it stands now, so to do that run


sudo cp /etc/fstab ~/fstab


and it is never a good idea to run as root and it unlikely that you were doing that before. On 9.10 when you mounted the drive you said it asked for a password, this was the OS asking for root permissions to do the mount.

10.04 isn't doing that which is causing you the problems, what we are doing with fstab now is making it automatically mount on startup(essentially root will then be doing this) so it won't ask you for the password ever but will still be writable.

Coh3n
May 24th, 2010, 08:50 PM
try

gksudo gedit /etc/fstab
that should open a text editor where you can paste the text that carlee gave you over the stuff that is already there.

Before you do that however it might be an idea to take a copy of the fstab as it stands now, so to do that run


sudo cp /etc/fstab ~/fstaband it is never a good idea to run as root and it unlikely that you were doing that before. On 9.10 when you mounted the drive you said it asked for a password, this was the OS asking for root permissions to do the mount.

10.04 isn't doing that which is causing you the problems, what we are doing with fstab now is making it automatically mount on startup(essentially root will then be doing this) so it won't ask you for the password ever but will still be writable.
I can't do that because it doesn't allow me to edit the fstab file. I also tried creating a new one to replace the old one and that didn't do anything.

The drive already gets mounted on start up, and I can browse through the files and even copy new mp3 files to Songbird. Actually, I just tested it and I can drag and drop files to and from the drive, so I'm assuming that means I have write access.

The thing is, when I try to play a song in Songbird it says it couldn't open the file. If I recopy the music from the drive then it works, but I don't know how the file path location could have changed with the update.

Also, with Transmission I can't download anything to this drive because it says I don't have permission to do so. Actually, it says it can't even read the drive...

You can probably tell that I'm very confused right now...

E: Okay so I just redefined the path that Transmission saves to. I made it save to the same folder it always does, so I don't know what was wrong with the old path. It also seems that I have to re-copy every song to Songbird. :(

rob-ward
May 24th, 2010, 10:59 PM
I can't do that because it doesn't allow me to edit the fstab file. I also tried creating a new one to replace the old one and that didn't do anything.

The drive already gets mounted on start up, and I can browse through the files and even copy new mp3 files to Songbird. Actually, I just tested it and I can drag and drop files to and from the drive, so I'm assuming that means I have write access.

Yes this means that what we have been doing has worked so you now have access to the drive and it should continue to mount automatically on startup to /home/YOURUSERNAME/windows at least I hope thats what now happens(you can check this my running the command


mount





The thing is, when I try to play a song in Songbird it says it couldn't open the file. If I recopy the music from the drive then it works, but I don't know how the file path location could have changed with the update.

I'm afraid I don't have a lot of experience with songbird however the location will have changed. This is because the directory that the drive is mounted to is now fixed(~/windows) rather than dynamically allocated.

There is however a potential fix.

Earlier in the discussion we found that the drive was mounting to
/media/36127FDB127F9E95_

I believe (I arn't 100% sure) that this will be the place that songbird is expecting your music to be. If this is the case then the following code should make songbird able to see the music


cd /media/

sudo ln -s ~/windows/

sudo mv windows 36127FDB127F9E95_




hopefully(again not tried this and it's not an ideal solution) that should fix the referencing of your music. If not I'm afraid that you will have to re-index all of your music which I agree isn't good especially if you have a lot (although it is the better way if it is simple).





Also, with Transmission I can't download anything to this drive because it says I don't have permission to do so. Actually, it says it can't even read the drive...

You can probably tell that I'm very confused right now...

E: Okay so I just redefined the path that Transmission saves to. I made it save to the same folder it always does, so I don't know what was wrong with the old path. It also seems that I have to re-copy every song to Songbird. :(

Glad you got transmission working as I wouldn't be able to even suggest where to start with that and i'm sorry all of this is confusing, for some reason the mounting obviously changed between 9.10 and 10.04. I'm guessing this is for security and to prevent people damaging windows partitions, this is one of them situations where linux is having to do things to protect windows based OS's which in the wrong situation could be damaged if write permissions were given straight away.

Coh3n
May 24th, 2010, 11:06 PM
Yes this means that what we have been doing has worked so you now have access to the drive and it should continue to mount automatically on startup to /home/YOURUSERNAME/windows at least I hope thats what now happens(you can check this my running the command


mount
Yes, it now mounts automatically. :)



I'm afraid I don't have a lot of experience with songbird however the location will have changed. This is because the directory that the drive is mounted to is now fixed(~/windows) rather than dynamically allocated.

There is however a potential fix.

Earlier in the discussion we found that the drive was mounting to
/media/36127FDB127F9E95_

I believe (I arn't 100% sure) that this will be the place that songbird is expecting your music to be. If this is the case then the following code should make songbird able to see the music


cd /media/

sudo ln -s ~/windows/

sudo mv windows 36127FDB127F9E95_


hopefully(again not tried this and it's not an ideal solution) that should fix the referencing of your music. If not I'm afraid that you will have to re-index all of your music which I agree isn't good especially if you have a lot (although it is the better way if it is simple).

I've already completely re-added all my music. It honestly took about 30 seconds (excluding the time I took to reorganized some misplaced files).



Glad you got transmission working as I wouldn't be able to even suggest where to start with that and i'm sorry all of this is confusing, for some reason the mounting obviously changed between 9.10 and 10.04. I'm guessing this is for security and to prevent people damaging windows partitions, this is one of them situations where linux is having to do things to protect windows based OS's which in the wrong situation could be damaged if write permissions were given straight away.
Well, whatever it was it's working now. :)

Thanks everyone for all the help, I really appreciate it.

sandyd
May 25th, 2010, 12:03 AM
Yes, it now mounts automatically. :)


I've already completely re-added all my music. It honestly took about 30 seconds (excluding the time I took to reorganized some misplaced files).


Well, whatever it was it's working now. :)

Thanks everyone for all the help, I really appreciate it.
:?#-oIm still wondering which of the comands actually made it work...
I had the same problem, but I assumed it was just something due to my fiddling and tinkering around that caused me to have to mount it in my home folder.

In other words, Im creating a very nasty bug report against ntfs-config...

Coh3n
May 25th, 2010, 12:05 AM
:?#-oIm still wondering which of the comands actually made it work...
I had the same problem, but I assumed it was just something due to my fiddling and tinkering around that caused me to have to mount it in my home folder.

In other words, Im creating a very nasty bug report against ntfs-config...
Well the automatic mounting worked after I installed NTFS Configuration Tool. I'm not sure when the rest started working.

sandyd
May 25th, 2010, 12:34 AM
heres the bug: https://bugs.launchpad.net/ntfs-config/+bug/585171

rob-ward
May 25th, 2010, 08:47 AM
Yes, it now mounts automatically. :)


I've already completely re-added all my music. It honestly took about 30 seconds (excluding the time I took to reorganized some misplaced files).


Well, whatever it was it's working now. :)

Thanks everyone for all the help, I really appreciate it.

It's no problem that what we are here for :-)



:?#-oIm still wondering which of the comands actually made it work...
I had the same problem, but I assumed it was just something due to my fiddling and tinkering around that caused me to have to mount it in my home folder.

In other words, Im creating a very nasty bug report against ntfs-config...
I think i'm going to have a play with creating an NTFS partition and have it mount see if/what happens using different methods to get it to mount, see what ntfs-config is actually doing or not doing


heres the bug: https://bugs.launchpad.net/ntfs-config/+bug/585171

k, well if I find out any info about what it is doing wrong i'll add it to that

ferrystitch
May 25th, 2010, 06:46 PM
same trouble here

when i try to open ntfs partition from places - home folder - data(i mount ntfs partition *sda3 here)
then suddently windows close...
--------------------------------------------------------
fdisk

Disk /dev/sda: 60.0 GB, 60011642880 bytes
224 heads, 19 sectors/track, 27540 cylinders
Units = cylinders of 4256 * 512 = 2179072 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x91769176

Device Boot Start End Blocks Id System
/dev/sda1 * 1 7218 15359894+ 7 HPFS/NTFS
/dev/sda2 7219 10660 7323648 83 Linux
/dev/sda3 12031 27539 33003142+ 7 HPFS/NTFS
/dev/sda4 10661 12030 2914305 5 Extended
/dev/sda5 10661 11807 2440192 83 Linux
/dev/sda6 11808 12030 473088 82 Linux swap / Solaris

Partition table entries are not in disk order
----------------------------------------------------------
fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc nodev,noexec,nosuid 0 0
#Entry for /dev/sda2 :
UUID=4b423edc-ffb9-43a6-af24-bab56f189202 / ext3 errors=remount-ro 0 1
#Entry for /dev/sda5 :
UUID=7fbe2260-0fd5-45b0-8266-ef88b91bc69e /home ext3 defaults 0 2
#Entry for /dev/sda3 :
UUID=4A68829568827F85 /home/ferrystitch/data ntfs-3g defaults,locale=en_US.utf8 0 0
#Entry for /dev/sda6 :
UUID=07394162-354e-4cfa-b700-47b4fcf8052a none swap sw 0 0
-------------------------------------------------------------------

i was try to update kernel, but nothing changes... :(
is there any something miss here?