PDA

View Full Version : [ubuntu] How Do I AutoStart Services In Ubuntu 10.04 Desktop?



matthodge
May 22nd, 2010, 05:47 AM
I have installed a fresh copy of Ubuntu 10.04 Desktop x64. It is running desktop with XBMC plugged into my TV, but is also used as a server.

I have installed several packages including
- xinetd (for GLFTPD)
- webmin
- VirtualBox
- NXServer

When I reboot the system, none of the applications automatically start.

I have to ssh into the box and run:
sudo /etc/init.d/xinetd start
sudo /etc/init.d/webmin start

etc for each application I want to start.

How do I start applications automatically in Ubuntu 10.04? Do I have to use upstart?

I usually use webmin to set my services to autostart but with upstart it doesn't work anymore.

Thanks.

ls8_
May 22nd, 2010, 07:07 AM
This is my first post so it might not help you at all.

Start a terminal,
$ gnome-session-propertiesthen add the programs.

matthodge
May 22nd, 2010, 11:56 PM
Thanks ls8.

I was hoping there would be a way to add them from the command line though.

hok00age
May 23rd, 2010, 01:08 AM
Thanks ls8.

I was hoping there would be a way to add them from the command line though.

try using modconf

matthodge
May 23rd, 2010, 03:03 AM
Can you please elaborate? Modconf seems to be a driver installer:

http://packages.ubuntu.com/hardy/modconf

exactt
January 19th, 2011, 02:59 PM
i case somebody wants to know the answer:

try something like this:


update-rc.d tomcat6 enable 2

this automatically starts(enables) tomcat6 in runlevel 2.

crtlbreak
January 22nd, 2011, 06:53 PM
i case somebody wants to know the answer:

try something like this:


update-rc.d tomcat6 enable 2

this automatically starts(enables) tomcat6 in runlevel 2.

Hi exactt,
not sure I understand you - are you saying he should start the modconf in runlevel 2 as you had started your tomcat6?

Suggested [assumption code]
sudo update-rc.d modconf enable 2

exactt
January 24th, 2011, 10:19 AM
I was referring to the original post regarding

- xinetd (for GLFTPD)
- webmin
- VirtualBox
- NXServer

Put them in place for tomcat6 . Regarding the appropriate runlevels I am actually not 100% sure...


sudo update-rc.d xinetd enable 2

HandeH
February 3rd, 2011, 10:52 AM
I have succeeded to run scripts and start applications by gnome-schedule (apt://gnome-schedule) or by putting into gnome-session-properties a quoted command starting with bash -c, like this way:

bash -c "rm -rf ~/.macromedia/Flash_Player/#SharedObjects/*" as suggested here (http://ubuntuforums.org/showpost.php?p=10120454&postcount=4).

There is also another fresh thread (http://ubuntuforums.org/showthread.php?p=10423781) on this issue. And some bug reports: 460746 (https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/460746), 518740 (https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/518740). Consider to mark those affecting you also.