View Full Version : [ubuntu] 10.04 install fails at disk partition

May 7th, 2010, 10:30 PM
Okay, this one is really over my head. I had 9.04 install on a dual proc home built system that was running fine until a recent update wiped out grub. Since I have all my data backed up, I decided just to install 10.04.

I select Use Entire Disk but when Ubuntu tries to install, I get this error:

The ext4 file system creation in partition #1 of Serial ATA nvidia_dacaecb (mirror) failed.

Tried deleting and recreating the partitions, but I still get the same error message.

Also get the same error if I try installing them side by side. I've already blown the partitions, so might as well take this down to bare wood and start over, but I can't get past that error no matter what I try.

I tried formatting through the disk utility in the live version, but I get an error that says:

One or more block devices are holding /dev/sda

What the heck is going on?

May 7th, 2010, 11:45 PM
If your back up data are somewhere else ( not on HDD on witch you try to instal Lucid) you can use Gparted live CD (http://gparted.sourceforge.net/) and make partitions.During install Lucid should recognize partitions and you will be able to install.

May 7th, 2010, 11:49 PM
I'm reinstalling 9.04 right at this minute. That install is working fine, no problems when I select Use Entire Disk. 9.04 installs without a hitch, 10.4 says something is blocking the disk. Same disk, I don't get it.

I ran Gparted from the live disk and blew away all the old partitions. Still didn't work. Same error message.

One installs, one doesn't. Frustrating.

May 7th, 2010, 11:57 PM
You should file a bug report.

May 8th, 2010, 12:45 AM
No thanks, done that before. Here's how those usually go:

- Get passed around to three or four different staff members.

- Ubuntu blames another piece of software.

- Suggests I file a bug report at some other web site.

- Closes bug report.

I like Ubuntu, but don't like dealing with the developers.

May 8th, 2010, 01:06 AM
The (mirror) makes it sound like something is assuming raid. Maybe the following is an issue http://www.ubuntu.com/getubuntu/releasenotes/1004#Dmraid%20active%20by%20default%20on%20Desktop %20CD

May 8th, 2010, 01:37 AM
perhaps it'd help to verify what the boot/grub directory says about whether you have Grub or Grub2. As mentioned on this forum, check for existence of files menu.1st and grub.cfg. if you try this I urge you to read this as I did. was trying to unravel my own dilemma. see https://help.ubuntu.com/community/RecoveringUbuntuAfterInstalling.... I came on this lead via a search. But after being burdened with other chores, I gave up for now.

Best of luck. Thanks for posting,,,, I will look back here when I try to solve a locked 9.04.

May 8th, 2010, 04:26 AM
Figured it out, but it was quite the trek.

I can't just blow a 10.04 disk in and go. I have to first install 9.04, upgrade that to 9.10, then upgrade that to 10.04. Then it works.