PDA

View Full Version : [ubuntu] No boot splash in Lucid Lynx on system with ATI graphics card



Alvin Chiu
May 7th, 2010, 04:33 PM
I have been unable to get the fancy purple bootsplash (plymouth) since I installed Lucid Lynx on my ThinkPad T43. The bootsplash would up when I had booted off of a Live CD, but all future instances post-install only shows the blinking terminal cursor, followed by the GNOME log in screen. This has occurred after upgrading from Karmic, and after attempting a fresh installation of Lucid. Here's what I've tried so far without success:



comment out "GRUB_HIDDEN_TIMEOUT=0" in the grub file
tried running echo FRAMEBUFFER=y > /etc/initramfs-tools/conf.d/splash
update-initramfs -u
under su but it did not work because my conf.d directory doesn't contain a file called "splash", but only one file called "resume".
This fix was taken from https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/540801.

A Google search showed that a lot of users with this problem have NVIDIA cards; however I'm running ubuntu on a system with an ATI card.

Thanks in advance for any help.

bdw
May 11th, 2010, 04:55 AM
Hey there! :)

Which ATI card or chipset are you running and are you using the proprietary ATI fglrx drivers?

-- Brian

Iskaros
May 11th, 2010, 04:58 AM
I have the same problem!
ATI Radeon x1200

Alvin Chiu
May 21st, 2010, 04:57 PM
Hi bdw,

I have a 64MB ATI Mobility Radeon X300. I used the X.org video driver that was installed by default by Ubuntu.

-A

Alvin Chiu
June 20th, 2010, 07:58 PM
bump

HeadHunter00
July 1st, 2010, 04:10 PM
EDIT: Oh! never mind, i fixed my problem with your step 2. but, i had to enable plymouth in bum first. to do that, install bum using synaptic, open bum (system-->administration-->bootup-manager), and then enable plymouth.

Alvin Chiu
July 26th, 2010, 07:06 AM
EDIT: Oh! never mind, i fixed my problem with your step 2. but, i had to enable plymouth in bum first. to do that, install bum using synaptic, open bum (system-->administration-->bootup-manager), and then enable plymouth.
Installed bum and checked off plymouth, plymouth-log, plymouth-splash, and plymouth-stop. Applied changes and then restarted. I still get the blinking cursor when I boot up. Looks my computer is being very stubborn.

HeadHunter00
July 27th, 2010, 01:47 AM
sorry dude, i didnt have any experience with ati cards, only nvidia and intel.