PDA

View Full Version : [all variants] use PHP5.2 instead of PHP5.3?



anarkhos
May 3rd, 2010, 05:38 PM
I'd like to use PHP5.2x instead of PHP5.3x on my Ubuntu 10.04. There is a small bug in Drupal where tweaking Views causes an error which seems to be associated with php5.3.

So, how would I regress to using 5.2x on Ubuntu?

bvanaerde
May 3rd, 2010, 05:43 PM
How did you install PHP?

I am using XAMPP for a combined install of PHP, mySQL, phpmyadmin, ...
The current XAMPP version also has 5.3.1, but you can download the previous versions too:

http://sourceforge.net/projects/xampp/files/

If I'm not mistaken, I'm using XAMPP version 1.7.2, which has PHP version 5.2.9.

You can find out how to install it here:
http://www.apachefriends.org/en/xampp-linux.html#377