PDA

View Full Version : [ubuntu] Nvidia 1440x900



MrJackdaw
May 2nd, 2010, 10:05 AM
Please help!

I have searched for, and tried, many ideas to get my Ubuntu installation working at 1440x900.

I am using the latest version of Ubuntu, with the Current Nvidia drivers that were auto-installed.

Yes, I have tried Nvidia-settings - it just doesn't show up under the options!

Current Xorg;


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Fri Apr 9 10:35:18 UTC 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: xconfig, VertRefresh source: xconfig
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-1"
HorizSync 28.0 - 55.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6600 GT"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1152x864_60 +0+0; 1024x768 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

MrJackdaw
May 2nd, 2010, 03:43 PM
Fixed!

But my workaround was so odd, that I am sure it was wrong. The key was the fact that my monitors EDID was wrong. I put one I found for my monitor and used the
Option "CustomEDID" "CRT-0:/tmp/edid1.bin" setting to fix it. Had to reboot once but... Yey!