PDA

View Full Version : [ubuntu] Firefox sound not working



lolzwut
April 30th, 2010, 08:55 PM
To start off I'd like to say I tried this solution: http://ubuntuforums.org/showthread.php?t=255422 but it doesn't work. My firefoxrc file is blank.


So onto my main problem, my sound just stopped working earlier today on firefox. I didn't even do anything it just didn't work. The sound works on everything else though like media player. I've searched the site for threads about it but none of the solutions work. I've restarted firefox a ton of times so I don't know what could be wrong or how to fix it. Can someone help me? Thanks.

edit: btw my sound is turned up on firefox in the sound mixer

ratcheer
April 30th, 2010, 09:05 PM
Sound for Flash in Firefox?

Tim

lolzwut
April 30th, 2010, 09:16 PM
Sound for Flash in Firefox?

Tim


what? the sound doesn't work at all..

ratcheer
April 30th, 2010, 09:24 PM
That's what I was asking. I know how to fix the Flash sound issue, but not if your problem is bigger.

Tim

Kafubie
April 30th, 2010, 09:30 PM
For me, I went to
The Sound Icon -> sound preferences -> output -> connector -> analog speakers. (if you don't have the sound button on your panel,right click any panel -> go to add to panel -> indicator applet)
:-D

lolzwut
April 30th, 2010, 09:47 PM
That's what I was asking. I know how to fix the Flash sound issue, but not if your problem is bigger.

Tim


Sorry, I didn't understand the question completely. The sound only doesn't work on streaming videos like youtube. I guess that's flash. Can you tell me how to fix it?

@Kafubie:

I don't have a connector tab

Kafubie
April 30th, 2010, 09:53 PM
Sorry, I didn't understand the question completely. The sound only doesn't work on streaming videos like youtube. I guess that's flash. Can you tell me how to fix it?

@Kafubie:

I don't have a connector tab

I mean, go to the input tab on top, then go to connecter which is like half way down in the input tab. If it's literally not there then I don't know If I could help. You need expert powers!:lolflag:

ratcheer
April 30th, 2010, 09:55 PM
Yes, YouTube videos are Flash.

So, next question: Does your system have more than one sound card? If yes, the problem is that Flash will ONLY use the first sound card that ALSA sees. If that is not the card connected to your speakers, you will get no sound from Flash.

Tim

lolzwut
April 30th, 2010, 10:05 PM
That's weird it just started working again. I don't get it for absolutely no reason it just started working. Whatever at least it works, I'll post back here again if it stops working later on.




Yes, YouTube videos are Flash.

So, next question: Does your system have more than one sound card? If yes, the problem is that Flash will ONLY use the first sound card that ALSA sees. If that is not the card connected to your speakers, you will get no sound from Flash.

Tim

Um....I don't know how to check how many soundcards I have. I'm really a linux noob sorry. I would the guess the answer is one though because in sound preferences under hardware it has internal audio then my headphones... I don't know if that's what you're asking for though.

ratcheer
April 30th, 2010, 10:17 PM
Ok, I'm glad you're working, again.

Tim

stinkypudding
April 30th, 2010, 10:28 PM
May I ask what if anything you did? I'm having the exact same issue. Flash video works, but no audio. Everything else works fine, and I just have a single sound card. And it's not limited to firefox, same issue with Google Chrome. I've uninstalled and reinstalled flash, to no avail. Can anyone help?

Kafubie
April 30th, 2010, 10:30 PM
Try the way I recently posted, it helped for me.
I did exactly what you did prior also. lol

lolzwut
April 30th, 2010, 10:33 PM
May I ask what if anything you did? I'm having the exact same issue. Flash video works, but no audio. Everything else works fine, and I just have a single sound card. And it's not limited to firefox, same issue with Google Chrome. I've uninstalled and reinstalled flash, to no avail. Can anyone help?

nope sorry. I didn't do anything it just worked for no reason. I didn't even restart firefox

smythie86
May 2nd, 2010, 12:45 AM
Yes, YouTube videos are Flash.

So, next question: Does your system have more than one sound card? If yes, the problem is that Flash will ONLY use the first sound card that ALSA sees. If that is not the card connected to your speakers, you will get no sound from Flash.

Tim

I believe this is the exact problem I am having. sound works for amarok, but not for firefox. I have 2 sound cards on my system, one on the motherboard, and another one that I am actually plugged into. How can I fix this problem?

Thanks

ratcheer
May 2nd, 2010, 01:19 AM
I believe this is the exact problem I am having. sound works for amarok, but not for firefox. I have 2 sound cards on my system, one on the motherboard, and another one that I am actually plugged into. How can I fix this problem?

Thanks

1) cat /proc/asound/modules

If card 0 is the one you don't want, you have to force it to be card 1.

2) Edit file /etc/modprobe.d/alsa-base.conf. Find the line that says:

"# Prevent abnormal drivers from grabbing index 0" and, after it, insert a new line:

options xxxxxxx index=1

where xxxxxxx is the name of the sound module with index 0 from step 1 output

3) Save the file and reboot. Your Flash sound should be working. To double check, rerun "cat /proc/asound/modules".

I hope this helps.

Tim

itisachilles
May 2nd, 2010, 03:28 AM
If limewire is installed on your computer and its running TURN IT OFF AND EXIT it will kill any sound coming from firefox but not chrome nor opera (as far as i can tell)
p.s. only had this problem in 10.04

smythie86
May 2nd, 2010, 05:19 PM
1) cat /proc/asound/modules

If card 0 is the one you don't want, you have to force it to be card 1.

2) Edit file /etc/modprobe.d/alsa-base.conf. Find the line that says:

"# Prevent abnormal drivers from grabbing index 0" and, after it, insert a new line:

options xxxxxxx index=1

where xxxxxxx is the name of the sound module with index 0 from step 1 output

3) Save the file and reboot. Your Flash sound should be working. To double check, rerun "cat /proc/asound/modules".

I hope this helps.

Tim

Yes this was exactly the problem, and this fixed it. Thank you!

ratcheer
May 2nd, 2010, 10:06 PM
Yes this was exactly the problem, and this fixed it. Thank you!

You're welcome. I'm glad I could help.

Tim

Kafubie
May 2nd, 2010, 10:34 PM
-Rat
=D>=D>=D>=D>=D>

eklypze
May 3rd, 2010, 01:21 AM
Thanks so much ratcheer ! It worked !

ratcheer
May 3rd, 2010, 11:46 AM
Thanks so much ratcheer ! It worked !

You're welcome.

Tim

distilledwater
May 11th, 2010, 06:26 AM
For me, I went to
The Sound Icon -> sound preferences -> output -> connector -> analog speakers. (if you don't have the sound button on your panel,right click any panel -> go to add to panel -> indicator applet)
:-D

Awesome! this worked for me except i had to change it to > analog output.

Woo! this problem has been troubling me for the last two days.

I don't understand how that fixed it though.

distilledwater
May 14th, 2010, 05:42 AM
Alright actually my audio is still not fixed.

Audio works fine through Amarok and VLC when i play different forms of media.

In firefox when i try to watch a video on youtube or try streaming music from grooveshark or myspace i get no audio. The visual aspect of the video on youtube works but not the audio.

Also when i close the tab after getting no audio firefox will just crash.

I have uninstalled flash completely and reinstalled it multiple times, then i tried fully reinstalling firefox, still to no avail.

This is driving me nuts cause everything else on lucid works perfectly.

mcalautt
November 27th, 2010, 04:51 AM
I have the problem. vidio/audio works fine in players but not in konqueror or firefox.


DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04 <br>DISTRIB_CODENAME=lucid

DISTRIB_DESCRIPTION=&quot;Ubuntu 10.04.1 LTS
Linux toshiba-carcass 2.6.32-26-generic #47-Ubuntu SMP Wed Nov 17 15:59:05 UTC 2010 i686 GNU/Linux
firefox 3.6.12 flashplugin-installer 10.1.102.65ubuntu0.10.04.1

i tried downloading the libflashplayer.so from adoble directly and added it in
/usr/share/ubufox/plugins/libflashplayer.so
/usr/lib/flashplugin-installer/libflashplayer.so
/usr/lib/firefox/plugins/libflashplayer.so

mcalautt
November 29th, 2010, 01:40 AM
I found it.. it was the stupid PCM volume control. It was at 0. its on the mixer controls when you click on the speaker in the tool bar

GWild
December 26th, 2010, 02:41 PM
1) cat /proc/asound/modules

If card 0 is the one you don't want, you have to force it to be card 1.

2) Edit file /etc/modprobe.d/alsa-base.conf. Find the line that says:

"# Prevent abnormal drivers from grabbing index 0" and, after it, insert a new line:

options xxxxxxx index=1

where xxxxxxx is the name of the sound module with index 0 from step 1 output

3) Save the file and reboot. Your Flash sound should be working. To double check, rerun "cat /proc/asound/modules".

I hope this helps.

Tim

ratcheer:

Thank you for posting this.

I'm running Kub 10.04 64 and lost Flash audio after installing the Flash blocker add-on for Firefox - but lost ALL Flash audio on the system (it worked prior to installing the Flash blocker).

I used your method (and a bit of trial and error) and was able to restore Flash audio on the system.

ratcheer
December 26th, 2010, 07:26 PM
ratcheer:

Thank you for posting this.

I'm running Kub 10.04 64 and lost Flash audio after installing the Flash blocker add-on for Firefox - but lost ALL Flash audio on the system (it worked prior to installing the Flash blocker).

I used your method (and a bit of trial and error) and was able to restore Flash audio on the system.

You are welcome.

Tim

jornand
July 11th, 2011, 07:38 AM
I had the same problem for ages until I accidentally stumbled upon a solution. It is important to have a flash video or flash app running. If no, the alsamixer won't show up. Then go to sound/preferences/applications and crank up the volume on the alsamixer. Problem solved! :)

cje
September 13th, 2011, 09:09 PM
I had the same problem for ages until I accidentally stumbled upon a solution. It is important to have a flash video or flash app running. If no, the alsamixer won't show up. Then go to sound/preferences/applications and crank up the volume on the alsamixer. Problem solved! :)

That's it! Thanks! :-)