PDA

View Full Version : [SOLVED] 9.10 to 10.4 upgrade and LTSP



rwmarch
April 30th, 2010, 05:59 PM
Version 9.10 had been installed via the alternate CD as the LTSP Server Edition.
In place upgrade to 10.4 completed normally via Update Manager.
However, LTSP terminal boot now fails with error "Forbidden directory" and "Access Violation".

The following was found ...
Ubuntu 10.4 uses tftp-hpa. Either this is a change from Ubuntu 9.10 or the default behaviour of tftp-hpa has changed.
So now, the filename argument given in /etc/ltsp/dhcpd.conf must include the full pathname. The previous requirement was to exclude the chroot path.
If this is documented somewhere, I missed it.

And after modifying /etc/ltsp/dhcpd.conf, do not forget to restart the dhcp daemon ...
$ sudo /etc/init.d/dhcp3-server restart

secteur
May 1st, 2010, 12:39 PM
Hi there,

I have the same issue after upgrading from 9.10 to 10.04.

Tried to modify my dhcpd.conf as you mentioned but not sure whether I've done the right thing (doesnt work yet)

So I should have:
filename="/opt/ltsp/i386/ltsp/i386/pxelinux.0"

where it used to be
filename="/ltsp/i386/pxelinux.0"
?

Tried but LTSP client still fails with Forbidden Directory error PXE-T02

Also tried
filename="/opt/ltsp/i386/pxelinux.0"
without luck.

Should the following line then be commented?
option root-path "/opt/ltsp/i386";

Thanks for your help

Mat

Also found a bug on launchpad which could be related:
https://bugs.launchpad.net/ubuntu/+source/tftp-hpa/+bug/531123
but it says solved a month ago.
Although the file that they mention /etc/init.d/tftpd-hpa which needed fixing seems to look very different on my server than theirs...

mwhitlock
May 1st, 2010, 01:44 PM
Hi, I had this problem and solved it with information gathered here (http://www.nubae.com/logs/ltsp20100303_pg4.html).

The file /etc/default/tftpd-hpa has the wrong path to the tftp directory, as follows:

TFTP_USERNAME="tftp"
TFTP_DIRECTORY="/srv/tftp"
TFTP_ADDRESS="0.0.0.0:69"
TFTP_OPTIONS=""

The tftp directory path should be /var/lib/tftpboot.

Making this change solved the problem for me, although I was immediately confronted with a new one. Logging in to a thin client caused the username and password to be authenticated OK but the log in did not complete and I was returned to the log-in screen.

I eventually managed to log into an icewm session, which works fine, although it won't log out. But all the other possible sessions behave as above. Any thoughts?

secteur
May 2nd, 2010, 12:56 PM
Hi mwhitlock, thank you so much for pointing to that discussion.

Here's how it worked for me:

In the file /etc/default/tftpd-hpa setting
TFTP_OPTIONS="--secure"

actually solved the T02 error Forbidden directory.

But it was still failing this time with T01 File not found.

Changing the path to /var/lib/tftpboot as you mentioned solved the T01 error.

Thanks again!

kfleten
May 5th, 2010, 01:23 PM
Hi
I had the same problem after upgrading from 9.10 to 10.04. I changed /etc/default/tftpd-hpa to this :

TFTP_USERNAME="tftp"
TFTP_DIRECTORY="/var/lib/tftpboot"
TFTP_ADDRESS="0.0.0.0:69"
TFTP_OPTIONS="--secure"

and did:
sudo ltsp-build-client --arch i386
sudo ltsp-update-image --arch i386

,but still got the error: Forbidden directory.

Then I did:
sudo ltsp-update-sshkeys
sudo ltsp-update-kernels
sudo ltsp-update-image --arch 1386
sudo service tftpd-hpa restart

That solved the problem :-)

0dB
September 13th, 2010, 07:02 PM
Same problem for me. But I followed the last post from kfleten, I changed /etc/default/tftpd-hpa to

TFTP_USERNAME="tftp"
TFTP_DIRECTORY="/var/lib/tftpboot"
TFTP_ADDRESS="0.0.0.0:69"
TFTP_OPTIONS="--secure"

Then all I did was

sudo service tftpd-hpa restart

and LTSP worked. I did not have to follow the other steps.

Thanks, all!

bluntknife
October 31st, 2010, 08:19 AM
Same problem for me. But I followed the last post from kfleten, I changed /etc/default/tftpd-hpa to

TFTP_USERNAME="tftp"
TFTP_DIRECTORY="/var/lib/tftpboot"
TFTP_ADDRESS="0.0.0.0:69"
TFTP_OPTIONS="--secure"

Then all I did was

sudo service tftpd-hpa restart

and LTSP worked. I did not have to follow the other steps.

Thanks, all!


This also worked for me. Thanks

lifeboy
November 15th, 2010, 12:17 PM
I upgraded a Hardy server to Intrepid originally and two days ago to 10.04 (Lucid) and then to 10.10 (Maveric). Everything went very smoothly, except that DHCP seemed broken afterwards. It also seems that the newer version of LTSP actually creates the image for the thin clients in /srv/ltsp now.

To get the clients to boot again I changed this setting in /etc/ltsp/dhcpd.conf:


option root-path "/srv/tftp/ltsp/i386/";

And then in /etc/default/tftpd-hpa I added:


TFTP_OPTIONS="--secure"

Going back to the /var/lib/tftpboot/ltsp directory doesn't seem to be the default location any more. What I do find interesting though is that both directories contain the same files with the same timestamps.

roland@zambas:~$ sudo ls -la /var/lib/tftpboot/ltsp/i386
total 38536
drwxr-xr-x 3 root root ____4096 2010-11-14 21:17 .
drwxr-xr-x 5 root root ____4096 2010-11-14 11:21 ..
-rw-r--r-- 1 root root __422607 2008-04-10 18:51 abi-2.6.24-16-generic
-rw-r--r-- 1 root root __705737 2010-10-17 04:02 abi-2.6.35-22-generic
-rw-r--r-- 1 root root __128592 2010-10-17 04:02 config-2.6.35-22-generic
-rw-r--r-- 1 root root ___89441 2010-11-14 11:21 gpxelinux.0
lrwxrwxrwx 1 root root ______28 2010-11-14 11:21 initrd.img -> initrd.img-2.6.35-22-generic
-rw-r--r-- 1 root root _4502999 2008-12-15 15:38 initrd.img-2.6.24-16-generic.bak
-rw-r--r-- 1 root root 11530007 2010-11-14 11:21 initrd.img-2.6.35-22-generic
-rw-r--r-- 1 root root ______26 2010-11-14 21:17 lts.conf
lrwxrwxrwx 1 root root ______25 2010-11-14 11:21 nbi.img -> nbi.img-2.6.35-22-generic
-r--r--r-- 1 root root 15812719 2010-11-14 11:21 nbi.img-2.6.35-22-generic
-rw-r--r-- 1 root root ___26742 2010-11-14 11:21 pxelinux.0
drwxr-xr-x 2 root root ____4096 2010-11-14 11:21 pxelinux.cfg
-rw-r--r-- 1 root root _1830809 2010-10-17 04:02 System.map-2.6.35-22-generic
-rw-r--r-- 1 root root ____1192 2010-10-17 04:05 vmcoreinfo-2.6.35-22-generic
lrwxrwxrwx 1 root root ______25 2010-11-14 11:21 vmlinuz -> vmlinuz-2.6.35-22-generic
-rw-r--r-- 1 root root _4289616 2010-10-17 04:02 vmlinuz-2.6.35-22-generic


roland@zambas:~$ sudo ls -la /srv/tftp/ltsp/i386/
total 33700
drwxr-xr-x 3 root root ____4096 2010-11-14 11:21 .
drwxr-xr-x 4 root root ____4096 2010-11-14 11:21 ..
-rw-r--r-- 1 root root __705737 2010-10-17 04:02 abi-2.6.35-22-generic
-rw-r--r-- 1 root root __128592 2010-10-17 04:02 config-2.6.35-22-generic
-rw-r--r-- 1 root root ___89441 2010-11-14 11:21 gpxelinux.0
lrwxrwxrwx 1 root root ______28 2010-11-14 11:21 initrd.img -> initrd.img-2.6.35-22-generic
-rw-r--r-- 1 root root 11530007 2010-11-14 11:21 initrd.img-2.6.35-22-generic
lrwxrwxrwx 1 root root ______25 2010-11-14 11:21 nbi.img -> nbi.img-2.6.35-22-generic
-r--r--r-- 1 root root 15812719 2010-11-14 11:21 nbi.img-2.6.35-22-generic
-rw-r--r-- 1 root root ___26742 2010-11-14 11:21 pxelinux.0
drwxr-xr-x 2 root root ____4096 2010-11-14 11:21 pxelinux.cfg
-rw-r--r-- 1 root root _1830809 2010-10-17 04:02 System.map-2.6.35-22-generic
-rw-r--r-- 1 root root ____1192 2010-10-17 04:05 vmcoreinfo-2.6.35-22-generic
lrwxrwxrwx 1 root root ______25 2010-11-14 11:21 vmlinuz -> vmlinuz-2.6.35-22-generic
-rw-r--r-- 1 root root _4289616 2010-10-17 04:02 vmlinuz-2.6.35-22-generic

Maybe someone can shed light on the matter?

regards

Roland

AnoPoli
June 2nd, 2012, 07:00 PM
A fresh install of ubuntu 10.04.4 as ltsp server gives another strange error:
dhcpd expects to find pxelinux.0 and the other files in /opt/ltsp/i386.tmp while they are ofcourse in /opt/ltsp/i386
When one fix that, all the other works as expected.
The only issue is that gnome comes up sometimes without theme at all to the clients, but that may be local speed problem.