PDA

View Full Version : [ubuntu] U1004.Laptop hard drive overheating



Mark Goldshtein
April 30th, 2010, 05:22 PM
Please, help to determine a cause and a cure for hard drive overheating.

I have Lenovo Y450-3M laptop and Western Digital HDD inside:


-- Disk List ---------------------------------------------------------------
(1) WDC WD2500BEVT-22ZCT0 : 250.0 GB [0-0-0, pd1]
----------------------------------------------------------------------------
Model : WDC WD2500BEVT-22ZCT0
Firmware : 11.01A11
Serial Number : WD-WXE0A7903595
Total Disk Size : 250.0 GB (8.4/137.4/250.0)
Buffer Size : 8192 KB
NV Cache Size : ----
Queue Depth : 32
Number of Sectors : 488397168
Rotation Rate : 5400 RPM
Interface : Serial ATA
Major Version : ATA8-ACS
Minor Version : ----
Transfer Mode : SATA/300
Power On Hours : 2211 hours
Power On Count : 658 count
Temperature : 45 C (113 F)
Health Status : Good
Features : S.M.A.R.T., APM, AAM, 48bit LBA, NCQ
APM Level : 0080h [ON]
AAM Level : 80FEh [OFF]

-- S.M.A.R.T. --------------------------------------------------------------
ID Cur Wor Thr RawValues(6) Attribute Name
01 200 200 _51 000000000000 Read Error Rate
03 191 185 _21 000000000580 Spin-Up Time
04 100 100 __0 000000000296 Start/Stop Count
05 200 200 140 000000000000 Reallocated Sectors Count
07 100 253 __0 000000000000 Seek Error Rate
09 _97 _97 __0 0000000008A3 Power-On Hours
0A 100 100 _51 000000000000 Spin Retry Count
0B 100 100 __0 000000000000 Recalibration Retries
0C 100 100 __0 000000000292 Power Cycle Count
C0 200 200 __0 000000000170 Power-off Retract Count
C1 184 184 __0 00000000BE04 Load/Unload Cycle Count
C2 102 _96 __0 00000000002D Temperature
C4 200 200 __0 000000000000 Reallocation Event Count
C5 200 200 __0 000000000000 Current Pending Sector Count
C6 100 253 __0 000000000000 Uncorrectable Sector Count
C7 200 200 __0 000000000000 UltraDMA CRC Error Count
C8 100 253 _51 000000000000 Write Error RateU910 and U1004 (betas, rc, final) x86 warming up a HDD to 48-50 degrees Celsius. Room temperature about 24 degrees. LiveCD mode, swap is off, no single touch of a hard drive, temperature goes up quickly, about 10 degrees in 30-40 minutes. Tasks are simple: text editing, mail, web, music a little (I mean no "box, sex, jazz" at all).

Hardware itself is healthy, MS Win7 x86 shows about 39 degrees with the same load in the same environment. Along with Fedora Core 13 Beta x86.

Search through forum and bug tracker does reveal some similar questions discussed. Follow recommendations and check drive status with smartctl "load/unload cycle count" show that number does not increasing during a warm up.
So, what is it? An ubuntu-specific bug? Or feature to keep us warm all that long cold winter?

Thanks.

P.S. Yes, bug is reported.
https://bugs.launchpad.net/ubuntu/+bug/498319

Mark Goldshtein
May 1st, 2010, 01:50 PM
Seems like Ubuntu does not control 'load/unload cycle' of the hard drive at all. Or, default policy of hard drive governor set to 'zero parking'. The count stays still.

At the same time, a second operating system on the laptop, MSW7 have produced about 48000 cycles. If we divide 48000/2250 working hours, result will be about 21 cycles per hour, rather normal for notebook hard drive.

Well, does anybody have any clue about this case of overheating? I think, 10 degrees Celsius is a big difference between two OSes.

Soadyheid
May 1st, 2010, 03:19 PM
What have you got the power settings set to? Do you have "Spin disk down when possible" checked which would no doubt keep the temperature down. You'd have to compare settings between Ubuntu, Windows, etc. Maybe the algorithm which reads the temperature is incorrect in one of the OS' ( I wonder where they hide the sensor? :confused:)
Are you getting any errors from the disk or are you just worried about the difference in temperature? Your output says "Health, good" so do you need to worry?

Play Bonny! :)

Mark Goldshtein
May 1st, 2010, 03:52 PM
What have you got the power settings set to? Do you have "Spin disk down when possible" checked which would no doubt keep the temperature down.

That checkbox is checked. No effect on temperature.


You'd have to compare settings between Ubuntu, Windows, etc.

Done. MSW7, Fedore Core 13 Beta, Debian Squeeze show about 40 degrees Celsius. Except for Ubuntu, which stays about 49. Load is the same.


Maybe the algorithm which reads the temperature is incorrect in one of the OS'?

It is correct, AFAIK. Utilities just read SMART data from the hard drive. It is OS independent.


( I wonder where they hide the sensor? :confused:

You mean, physically?


Are you getting any errors from the disk or are you just worried about the difference in temperature? Your output says "Health, good" so do you need to worry?

No errors, green light. And yes, I am just worrying about temperature. If room temperature will go up (and it definitely will at summer), so drive's temperature will be close to the limit. If there any need to set hard drive governor policy the way it warm up a drive ten degrees more than any other OS?

lavinog
May 1st, 2010, 04:27 PM
Seems like Ubuntu does not control 'load/unload cycle' of the hard drive at all. Or, default policy of hard drive governor set to 'zero parking'. The count stays still.

At the same time, a second operating system on the laptop, MSW7 have produced about 48000 cycles. If we divide 48000/2250 working hours, result will be about 21 cycles per hour, rather normal for notebook hard drive.

Well, does anybody have any clue about this case of overheating? I think, 10 degrees Celsius is a big difference between two OSes.

There was a post that went on for over a year with users complaining about the load/unload cycling in ubuntu being too high. Users noted that windows did not unload the head, and complained that ubuntu should act that way. Many of us disagreed with the majority and noted that manufactures designed the hds to be unloaded.
I think the current setup is to enable unloading only when on the battery.

EDIT: hdparm is what you use to set the APM setting which enables unloading the heads:

-B Query/set Advanced Power Management feature, if the drive sup‐
ports it. A low value means aggressive power management and a
high value means better performance. Possible settings range
from values 1 through 127 (which permit spin-down), and values
128 through 254 (which do not permit spin-down). The highest
degree of power management is attained with a setting of 1, and
the highest I/O performance with a setting of 254. A value of
255 tells hdparm to disable Advanced Power Management altogether
on the drive (not all drives support disabling it, but most do).

Mark Goldshtein
May 1st, 2010, 04:39 PM
I think the current setup is to enable unloading only when on the battery.

It is a good idea to try U1004 on batteries. Will reboot now.

Is the default scheme can be changed by # sdparm and these values between 255 and 0?

lavinog
May 1st, 2010, 04:47 PM
It is a good idea to try U1004 on batteries. Will reboot now.

Is the default scheme can be changed by # sdparm and these values between 255 and 0?
I updated my post.
this should enable it temporarily:


sudo hdparm -B 128 /dev/sda

Mark Goldshtein
May 1st, 2010, 05:17 PM
I updated my post.
this should enable it temporarily:


sudo hdparm -B 128 /dev/sda


Thanks!
Running on batteries, temperature stays about 41 degrees Celsius.

Will reboot into AC power mode and try hdparm.

Running on AC power. hdparm -B 128 works and temperature stays about 42 degrees Celsius.
Thanks for your advice!

lavinog
May 1st, 2010, 08:00 PM
I am doing some power measurments.
Changing the setting from 254 to 128 reduces power consumption from 18.5W to 17.1W.
That is pretty substantial.

I have 92,000 cycles and 127 days of power on time. I determined that 600,000 cycles is designed limit. The drive is 4 years old and has been running ubuntu for about 90% of the time.

Rebelli0us
May 1st, 2010, 08:33 PM
It's probably the device drivers, see my post here:

http://ubuntuforums.org/showthread.php?p=9212112#post9212112

Also about the clicking in WD disks, search "wdidle3.exe" utility, see my post here

http://www.silentpcreview.com/forums/viewtopic.php?t=52937&highlight=

lavinog
May 1st, 2010, 08:40 PM
https://wiki.ubuntu.com/PowerManagement



How to get disks to spin down and idle correctly (without excessive load cycling)

10.04

The laptop-mode-tools (disk idleing) package does not get installed by default any more, but just installing it should make disk idleing work (on battery) right away now.


After installing laptop-mode-tools you can edit /etc/laptop-mode/laptop-mode.conf


#
# Power management for HD (hdparm -B values)
#
BATT_HD_POWERMGMT=1
LM_AC_HD_POWERMGMT=254
NOLM_AC_HD_POWERMGMT=254

Mark Goldshtein
May 2nd, 2010, 01:05 PM
lavinog
Thanks a lot for your time and efforts! Problem is resolved.