PDA

View Full Version : Flash and 10.04 64-bit



samalex
April 30th, 2010, 04:36 PM
Hi,

For those running 64-bit Lucid, did it come preinstalled with NSPlugin wrapper and 32-bit Flash or the Alpha version of 64-bit Flash for Linux? My system is still running Jaunty and I'm using the Alpha 64-bit version of Flash which works quite well, so just curious which one they included in 64-bit Lucid.

Sam

alket
April 30th, 2010, 05:06 PM
Me, just download the Linux x64 Flash from http://labs.adobe.com unzip it and put it as root at /usr/lib/mozilla/plugins

chessnerd
April 30th, 2010, 05:09 PM
Installing through the repos will give you NSPlugin wrapper and plethora of other packages along with the installer.

brian183
April 30th, 2010, 05:10 PM
If you install the package "ubuntu-restricted-extras" or "flashplugin-installer" it will install the 32bit flash with nspluginwrapper. I downloaded the adobe 64bit flash from their site instead.

LowSky
April 30th, 2010, 05:11 PM
Me, just download the Linux x64 Flash from http://labs.adobe.com unzip it and put it as root at /usr/lib/mozilla/plugins

I just put mine in the /home/user/.mozilla/plugins folder
seems to work fine their too. Then again I'm the only user on my machine.

swoll1980
April 30th, 2010, 05:27 PM
If your the only user just create a folder in .mozilla called plugins, and stick the 64bit player from adobe's site in there. It works great.

mihai.ile
April 30th, 2010, 05:46 PM
Me, just download the Linux x64 Flash from http://labs.adobe.com unzip it and put it as root at /usr/lib/mozilla/plugins

did the exact same thing after noticing that flash from synaptic wants to download ia32libs and such...

EMVirostek
April 30th, 2010, 05:59 PM
I'm trying to do this and am getting the following error message...in LL-LTS...

"You don't have the right permissions to extract archives in the folder "file:///usr/lib/mozilla/plugins"

Any ideas? I'm the only user...

clancymf
April 30th, 2010, 06:00 PM
you probably need root priviledges

bedhead75
April 30th, 2010, 06:01 PM
You have to have root access to copy files to that folder. Use "sudo".

EMVirostek
April 30th, 2010, 06:03 PM
can you tell me how to use sudo? I'm kind of a linux newb...

I assume I need to do it in a terminal...but I dont know the command...

Thanks!

BigSilly
April 30th, 2010, 06:19 PM
As a newcomer, it's probably easier for you to just type
gksudo nautilus then enter your password. That will give you full permissions to do what you like with the filesystem. Be careful though! :D

samalex
April 30th, 2010, 06:54 PM
Hi everyone,

So I guess Flash isn't installed by default, but yeah I'll grab the 64-bit alpha version from Adobe either way since I really hate using the wrapper. I just wasn't sure what Canonical included outta the box, if anything.

Sam

half-life
April 30th, 2010, 07:08 PM
i already put the flash player 64bits in usr/lib/mozilla and now how do i turn it to default player when i have the wrapper as default?

EMVirostek
April 30th, 2010, 07:16 PM
So I tried the gksudo nautilus command and still can't get it to let me relocate the plugin.

I downloaded the tar.gz file from adobe and guess i don't know how to get the .so to the right place...

Also, I'm getting an error on some webpages that there is a missing plug in and i am guided to click on a button to locate that plug in. hen it takes me there and there are no available plugins...

So confused!

EMVirostek
April 30th, 2010, 07:29 PM
Found this link...

http://ubuntuforums.org/showthread.php?t=1358591

Seems to work fine now!

Thanks for all the help!

swoll1980
April 30th, 2010, 07:38 PM
As a newcomer, it's probably easier for you to just type
gksudo nautilus then enter your password. That will give you full permissions to do what you like with the filesystem. Be careful though! :D

As a newcomer having GUI root access to the file system is probably not a great idea.

VastOne
April 30th, 2010, 08:25 PM
I just put mine in the /home/user/.mozilla/plugins folder
seems to work fine their too. Then again I'm the only user on my machine.

This does not work for me...Gonna try it in the usr ....Plugins when I get back home

BigSilly
April 30th, 2010, 08:45 PM
As a newcomer having GUI root access to the file system is probably not a great idea.

No, but then it's not permanent is it?

zipperback
April 30th, 2010, 09:32 PM
Hi,

For those running 64-bit Lucid, did it come preinstalled with NSPlugin wrapper and 32-bit Flash or the Alpha version of 64-bit Flash for Linux? My system is still running Jaunty and I'm using the Alpha 64-bit version of Flash which works quite well, so just curious which one they included in 64-bit Lucid.

Sam

It looks like it is still installing the 32 bit version with the wrapper.

It's pretty simple to install the 64 bit version though.

- zipperback
:popcorn:

bro
April 30th, 2010, 09:51 PM
can you help me out? The default install doesn't work for me because my mouse buttons don't interact with the flash player.

So I copied the 64-bit version to ~/.mozilla/plugins/
I've also tried /usr/lib/mozilla/plugins/

I uninstalled all other flash stuff. It still doesn't recognize it and firefox says 'you need to upgrade your flash player to see this video' if I visit youtube. I restarted firefox. I logged in and out.

I've been searching forums but can't find what I'm doing wrong.

(I'm doing this in Lucid)

DougieFresh4U
April 30th, 2010, 09:55 PM
Not sure if this is correct, but I also put the libflashplayer.so file in my firefox plugins

bro
April 30th, 2010, 10:09 PM
I found a solution that works for me. The script attached comes from underneath this youtube video (http://www.youtube.com/watch?v=KzshA3GKqyM).

Download the file, shutdown firefox and in a terminal navigate to the Download folder and type:


sudo ./installfl.sh

Don't know why someone made a youtube video for people who can't watch them :confused: but thank him nevertheless for the script.

It did not kill my firefox in lucid. The line in the script should probably be killall -9 firefox-bin or something. If someone would like to improve on it...

Lensman
May 1st, 2010, 12:31 AM
All I have ever done is to download and extract the 64 bit libflashplayer.so to my home directory.

Open a terminal, sudo and then type-



cp libflashplayer.so /usr/lib64/mozilla/plugins

And you are good to go. Never failed me yet. Yes, you can do the same with Root privilege in Nautilus, but unless you know exactly what you are doing, you could be in for a world of hurt.

Hope this helps.

oldos2er
May 1st, 2010, 01:30 AM
can you help me out? The default install doesn't work for me because my mouse buttons don't interact with the flash player.


Sounds like this bug: https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/410407

Lightstar
May 1st, 2010, 01:51 AM
can you help me out? The default install doesn't work for me because my mouse buttons don't interact with the flash player.
(I'm doing this in Lucid)

I had the same problem, was ready to go back to 32bit

Used this to fix it up, probably similar to the solution you found
http://ubuntuforums.org/showthread.php?t=1358591

_0R10N
May 1st, 2010, 01:57 AM
Found this link...

http://ubuntuforums.org/showthread.php?t=1358591

Seems to work fine now!

Thanks for all the help!


It's works great on Lucid!!! One less problem!:guitar:

mamamia88
May 1st, 2010, 02:00 AM
removed flash plugin non free from synaptic then copied the file into the directory listed. i still have restricted extras installed. flash was still working even after i removed the flash plugin non-free from synaptic. is there a way to tell which version of the plugin firefox is using?

oldos2er
May 1st, 2010, 02:31 AM
Open a new tab in Firefox, location about:plugins

It should show Shockwave Flash, with a path to libflashplayer.so. Mine says "File: /usr/lib/flashplugin-installer/libflashplayer.so". If I run the command "file /usr/lib/flashplugin-installer/libflashplayer.so" I get the output "libflashplayer.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped"

WinterRain
May 1st, 2010, 03:12 AM
I just put mine in the /home/user/.mozilla/plugins folder
seems to work fine their too. Then again I'm the only user on my machine.

It also works in /usr/lib64/mozilla/plugins

WinterRain
May 1st, 2010, 03:16 AM
Open a new tab in Firefox, location about:plugins

It should show Shockwave Flash, with a path to libflashplayer.so. Mine says "File: /usr/lib/flashplugin-installer/libflashplayer.so". If I run the command "file /usr/lib/flashplugin-installer/libflashplayer.so" I get the output "libflashplayer.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped"

That means you need to uninstall flashplugin-installer. That is the 32bit flash with the wrapper. Mine has no path.

After installing non-free-codecs, (which includes ubuntu-restricted-extras) I had to remove flashplugin-installer and manually install 64bit libflashplayer.so

oldos2er
May 1st, 2010, 03:54 AM
That means you need to uninstall flashplugin-installer.

I don't have flashplugin-installer installed.

WinterRain
May 1st, 2010, 04:01 AM
I don't have flashplugin-installer installed.

That's weird that it's showing up then. But it also says dynamically linked, and stripped, so maybe the 64bit flash overrode it.

garba
May 1st, 2010, 12:44 PM
Just downloaded the following tar.gz package from adobe:

http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_1_rc2_linux_041910.tar.gz

after unzipping it I moved the library to the /usr/lib/mozilla/plugin folder, restarted firefox but flash doesn't work. Nice.

garba
May 1st, 2010, 12:59 PM
Looks like there's something wrong with the flash version the adobe download center page links to, I can't get it to work on the Lynx. On the other hand, tried this one (this is the URL the script posted on this thread downloads the plugin from), and it works flawlessly:

http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.45.2.linux-x86_64.so.tar.gz

Viva
May 1st, 2010, 01:13 PM
I just downloaded the 64bit rc from adobe and copied it to ./mozilla/plugins directory in my home folder. Working perfectly so far.

garba
May 1st, 2010, 01:37 PM
can't understand why the 10.1 rc release is not working for me :(

shuttleworthwannabe
May 1st, 2010, 01:46 PM
Guys, here is a excellent HOWTO for dummies: http://www.sucka.net/2010/04/proper-install-of-flash-for-x64-ubuntu/

I think we should give this guy a =D>

DougieFresh4U
May 1st, 2010, 02:39 PM
Forum member carlee has provided anice little installer (http://ubuntuforums.org/showthread.php?t=1414595) for 64 bit flash

Thanks to carlee

mamamia88
May 1st, 2010, 03:42 PM
here is what mine looks like is that correct?

WinterRain
May 1st, 2010, 04:14 PM
can't understand why the 10.1 rc release is not working for me :(

You downloaded the 32bit version.
http://ccounty.files.wordpress.com/2009/08/doh1.jpg
Here (http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.45.2.linux-x86_64.so.tar.gz) is the one you want.

Edit: I just noticed you fixed it. The first link you tried was 32bit though.

oldos2er
May 1st, 2010, 06:44 PM
That's weird that it's showing up then. But it also says dynamically linked, and stripped, so maybe the 64bit flash overrode it.

Just to clarify, I do have flashplugin64-installer installed.

markyb73
May 1st, 2010, 07:03 PM
i have used the ppa for a while in the link shuttleworthwannabe has posted...works a treat :)

mbz99
May 1st, 2010, 09:09 PM
Me, just download the Linux x64 Flash from http://labs.adobe.com unzip it and put it as root at /usr/lib/mozilla/plugins

the current flash player plug-in here

/usr/lib/flashplugin-installer/

legolas_w
May 1st, 2010, 09:29 PM
How I can understand whether I have the real 64 bit flash or the wrapper one?
I used ubuntu-tweak to install flash and actually I installed anything named flash available in the list of applications along with ubuntu extras :d

thansk

dartdog
May 1st, 2010, 09:48 PM
I prefer Chrome on 64 (Chromium to be precise,,) any one have 64 bit flash configured, if so care to share info on what to do?

garba
May 1st, 2010, 10:08 PM
You downloaded the 32bit version.
http://ccounty.files.wordpress.com/2009/08/doh1.jpg
Here (http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.45.2.linux-x86_64.so.tar.gz) is the one you want.

Edit: I just noticed you fixed it. The first link you tried was 32bit though.

oh my that's true, now I feel dumb, I got there looking for "linux 64bit flash download" on google but didn't realize that stuff was meant for 32bit platforms.

oldos2er
May 1st, 2010, 11:58 PM
How I can understand whether I have the real 64 bit flash or the wrapper one?
I used ubuntu-tweak to install flash and actually I installed anything named flash available in the list of applications along with ubuntu extras :d

On Ubuntu tweak (running Lucid), Click Application Center, Other, and you should see Flashplugin64-installer. I would uninstall other versions of flash, if I were you.

legolas_w
May 2nd, 2010, 06:02 AM
On Ubuntu tweak (running Lucid), Click Application Center, Other, and you should see Flashplugin64-installer. I would uninstall other versions of flash, if I were you.



I removed the other flash and installed the 64 bit one but I am facing a problem.

After doing this and restaring firefox it does not show any flash content and instead it shows a message that I need a plugin to view the flash enabled pages correctly.

Any idea?

thanks.

WinterRain
May 2nd, 2010, 06:05 AM
I removed the other flash and installed the 64 bit one but I am facing a problem.

After doing this and restaring firefox it does not show any flash content and instead it shows a message that I need a plugin to view the flash enabled pages correctly.

Any idea?

thanks.

Download this (http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.45.2.linux-x86_64.so.tar.gz) and extract it and put it in /usr/lib/mozilla/plugins. Uninstall the other one first though.

Linuxforall
May 2nd, 2010, 06:06 AM
Alpha working fine here using the sudo mv libflashplayer.so /usr/lib/mozila/plugins method.

WinterRain
May 2nd, 2010, 06:07 AM
Alpha working fine here using the sudo mv libflashplayer.so /usr/lib/mozila/plugins method.

Been working great for me.

moleschott
May 3rd, 2010, 12:15 AM
sudo mv libflashplayer.so /usr/lib/mozila/plugins

it says no such folder. How can i install flash player on my 64 bit system. Please tell me

Viva
May 3rd, 2010, 01:03 AM
sudo mv libflashplayer.so /usr/lib/mozila/plugins

it says no such folder. How can i install flash player on my 64 bit system. Please tell me

Just create a folder called plugins in ./mozilla directory in your home folder and move the file there. Make sure you don't have any other flash plugins installed.

Goldenlight
May 3rd, 2010, 06:22 PM
Very easy to do and I know nothing about using Terminal

1) Step one download latest version from http://labs.adobe.com navigate to 64 bit flash

2)Download and EXTRACT file to Desktop, or any folder you can remember

3)Open Terminal Screen and navigate to where file was downloaded. Example cd Desktop. This is where I extracted it at. Folder directories are case sensitive in Linux. Make sure you type the folder exactly as it appears. Ex.. Documents and documents are completely different folders.

Should look similar to this user@user-desktop:~$

4)Last step type sudo cp ~/libflashplayer.so /usr/lib64/mozilla/plugins
Enjoy 64 bit flash...
:popcorn::popcorn::popcorn:

Credit goes to WinterRain..

(http://labs.adobe.com/)

oldos2er
May 3rd, 2010, 07:20 PM
sudo mv libflashplayer.so /usr/lib/mozila/plugins

it says no such folder. How can i install flash player on my 64 bit system. Please tell me

There's a typo in your command; should be sudo mv libflashplayer.so /usr/lib/mozilla/plugins