PDA

View Full Version : [ubuntu] Can't set max resolution for my Samsung SyncMaster 943



kabeza
April 30th, 2010, 02:56 PM
Hi
I've a Samsung SyncMaster 943, widescreen
I also have a GForce 8400 GS

This monitor supports (as seen on website) a 1440*900 resolution. I've installed the nvidia driver (from homepage) with version 195.36.24

The NVidia X Server Settings shows only a 1360*768 as max possible resolution.

So, I've edited xorg.conf, restarted PC but got no luck... here it is my xorg.conf


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder75) Thu Apr 22 11:44:23 PDT 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Samsung"
ModelName "SyncMaster 943"
#HorizSync 30.0 - 81.0
#VertRefresh 56.0 - 75.0
Modeline "1440x900@75" 146.10 1440 1472 2024 2056 900 917 928 946
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


1. is my modeline correct? Got this from an online modeline calculator

2. The HorizSync and VerRefresh values were modified (got these values from another guy with similar monitor), but didn't work

3. What other stuff should I try to set monitor with max. resolution?

Thanks a lot in advance,

CronoCloud
May 3rd, 2010, 03:23 AM
I'm saw a reference to your post on the Fedora forums. I installed Fedora 12 on Thursday and had the same problem, since my TV/monitor wasn't sending EDID properly, but I got it working with this xorg.conf:




# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (mockbuild@builder.wilsonet.com) Sun Feb 28 16:29:49 EST 2010

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-0"
HorizSync 28.0 - 81.0
VertRefresh 43.0 - 72.0
# 1440x900 @ 60.00 Hz (GTF) hsync: 55.92 kHz; pclk: 106.47 MHz
Modeline "1440x900_60.00" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync
# 1360x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 84.72 MHz
Modeline "1360x768_60.00" 84.72 1360 1424 1568 1776 768 769 772 795 -HSync +Vsync
# 1280x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 80.14 MHz
Modeline "1280x768_60.00" 80.14 1280 1344 1480 1680 768 769 772 795 -HSync +Vsync
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6150SE nForce 430"
Option "IgnoreEDID" "true"
Option "UseEdidFreqs" "false"
Option "UseEdidDpi" "FALSE"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Videocard0"
Monitor "Monitor0"
EndSection

Section "Screen"

Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
# Option "metamodes" "nvidia-auto-select +0+0"
Option "metamodes" "1440x900_60 +0+0"
SubSection "Display"
Depth 24
Modes "1440x900" "1440x900_60.00" "1360x768_60.00" "1280x768_60.00"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


Hope this helps

Ron Rogers Jr. (CronoCloud)

kabeza
May 3rd, 2010, 12:22 PM
I've changed the xorg.conf file, restarted, but no luck
Seems my config is being taken from another file, but dunno which...

http://i.imgur.com/wi2dP.png

kabeza
May 18th, 2010, 12:35 PM
sorry for bumping, but hadn't found anything yet.
Maybe the problem is this lousy monitor I have? Samsung Syncmaster 946 wide

Theoretically max resolution is 1440*900 but can't set more than 1360*768