PDA

View Full Version : [ubuntu] 10.04 refusing to update?



Beware The Birchmen
April 30th, 2010, 02:39 PM
I just installed 10.04 and now when I try and run the update manager it tells me:
Could not download all repository indexes

The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct.

I click close and then it says:
An error occurred

The following details are provided:
E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the list directory

What gives? :confused:

Swatfoot
April 30th, 2010, 02:56 PM
Here is a longshot but wont hurt

" sudo rm /var/lib/apt/lists/partial/* " without quotes then
" sudo apt-get update "

Beware The Birchmen
April 30th, 2010, 03:01 PM
This is really annoying. It is refusing to download ANYTHING. I had the hardware drivers popup and I selected to install Nvidia drivers and it is just sitting there. What is going on? :-&

Beware The Birchmen
April 30th, 2010, 03:12 PM
I can't be the only person having this problem??? The only thing I've done is install 10.04 and then I tried to update...and it gives me that error. Then I restarted and it popped up Restricted Hardware and it tried to download nvidia driver and just sits there. Makes me sad :(

Swatfoot
April 30th, 2010, 03:13 PM
This might sound stupid but I did fresh install of 10.04 LTS last night and I took forever to download the nvidia driver. But you could go into software sources in admin change source to other and then find best server might help.

happyt8r
April 30th, 2010, 03:16 PM
I had issues downloading anything last night after a fresh install. It was unbelievably slow. I assumed the repositories were getting hit hard last night with all the new installs.

Beware The Birchmen
April 30th, 2010, 03:18 PM
This might sound stupid but I did fresh install of 10.04 LTS last night and I took forever to download the nvidia driver. But you could go into software sources in admin change source to other and then find best server might help.
Question duder: I just set it to other and now I'm not getting the error :) but it doesn't find any updates either :confused: when you installed was there anything to update?
Thanks for replies so far.

Beware The Birchmen
April 30th, 2010, 03:18 PM
I had issues downloading anything last night after a fresh install. It was unbelievably slow. I assumed the repositories were getting hit hard last night with all the new installs.
I see...were there updates appearing though???

P4man
April 30th, 2010, 03:22 PM
Maybe there are no updates a few hours after the release and while all ubuntu devs and package maintainers have a hangover from yesterdays release party ? ;)

Beware The Birchmen
April 30th, 2010, 03:27 PM
Maybe there are no updates a few hours after the release and while all ubuntu devs and package maintainers have a hangover from yesterdays release party ? ;)
So you had no updates after install???? True story?

donkyhotay
April 30th, 2010, 03:30 PM
You also have to realize the ubuntu servers generally get slammed the coupld of days after release day. I've noticed I often encounter problems connecting to servers, slow downloads, etc. until things settle down.

Beware The Birchmen
April 30th, 2010, 03:37 PM
You also have to realize the ubuntu servers generally get slammed the next few days after release day. I've noticed I often encounter problems connecting to servers, slow downloads, etc. until things settle down.

Ok thanks if that is all the message is I guess I shouldn't be too concerned??? you dudes are pretty cool cats thanks for the replies

P4man
April 30th, 2010, 03:37 PM
So you had no updates after install???? True story?

I wouldnt know as I just did an update from RC to release last night. Ever since, no new updates no.

billwilson
April 30th, 2010, 03:38 PM
I signed up for the Candidate and was able to update just fine until the day before the official release

Beware The Birchmen
April 30th, 2010, 03:49 PM
I signed up for the Candidate and was able to update just fine until the day before the official release

Ah ok. Sounds like they are getting overran for now. It seems the nvidia driver is actually downloading like you dudes said, but at like 14.4 modem speeds. I'll leave it up and see if it finishes. THanks for the replies again you guys are cool dudes.

Sealbhach
April 30th, 2010, 03:50 PM
Well, maybe try another server. Go to System/Adminisitration/Software Sources, in the Download From box, choose Other, then Select Best Server.

This will ping all the available servers and find the one that is fastest for your location.

.