PDA

View Full Version : [ubuntu] Wrong background color for google desktop tray icon



reablom
April 30th, 2010, 12:46 PM
After installing Ubuntu 10.04 the background of the google desktop tray icon does not match the color of the upper panel. It seems not all themes have this problem. Ambiance, dust, radiance and New wave do, but the other standard themes don't.

I guess one picture says more than a thousand words so:

http://img688.imageshack.us/img688/9872/googleicon.jpg (http://img688.imageshack.us/i/googleicon.jpg/)

Any idea how to solve this?
http://yfrog.com/j4googleiconjhttp://yfrog.com/j4googleiconj

tak1150
April 30th, 2010, 07:11 PM
Same problem here with OOo quicklauncher icon and Beagle icon as well.

miceagol
May 1st, 2010, 12:08 AM
Ditto, but with the terminal and drapes icons. In addition there seems to be a ghost menu attached to my panel. Anyone know how to remove this? It was there also before I upgraded.

http://folk.uio.no/michaeka/tilverden/ghost_panel.png

CalebWishart
May 1st, 2010, 03:38 PM
Ditto, but with the terminal and drapes icons. In addition there seems to be a ghost menu attached to my panel. Anyone know how to remove this? It was there also before I upgraded.

http://folk.uio.no/michaeka/tilverden/ghost_panel.png
It looks like you are running global menu bar. That's the "ghost menu" (bookmarks, tools, help). You can move it over (right click, select move) to use it, or you can remove it (right click, select remove from panel).

As for the wrong color behind the icons, I have the same problem with the Google Desktop icon. I my guess is that the icon doesn't have a transparent background, but I can't find the right icon to change.
I tried changing both the /opt/google/desktop/resources/gdl_small.png and the /opt/google/desktop/resources/gdl_large.png both of which are Google Desktop icons, but that only changed the icons in the application menu.

If anyone knows where the Google Desktop icon that is displayed in the tray is stored, please let me know.

c-shadow
May 1st, 2010, 06:23 PM
Same problem here with more applications and ambiance and radiance.
Clean install with /home partition from karmic. Tried removing ~/.gconf/apps/panel and restarting panel but it didn't help. New created users have the same problem. Both themes do not look good if size is changed above 24 pixels because of this color gradient.

reablom
May 1st, 2010, 06:43 PM
...

As for the wrong color behind the icons, I have the same problem with the Google Desktop icon. I my guess is that the icon doesn't have a transparent background, but I can't find the right icon to change.
...

I don't think transparency is the problem as it works fine in some themes (e.g. "High Contrast Inverse"). It looks more like the wrong background color is chosen: the sand color of the letters and other icons instead of the greyish brown of the bar.

Tuchkata
May 4th, 2010, 09:56 AM
I have the same problem with 10.04. My problem is with VLC and CheckGMail. Still no solution ? With Karmic everything was ok.

xDarkicex
May 4th, 2010, 12:34 PM
I have this problem with a few of the themes off gnome-look

Tuchkata
May 4th, 2010, 07:59 PM
Any solutions ? Is there a launchpad report about the problem ? Hope the fix is coming ...

mister_k81
May 5th, 2010, 12:42 AM
I'm having the same problems with aMSN and VLC in the systray using 10.04. I've never experienced this issue before 9.10, 9.04 or even 8.10. It looks like a bug in the latest version of Gnome....

I really hope someone fixes this in an update, because it's a real eyesore to look at.

Zaff
May 8th, 2010, 09:34 PM
Same problem here with Amarok 1.4 (yes I'm going to change someday) and gmail-notify.

bornagainpenguin
May 11th, 2010, 03:01 PM
Ohh! I know, we could fix real bugs like this one or pull our roots while playing with windicators...

Guess which one the Canonical developers did?

--bornagainpenguin

apostate
May 11th, 2010, 11:32 PM
Ohh! I know, we could fix real bugs like this one or pull our roots while playing with windicators...

Guess which one the Canonical developers did?

--bornagainpenguin



LOL.

Yeah, I can't help think that the interface for Lucid is something of a regression from Karmic. Lame. I wish they would stop "enhancing" GNOME by crippling it even further, and fix the stuff people have been bitching about for years.

reablom
May 13th, 2010, 07:37 PM
Ohh! I know, we could fix real bugs like this one or pull our roots while playing with windicators...

Guess which one the Canonical developers did?

--bornagainpenguin

Are you being sarcastic? Anyway, I find this bug quite annoying.

TWilliam
May 16th, 2010, 09:12 AM
No solution to offer, but I do have a bit of info that might be helpful.

It seems that the issue is not with icon transparency, but with the background color of the Notification Area Applet. It appears that the Notification Area Applet doesn't take its background setting from the Panel, but rather from the theme's Window Background color.

Go to System--->Preferences--->Appearance

Select the Theme tab. Whatever your current theme is should already be highlighted.

Click the Customize button (1, see attached image).

Select the Colors tab. The button indicated by 2 in the attached image will bring up a color selection dialog. If you change the color here, in addition to changing the color of your window backgrounds you will also see the unruly icons in your Notification Area change.

So I guess the question is, is there a way to either change the Notification Area Applet so that it sets its background from the same parameter that sets the Panel background, or to set the Notification Area Applet's background transparent so that the Panel shows through?

blendmaster1024
May 17th, 2010, 05:08 AM
i have part of a solution, at least an area to research (though i do not have this problem with dust-sand).

the theme is setting a different background for the notification area than the rest of the panel. this is going to require some theme knowledge to fix, and it's hard to be specific about how it's doing this and why it looks bad when i don't have the problem myself.

hopefully useful....

Knacker
May 17th, 2010, 09:10 PM
same problem with google-desktop icon. finding a fix for the notification area color/transparency problem is the most important thing, but it would also be great if anyone knows where the google desktop icon is or how it can be changed (i.e. changed to fit with lucid's monochrome taskbar icons).

anyway, +1 people who would be really grateful for a fix to this.

Thanks!

bornagainpenguin
May 19th, 2010, 01:49 AM
Are you being sarcastic?

I'm feeling stressed actually--that's the confused state caused when ones mind overrides the body’s natural desire to choke the living &*%$ out of some %$#* that desperately needs it. And why wouldn't I feel that way? This is yet another bug being ignored while the Canonical developers do anything and everything but fix the problem. The past has shown it does no good to complain, make bug reports, threaten to leave, actually leave, etc etc...

Seeing as there was nothing constructive I could do, I simply aim to amuse myself as I save up my pennies for a MacBook. Sorry if you feel caught in the crossfire. Feel free to amuse yourself by flinging some poo right back at me.


Anyway, I find this bug quite annoying.

You and me both, friend! But what can we do about it? Canonical doesn't give a flying Shuttleworth what you or I like or consider to be a bug.

Not to worry though, if you think things are buggy now, wait for the Meerkat release! :guitar:

--bornagainpenguin

Ascurion
June 10th, 2010, 10:29 AM
I got the same bug running 10.04 but unfortunately no solution either. Since the last message is three weeks old I wanted to ask if there is some progress on this.
Thanks!

desgua
June 14th, 2010, 01:35 AM
None that I'm aware of.

JoeGoalie
June 14th, 2010, 03:52 AM
Really? None? That really sucks. I'm having the same issue with gmote.

t.rei
June 14th, 2010, 09:57 AM
*sigh* and another one. Well at least this bug is getting some PR.

There are quite a lot of apps that show this behavior. Maybe it's time to play around a bit and get a works and works not list:

Works not:


Ambience theme (yey default not working!):
Murrine Engine?
Equinox Engine?
Human theme
Human Clearlooks theme
Radiance theme
WoW-* themes
elementary theme
Amaranth theme (pixmap?)
Clearlooks classic
Dust
Dust Sand
Glider
Glossy
Gorilla
*Contrast*
Inverted
Lush
New Wave
Simple

Sadly I don't seem to have anything installed.

To test this I did: Set panel BG to colored, semi-transparent.
Compared the gajim (ppa version, supposed to be fixed) icon to the way the pidgin icon behaved.
To be fair: there are some themes that explicitly theme the panel and therefore are in the not-working-list.

Can anyone report of any working theme / theme-engine ?

*edit*
This bug is so widespread and so everpresent and such an obvious one... it SHOULD be locatable.
Step one: find engine that does it right,
Step two: if no engine does it right, compare code of working (pidgin) tray icon handling to not working ones (vlc, gajim, google, openoffice,...)Step three: find the fix and spam each and every one of the 'not working' users, be it theme or app with the solution:D

larsenguitars
June 19th, 2010, 03:10 AM
I'm having this problem with the openoffice quickstarter icon.
Using a customized Ambience theme with Ubuntu-Mono-Light icons.

In the attached screenshot, you can see that I'm actually not having this trouble at all with Thunderbird's Firetray icon or the Screenlets Daemon icon.
The Amarok icon is in the Indicator Applet & not the Notification Area.

Maybe someone could find a hack to make the Notification Area get it's color from somewhere else ???
Or maybe there could be a way to make the offending icons show up in Indicator Applet rather than Notification Area ???

160877

afrodeity
June 20th, 2010, 01:44 PM
My google-desktop icons are in /opt/google/desktop/resource/gdl_large.png

and /opt/google/desktop/resource/gdl_small.png

I've uploaded two versions of the above with white on transparent background. Please test them.

http://www.mediafire.com/?sharekey=41d4076c3ada40351f8e0fff488e27e031a0b94c d9ffdb13515d15c8b368bfbe

also

Check this thread http://ubuntuforums.org/forumdisplay.php?f=385

afrodeity
June 20th, 2010, 05:51 PM
The large icon will land up in your menu. I kept the default icon which is much better against a white background.

To refresh the icon:

pkill gnome-panel

However after doing this, my Google-Desktop is no longer showuing up in the panel. I can call it using my hotkey which happens to be Alt-G.

I suspect one has to update the icon cache somehow, or logout and back in.


cd ~/.icons
gtk-update-icon-cache ICONSETNAME


Thus haven't managed to sucessfully use the above icons, will test next boot.

Knacker
June 21st, 2010, 08:08 AM
good idea. but changing icons in /opt/google/desktop/resource/ has no effect on the notification area icons for me. then again, i've not tried too much outside the obvious (which for me is not a lot...).

anyone else have any luck? or any ideas?

neurosk8
June 27th, 2010, 01:41 PM
no soluttions? this problem is so annoiyng

justtrying
June 27th, 2010, 02:50 PM
same problem here too. and in addition i can not make the top panel transparent like i used to do with all previous Ubuntu versions........Please we need a fix.
I used to be able to go to the panel properties and change its background color to solid then adjust the transparency to my liking.....not no more....if you try to do this you end up with a very ugly looking panel..it is like the middle part of the panel becomes transparent but the notification area as well as the places and system areas on the other end remain solid.
Ubuntu used to be a lot more fun.
http://ubuntuforums.org/images/smilies/confused.gif

t.rei
June 28th, 2010, 01:31 AM
If the notification area, the clock and the menu items have backgrounds, this is caused by settings in the theme.

pick your theme - and look for its gtkrc file either in:
/usr/share/themes/<yourthemename>/gtk-2.0/
or in:
~/.themes/<yourthemename>/gtk-2.0/

and look for what is done to the panel in there by searching for 'panel' i.e. and experimenting. ;) Sry, it's way too complex to write in a post but not too difficult to figure out.

Alternatively use a different theme. :/


As for the single items that have no transparent background... I am afraid theres nothing one can do, except wait for updates. Well you COULD ofcourse write the update and submit it to the maintainers... ;)

desgua
July 5th, 2010, 12:57 AM
I could not figure out what to do because I don't find nothing specifically linked to Google Desktop. May be someone knows where the icons are located and we can change that.;)

scotty2718
August 7th, 2010, 12:27 AM
WORKAROUND FOR GMAIL-NOTIFY 1.6.1 TRAY ICON BACKGROUND COLOR NOT MATCHING GNOME PANEL IN UBUNTU 10.04

The problem can be fixed by changing the icons to match the new system theme.

The icons can be found in /usr/share/apps/gmail-notify. The icons that set the tray icon are icon.png (red) and icon2.png (blue). Both have transparent backgrounds, but that doesn't appear to be working with the notification applet. You can either manually change the icons with the ones included in the "new-icons.tar.gz" file or follow the terminal instructions below.

I've included instructions below:

Download the attached new-icons.tar.gz file and extract the contents to the desktop. To extract the contents, first move "new-icons.tar.gz" to your desktop, right click the icon, and then choose "extract here." A new folder called "new-icons" should now be visible on your desktop.

Before continuing, make sure the desktop has a new directory named "new-icons" with two pictures inside (icon.png and icon2.png).

Now run the following commands one at a time in the terminal:

mkdir ~/Desktop/original-icons
cd /usr/share/apps/gmail-notify
cp icon.png icon2.png ~/Desktop/original-icons
cd ~/Desktop/new-icons
sudo cp icon.png icon2.png /usr/share/apps/gmail-notify
cd ~/Desktop/new-icons
rm icon.png icon2.png
rmdir ~/Desktop/new-icons

Alternatively, you could run the bash script I attached. Note, the script has to be run after the "new-icons" directory exists.

How to run the script:
0) Make sure the "new-icons" folder is on your desktop
1) Download the "icon-change.sh" file and put it on the desktop.
2) Right click the file and choose properties.
3) Click on the "permissions" tab and check "allow executing file as program".
4) Double click the file.
5) When the dialog box pops up, choose "run in terminal"

So, what just happened? Well, three things.

1) The icons in the gmail-notify have been replaced with the ones in the "new-icons" folder.

2) The old icons have been backup up in the folder "original-icons" that is now on your desktop.

3) The "new-icons" folder you extracted earlier has been deleted.

It may take some time for the notifier icon to change (you have to wait until it checks for mail again). You could always restart the application or click the "Check now" button if you want it to change immediately.

Knacker
August 13th, 2010, 11:36 PM
Just so that the above post doesn't cause anyone any confusion: please note that this is not a work around for the problem discussed in this thread. This is a fix for Gmail-Notify and has nothing to do (as far as I can tell) with google-desktop icon problem...which is still very much broken.


WORKAROUND FOR GMAIL-NOTIFY 1.6.1 TRAY ICON BACKGROUND COLOR NOT MATCHING GNOME PANEL IN UBUNTU 10.04

The problem can be fixed by changing the icons to match the new system theme.

The icons can be found in /usr/share/apps/gmail-notify. The icons that set the tray icon are icon.png (red) and icon2.png (blue). Both have transparent backgrounds, but that doesn't appear to be working with the notification applet. You can either manually change the icons with the ones included in the "new-icons.tar.gz" file or follow the terminal instructions below.

I've included instructions below:

Download the attached new-icons.tar.gz file and extract the contents to the desktop. To extract the contents, first move "new-icons.tar.gz" to your desktop, right click the icon, and then choose "extract here." A new folder called "new-icons" should now be visible on your desktop.

Before continuing, make sure the desktop has a new directory named "new-icons" with two pictures inside (icon.png and icon2.png).

Now run the following commands one at a time in the terminal:

mkdir ~/Desktop/original-icons
cd /usr/share/apps/gmail-notify
cp icon.png icon2.png ~/Desktop/original-icons
cd ~/Desktop/new-icons
sudo cp icon.png icon2.png /usr/share/apps/gmail-notify
cd ~/Desktop/new-icons
rm icon.png icon2.png
rmdir ~/Desktop/new-icons

Alternatively, you could run the bash script I attached. Note, the script has to be run after the "new-icons" directory exists.

How to run the script:
0) Make sure the "new-icons" folder is on your desktop
1) Download the "icon-change.sh" file and put it on the desktop.
2) Right click the file and choose properties.
3) Click on the "permissions" tab and check "allow executing file as program".
4) Double click the file.
5) When the dialog box pops up, choose "run in terminal"

So, what just happened? Well, three things.

1) The icons in the gmail-notify have been replaced with the ones in the "new-icons" folder.

2) The old icons have been backup up in the folder "original-icons" that is now on your desktop.

3) The "new-icons" folder you extracted earlier has been deleted.

It may take some time for the notifier icon to change (you have to wait until it checks for mail again). You could always restart the application or click the "Check now" button if you want it to change immediately.

Knacker
August 20th, 2010, 07:31 PM
though it seems like google is paying, and intends to pay zero attention to google-desktop on linux, i've posted questions/requests on the google group for google-desktop on linux...

i hope i described the problem correctly:

http://groups.google.com/group/google-desktop-linux-something-broken/browse_thread/thread/c9bcc6bdb62d7583

florin-ganea
September 1st, 2010, 12:19 PM
Well... it's within Google application; no workaround spotted.

I did the following:
- thunderbird (3.1.2) with firetray (0.2.8) add-on
- I changed in firetray configuration the icon both to:
---- /opt/google/desktop/resource/gdl_large.png
and
---- /opt/google/desktop/resource/gdl_small.png
In both cases the icon was shown perfectly. Therefore the problem is not in icons, nor in notification area, nor in gnome, nor in gtk.

So, unless Google fixes it or someone likes to decompile GDS... we need to live with it.

All the best,
Florin

florin-ganea
September 2nd, 2010, 09:20 AM
I have performed further testing... and it might be the case that also the theme (controls part) has something wrong.

I noticed that the GDS icon is displayed perfectly in the following themes (controls):
- clearlooks
- clearlooks classic
- crux
- dust sand
- high contrast - all
- industrial
- inverted
- mist
- qtcurve
- raleigh
- redmond
- simple
- thin ice

Other themes display the GDS icon wrong:
- ambiance
- dust
- new wave - all
- radiance

All the best,
Florin

fpoehler
October 25th, 2010, 07:31 PM
The themes that work should be the ones which have the same panel background as normal application windows. That's why the problem is not apparent there. However, newer themes often use a different color or a background image for the panel.

The fix is to apply the panel's properties (background color or background image) to GtkPlug widget class, which is not considered in most stock themes.

Steps:


Find out your panel's background color or the path to its background image (in case it has one).
For the color the hexadecimal value is needed (e.g. "#A1B2C3).
The image in most cases resides in /usr/share/themes/<Your_Theme's_Name>/gtk-2.0/ or a subfolder of that.

For Radiance theme it is

/usr/share/themes/Radiance/gtk-2.0/apps/img/panel.png
(In case there is a background image) copy the background image to your home folder (or a subfolder of your home folder).
Open (or create) the file named ".gtkrc-2.0" in your home folder.
Copy the following into the file:

style "GoogleDesktopIconFix" {
# In case your panel has a background image, add this line
bg_pixmap[NORMAL] = "subfolder/panel.png" # replace "panel.png" with the actual file name or (relative) path

#In case your panel has no background image, add this line
bg[NORMAL] = "#000000" # replace "#000000" with your color value
}
class "*oPlug" style "GoogleDesktopIconFix"
Open a terminal and type
pkill gnome-panel
enjoy :-)

Zaff
October 25th, 2010, 08:03 PM
The themes that work should be the ones which have the same panel background as normal application windows. That's why the problem is not apparent there. However, newer themes often use a different color or a background image for the panel.

The fix is to apply the panel's properties (background color or background image) to GtkPlug widget class, which is not considered in most stock themes.

Steps:


Find out your panel's background color or the path to its background image (in case it has one).
For the color the hexadecimal value is needed (e.g. "#A1B2C3).
The image in most cases resides in /usr/share/themes/<Your_Theme's_Name>/gtk-2.0/ or a subfolder of that.

For Radiance theme it is

/usr/share/themes/Radiance/gtk-2.0/apps/img/panel.png
(In case there is a background image) copy the background image to your home folder (or a subfolder of your home folder).
Open (or create) the file named ".gtkrc-2.0" in your home folder.
Copy the following into the file:

style "GoogleDesktopIconFix" {
# In case your panel has a background image, add this line
bg_pixmap[NORMAL] = "subfolder/panel.png" # replace "panel.png" with the actual file name or (relative) path

#In case your panel has no background image, add this line
bg[NORMAL] = "#000000" # replace "#000000" with your color value
}
widget "GtkPlug" style "GoogleDesktopIconFix"
Open a terminal and type
pkill gnome-panel
enjoy :-)

Would this work for wine applications ? I'm running spotify and it's the only icon still having this problem (banshee used to do the same in 10.04 but it's not anymore).
I'll look into it but if anyone knows how to fix spotify's icon in the tray that'd be great.

fpoehler
October 25th, 2010, 09:02 PM
Unfortunately I can't answer your question since I don't have Wine applications in use.
I suggest you simply try it out. It does not take you longer than 2 minutes and if it does not work for you, just delete the image and the .gtkrc-2.0 file (or undo the changes if the file was already there), restart the gnome panel and you're done.

Zaff
October 25th, 2010, 09:26 PM
Unfortunately I can't answer your question since I don't have Wine applications in use.
I suggest you simply try it out. It does not take you longer than 2 minutes and if it does not work for you, just delete the image and the .gtkrc-2.0 file (or undo the changes if the file was already there), restart the gnome panel and you're done.

Just tried it, doesn't look like it's working though, could be a wine problem. Not too concerned about it, just thought I'd give it a shot.
Thanks.

fpoehler
October 25th, 2010, 09:39 PM
Maybe the icon itself has no transparent background. In that case, the only way is to replace it with another icon that does have a transparent background.

florin-ganea
November 1st, 2010, 03:59 PM
It works for me; thanks.

florin-ganea
November 1st, 2010, 04:43 PM
I use radiance; and the fix has an interesting effect on the "lock" screen :-)
I have reverted the changes.

fpoehler
November 2nd, 2010, 01:46 AM
Ooops... Looks nice :) . Didn't notice that since I never lock my screen.

Try replacing class "GtkPlug" by class "*oPlug" to fix the issue.

florin-ganea
November 3rd, 2010, 08:52 AM
Now it's better; thank you.

vanbosco
November 21st, 2010, 10:06 AM
It works also for me, thanks a lot. :D

daucourt
November 22nd, 2010, 10:31 AM
Works for me on lucid LTS. Now beagle search icon has correct background.
During the step by step fix, I had to close gnome session ("pkill gnome-panel" what not enough)
Thanks a lot
Thierry

reablom
November 22nd, 2010, 08:16 PM
Ok. Works fine for me.
Thanks!

Redlichd
December 24th, 2010, 10:54 AM
Ok guys so im new to this but bear with me i think i have it fixed
the problem seems to be with the theme itself, more specifically ambiance which is the default theme for 10.10 im not sure about 10.04
you can solve this by copying this into your terminal
sudo gedit '/usr/share/themes/Ambiance/gtk-2.0/apps/gnome-panel.rc'
then you will see the file then put a # in front of line 10 where it says "bg_pixmap[NORMAL] = "img/panel.png"
log out then log back in and all should be well :p

gamhead
February 20th, 2011, 05:20 PM
Good work !

fpoehler is the man!

Now my utorrent and google desktop integrate perfectly - thanks! I went through so many rubbish forums before I found this.. :KS

deezer
February 28th, 2011, 02:27 PM
fpoehler you are the man!

Original poster, please mark as solved!

shahraeini
April 10th, 2011, 04:36 PM
thanks fpoehler, It works great for me, but I have a question.
for other application what should we do?! I think this code works only for google desktop.

The themes that work should be the ones which have the same panel background as normal application windows. That's why the problem is not apparent there. However, newer themes often use a different color or a background image for the panel.

The fix is to apply the panel's properties (background color or background image) to GtkPlug widget class, which is not considered in most stock themes.

Steps:


Find out your panel's background color or the path to its background image (in case it has one).
For the color the hexadecimal value is needed (e.g. "#A1B2C3).
The image in most cases resides in /usr/share/themes/<Your_Theme's_Name>/gtk-2.0/ or a subfolder of that.

For Radiance theme it is

/usr/share/themes/Radiance/gtk-2.0/apps/img/panel.png
(In case there is a background image) copy the background image to your home folder (or a subfolder of your home folder).
Open (or create) the file named ".gtkrc-2.0" in your home folder.
Copy the following into the file:

style "GoogleDesktopIconFix" {
# In case your panel has a background image, add this line
bg_pixmap[NORMAL] = "subfolder/panel.png" # replace "panel.png" with the actual file name or (relative) path

#In case your panel has no background image, add this line
bg[NORMAL] = "#000000" # replace "#000000" with your color value
}
class "*oPlug" style "GoogleDesktopIconFix"
Open a terminal and type
pkill gnome-panel
enjoy :-)

fpoehler
April 10th, 2011, 08:11 PM
This code may or may not work with other applications. The name "GoogleDesktopIconFix" is only a kind of variable you assign key/value pairs to and then say elements of a certain class shall apply what's defined in that variable. It doesn't mean it works only for the Google Desktop icon.

So the key to the problem is not the style "GoogleDesktopIconFix" but the class name "*oPlug": Every display element (e.g. a window, a button or a menu) has a GTK class and some parent classes (e.g. a toolbar is a special kind of a container. You can find a reference here (http://developer.gnome.org/gtk/2.24/gtkobjects.html)). Moreover, a developer can create subclasses with own names.

If you say class "*foo" style "bar", every element whose class name ends with "foo" will apply the style defined in "bar", e.g. a certain background color. (The "*" is a wildcard as known from file name searches).

So if you know the class name of the tray icon of your application, it's easy. Change "*oPlug" into that name and you shoud be done (provided the application does not use an icon with intransparent background). Unfortunately, there is no sure formula to find out that name (at least I don't know it). You'll find it somewhere in the source code, that's all I can say.

If you don't want to dig into source code, you can solve the issue the trial-and-error way:


Comment out the bg_pixmap line in the gtkrc and change the bg[NORMAL] color value to some "crazy" color (e.g. #F00, which is pure red).
Change the class name in gtkrc to something else and save file.
Open gnome-appearance-properties and choose any other theme.
After the appearance has changed, change back to the theme of the gtkrc you are editing.
See what has changed now (=what is now red in my example) and what has not.
Repeat steps 2-5 until only the icon of your application has changed (it's recommended to have some more applications present in order to notice unwanted changes).
Undo step 1, then type pkill gnome-panel in terminal. Everything should look good now.

(For step 2 - do it methodically. First try excluding letters by changing the class name to "*x*" where x is a single letter (case matters!) and replace step 3-4 with typing pkill gnome-panel in a terminal. If your icon has not changed in step 5, you know that letter is not in the class name you want. After you are through, try combinations of 2 letters and so on).

But be warned: This is very annoying and may take a lot of time. Only do it if the ugly icon is even more annoying.

naczelny1
November 29th, 2011, 08:32 PM
Those are all crude workarounds. The only solution is to fix notification area so that it wouldn't take the bg colour from window bg, but instead from gnome-panel, or - better yet - to have this customisable, including opacity value. How about we spam <ubuntu-desktop@lists.ubuntu.com> about this until someone reacts?