PDA

View Full Version : [ubuntu] Start X without monitor attached



pwhysall
April 30th, 2010, 09:18 AM
I have an Ubuntu Linux 10.04 installation which I would like to use via remote desktop. Everything works perfectly if I start the computer with a monitor attached. If I do not, X fails to start because it cannot find any screens.

How can I force X to start up without a monitor attached?

Aearenda
April 30th, 2010, 09:33 AM
I think you should be able to do this so:

1. Attach a monitor, and start Ubuntu but don't login.

2. Using Ctrl/Alt/F1, switch to a console

3. Login using your normal credentials

4. Type
sudo stop gdmThis stops the running xserver

5. Type
sudo Xorg -configureThis should blank the screen briefly and generate a file called xorg.conf.new.

6. Type
sudo mv xorg.conf.new /etc/X11/This moves the generated file into the right spot.

7. Type
sudo nano /etc/X11/xorg.confMove down to the line that says
Section "Monitor"and then to the next line that starts with EndSection. Immediately before that line add a new line like this:
Option "IgnoreEDID"Then save and close the file (Ctrl and X, then follow the prompts). This tells X to ignore what the monitor says, or not.

8. Type
sudo start gdmMake sure the login window comes up. You might need to set up autologin and remote desktop to not require user authorisation.

9. Shut down, unplug the monitor, and restart.

10. See if you can connect!


If you need to undo this, just run this command at a console:
sudo mv /etc/X11/xorg.conf ~/xorg.conf.badThen restart the computer.

pwhysall
April 30th, 2010, 10:31 AM
Thanks. Your time is appreciated.

I'm pretty au fait with Linux (been using it for 15 years) so I'm familiar with the file-editing and moving and stuff. However, I've not been in the position of having to have X start up like this before, and nor have I had to twiddle with X since it went all automagic. Such is the price of progress, I guess!

Anyway, the IgnoreEDID option doesn't seem to have had any effect and X doesn't start if the monitor is disconnected.

Here is my /etc/X11/xorg.conf (generated by X and with the IgnoreEDID option manually added):


Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"
EndSection

Section "Module"
Load "dri"
Load "extmod"
Load "glx"
Load "dri2"
Load "record"
Load "dbe"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
Option "IgnoreEDID"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
#Option "PageFlip" # [<bool>]
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "82915G/GV/910GL Integrated Graphics Controller"
BusID "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Here is my /var/log/Xorg.0.log


X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-25-server i686 Ubuntu
Current Operating System: Linux odin 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686
Kernel command line: root=UUID=0711e6da-2ca3-42ce-bdd1-59033fef8e03 ro quiet splash
Build Date: 23 April 2010 05:11:50PM
xorg-server 2:1.7.6-2ubuntu7 (Bryce Harrington <bryce@ubuntu.com>)
Current version of pixman: 0.16.4
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Apr 30 10:20:24 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/usr/lib/X11/xorg.conf.d"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(**) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
built-ins,
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
built-ins
(**) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(II) Loader magic: 0x81f0e80
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 6.0
X.Org XInput driver : 7.0
X.Org Server Extension : 2.0
(--) using VT number 7

(--) PCI:*(0:0:2:0) 8086:2582:107b:4037 Intel Corporation 82915G/GV/910GL Integrated Graphics Controller rev 4, Mem @ 0xffa
80000/524288, 0xd0000000/268435456, 0xffa40000/262144, I/O @ 0x0000ec00/8
(II) Open ACPI successful (/var/run/acpid.socket)
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.7.6, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.7.6, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 1.7.6, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.7.6, module version = 1.1.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.7.6, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.7.6, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "intel"
(II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
compiled for 1.7.6, module version = 2.9.1
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 6.0
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
4 Series, G45/G43, Q45/Q43, G41, B43, Clarkdale, Arrandale
(II) Primary Device is: PCI 00@00:02:0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: drmOpenMinor returns 9
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
(==) intel(0): Depth 24, (--) framebuffer bpp 32
(==) intel(0): RGB weight 888
(==) intel(0): Default visual is TrueColor
(II) intel(0): Integrated Graphics Chipset: Intel(R) 915G
(--) intel(0): Chipset: "915G"
(II) intel(0): Output VGA1 using monitor section Monitor0
(II) intel(0): EDID for output VGA1
(II) intel(0): Output VGA1 disconnected
(WW) intel(0): No outputs definitely connected, trying again...
(II) intel(0): Output VGA1 disconnected
(WW) intel(0): Unable to find initial modes
(==) intel(0): video overlay key set to 0x101fe
(EE) intel(0): No modes.
(II) UnloadModule: "intel"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

ddxSigGiveUp: Closing log

Aearenda
April 30th, 2010, 12:21 PM
Ok, I've had the chance to check the xorg.conf on the computer I have set up like this now. What I did earlier was from memory. When typing the post I forgot that I had added sync ranges in the Monitor section:
HorizSync 30.0 - 72.0
VertRefresh 50.0 - 160.0
Also, seeing your xorg.conf makes me think it would be worth setting this in the Device section:
Option "NoDDC" "true"My driver doesn't have that option, but I've a memory of needing it on a different machine a couple of years ago.

Sorry about the unnecessary detail, better safe than sorry!

PS: Just noticed these in the Screen section as well:

DefaultDepth 24
And under the 24-bit section,

Modes "1152x864@75" "1024x768@75"This is to suit the particular monitor that is present, but usually off.

Aearenda
April 30th, 2010, 12:31 PM
Useful thread: http://ubuntuforums.org/showthread.php?t=1462350 links to https://wiki.ubuntu.com/X/Config/Resolution#Setting%20xrandr%20commands%20in%20kdm/gdm%20startup%20scripts

Also see http://ubuntuforums.org/showthread.php?t=1292212

pwhysall
May 1st, 2010, 12:21 PM
Thanks for the additional suggestions. I'm not making any headway, unfortunately.

I seem to vary between breaking xorg.conf and X spitting its dummy out when it realises there's nothing hanging off the VGA port.

In idle moments, I whimsically dream of a world where I can add a line to xorg.conf that simply says:


Option "HeadlessStartup" "True"
...but surely that'd be a bit too easy.

In the meantime, would you mind showing me, in xorg.conf, where I'd add the relevant bits to manually define a screen and its modes?

Aearenda
May 1st, 2010, 01:04 PM
Oh dear! Maybe your video card has some quirk that makes this impossible. Looks like others have gone about this in other ways (http://forums.fedoraforum.org/showthread.php?t=198660), such as installing a VNC server. It is certainly much faster that way. Personally I use ssh to connect to remote systems and if I have to I run GUI applications this way:
ssh -Y -C -p PORT user@machineThis starts a commmand session, and then I type the name of the app to start, eg firefox. It starts up the window locally, but runs remotely. This separation of GUI from cpu is what the X server was originally designed to do! I use a non-standard port for ssh to avoid the inevitable password break-in attempts on port 22. I also use key-only authentication.


Anyway, here are the bits I suggested added to your xorg.conf posted above:


Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"
EndSection

Section "Module"
Load "dri"
Load "extmod"
Load "glx"
Load "dri2"
Load "record"
Load "dbe"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
Option "IgnoreEDID"
HorizSync 30.0 - 72.0
VertRefresh 50.0 - 160.0
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]

Option "NoDDC" "true"

#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
#Option "PageFlip" # [<bool>]
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "82915G/GV/910GL Integrated Graphics Controller"
BusID "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"

DefaultDepth 24

SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24

Modes "1024x768@60"

EndSubSection
EndSection

The modes line should really be adjusted to suit whatever monitor you might attach - I just put 1024x768 at 60Hz because it's safe.


EDIT: Maybe the IgnoreEDID line should be like this:

Option "IgnoreEDID" "1"

Also, if you really aren't going to use the local screen much, you could change to the vesa driver - change intel to vesa in the device section, driver line.

pwhysall
May 1st, 2010, 01:15 PM
Many thanks. I'll try that.

Ironically, I'm writing this reply in another installation of 10.04 - this time, inside a Parallels VM.

Aearenda
May 1st, 2010, 01:19 PM
Lucky you! I've been wrestling with trying to get a friend's fried Windows XP re-installed on a machine with a SATA controller, missing the oem setup disks. Lucid runs on it just fine....

efflandt
May 1st, 2010, 04:22 PM
I do not understand "why" you are even trying to run X if you have no monitor (nothing to see).

Perhaps you want to run some sort of vnc server instead, which runs its own background X server.

Or you can run X programs remotely to display at your location with ForwardX11 yes in ~/.ssh/config

pwhysall
May 2nd, 2010, 05:34 PM
I do not understand "why" you are even trying to run X if you have no monitor (nothing to see).

Perhaps you want to run some sort of vnc server instead, which runs its own background X server.

Or you can run X programs remotely to display at your location with ForwardX11 yes in ~/.ssh/config
I just want to take control of the extant X display, using Avahi to advertise screen sharing, from my Mac. This is installed, configured and, most importantly of all, works, as long as X starts correctly on the Linux box.

I don't want to run X11 on the Mac (everything running remotely from the Linux box will look rubbish, and anyway, I don't want to ssh into the box to start chucking application windows back the other way) and nor do I want to use an additional VNC server. The session I want is the session on the screen.

Aearenda
May 2nd, 2010, 10:24 PM
Did you try with the vesa driver?

pwhysall
May 3rd, 2010, 08:35 PM
Did you try with the vesa driver?
Yes. It didn't help, though; it just can't get enough of that need-a-monitor lovin'.

conradin
May 3rd, 2010, 09:15 PM
Looks like the software side is having some issues. There is a such thing as a vga loopback adapter which basicaly tricks your hardware into thinking it has a monitor attached whether it does or not.
You can look for schematics online.
or purchase one.
or wait for me to disassemble mine an post back with schematics

EDIT: VGA TERMINATOR PLUG (not loopback)
This forums discusses it.
http://www.mp3car.com/vbulletin/general-hardware-discussion/1763-how-does-video-card-detect-vga-monitor-present.html|

pinout:
vga loopback
pin 10 > 11 jumper
pin 1 > 6 Resistor 75 Ohms
pin 2 > 7 Resistor 75 Ohms
pin 3 > 8 Resistor 75 Ohms

mr_git
August 24th, 2010, 01:30 PM
I was having the exact same problem - I want to run X on a machine that (for now) doesn't have a monitor attached.

Using the intel driver, X was finding no monitors attached, and giving up:


(II) intel(0): Output VGA disconnected
(WW) intel(0): No outputs definitely connected, trying again...
(II) intel(0): Output VGA disconnected
(WW) intel(0): Unable to find initial modes
(EE) intel(0): No valid modes.
(II) UnloadModule: "intel"

I stumbled across a solution pieced together from several different threads on these and other forums.

First I needed to make a basic xorg.conf file, in which I specified the VESA driver rather than the intel one (see bottom of post for my xorg.conf)

This led to me seeing a different error:



(EE) VESA: Kernel modesetting driver in use, refusing to load
(WW) Falling back to old probe method for vesa
(EE) No devices detected.


I then had to add nomodeset to my grub boot options (used to be in /boot/grub/menu.lst but now in /etc/default/grub)


GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

...and run update-grub.

With some basic settings for the (non-existent) monitor, the result is that I get X running with no monitor plugged in, using the VESA driver, and with a decent resolution - which is fine for what I wanted it for.

My xorg.conf:



Section "Monitor"
Identifier "Monitor0"
HorizSync 31-81
VertRefresh 56-75
EndSection

Section "Device"
Identifier "Card0"
Driver "vesa"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
EndSection

Hope that helps someone.

Compu-king
September 8th, 2010, 01:30 PM
Thanks, Solved my problem perfectly! Just out of interest, how would I go about downscaling the resolution? 1024x768 would be enough for me - At it is now, I have to scroll around inside the VNC Viewer window.

Thanks though.

Aearenda
September 9th, 2010, 12:06 AM
Thanks, Solved my problem perfectly! Just out of interest, how would I go about downscaling the resolution? 1024x768 would be enough for me - At it is now, I have to scroll around inside the VNC Viewer window.

If you go back to post 4, and look for the line that says
Modes "1152x864@75" "1024x768@75"
you should be able to use that to get what you want by omitting the higher settings.

OR, try using the Monitors control panel from System->Preferences to set a desired resolution. This creates a file called .config/Monitors.xml under your home directory, which is easy to change manually, and this causes X to set your per-user desired resolution at login time.

yengip
December 17th, 2011, 09:55 PM
Sorry for resurrecting an old thread but it was the most helpful I found.

To create a headless system using 11.10 desktop distro with unity, I mostly followed the instructions earlier with some key changes.

1. the service you have to stop and start appears to be called "lightdm" not "gdm" (I guess 'cos I'm using unity not gnome).

2. I just set up my main user to log in automatically 'cos I couldn't get vncserver to work and I ran out of patience with the potential "userless" solutions I managed to find. I enabled desktop sharing using the GUI while I had a monitor connected.

3. I installed openssh so I could do terminal stuff from my windows pc.

3. My Xorg -configure gave me a file with loads of entries that just didn't work when I tested it so, with reference to the man page (http://www.x.org/archive/X11R6.8.1/doc/xorg.conf.5.html) I cobbled together an xorg.conf that ultimately looked like this:


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
Option "IgnoreEDID"
HorizSync 30.0 - 72.0
VertRefresh 50.0 - 160.0
EndSection

Section "Device"
Identifier "Default Device"
Option "NoLogo" "True"
Option "NoDDC" "True"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Default Device"
Monitor "Monitor0"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Note: one monitor, one device and one screen that references them.

At first I was getting a remote desktop that was stuck at 640x480 - difficult to use. The key to getting the right resolution appears to be the Modes statement in the Display subsection. Unless you're prepared to define your own mode (and you need a lot of technical info to do that) you're stuck with the built in VESA standard modes. I looked them up on Wikipedia and chose a fairly hi-res one. I has to drop the "@60" from the end to get the server to recognise it.

Now I have a headless system that boots up on it's own and lets me use VNCViewer to get a GUI and ssh to get a terminal (and sftp). I'm not concerned with security here as it's all inside my LAN.

Anyway, hope that helps someone else having the same challenges.

Ian

oldos2er
December 18th, 2011, 02:19 AM
Closed, necromancy.