PDA

View Full Version : 10.04 samsung r522 ati hd4650 - unable to change brightness



nyash
April 29th, 2010, 11:39 PM
Hi
I installed the LL 10.04 desktop x64 edition on a samsung r522 with a ati mobility hd 4650 graphics card.

When the system was being run on the default drivers, I was able to change the brightness in power managment, by moving the screen display brightness slider down.

After turning the ATI proprietary drivers on and restarting the system, the screen brightness is set to 100%.
Moving the slider in power management has no effect now with the ATi drivers on.

Is there a way to force the brightness value in a file somewhere or sth like that?

Thx.

Oweran
April 30th, 2010, 11:48 AM
Hello,

I've got the exact same problem with my Samsung R620 and a Mobility Radeon HD 4300 Series card.
I have install the latest Ati Catalyst Driver, but, it's still the same.
Otherwise, the 3D run smooth, and I've got a good score with glxgears, no problem with compiz...
The only thing is the brightness and it won't go down...

If I find something, I'll tell you right away :/

P.S : Works fine with the free drivers. So, in the meanwhile, you can just desactivate the proprietary drivers and you'll be good to go.

Oweran
May 3rd, 2010, 01:08 PM
Bump...

Someone've got the same problem and/or have an idea about that issue ?

My ATI keeps boiling up with the free ati drivers, so my laptop is very hot... That's the main problem of those drivers. (The second one is that I loose about 5000 fps...)

nyash
May 3rd, 2010, 03:58 PM
Exactly, the problem with the free drivers is that they heat up the computer substantially... :/

nyash
May 6th, 2010, 10:11 AM
Ok I found a solution, its quite limiting, but it works:

1. Edit this file: (make sure you have root rights)

/etc/default/grub

2. replace this line (preferably comment it out, so that just in case you can set it back in the future)
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

with this:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset acpi_backlight=vendor"

3. type
sudo update-grub


1. Restart your laptop
2. Press F2 at booting screen (in order to access BIOS)

3. I dont remember which tab it was, so you have to check them all, but there is a setting like this:
Brightness Control: [Auto]
change it to
Brightness Control: [User Controlled]

4. Save and Exit

Now when your computer is at the GRUB boot loader, use your function keys FN-Arrow down or Up
to change the screen brightness

The settings will persist and will stay in Linux once it loads.

metallus
May 6th, 2010, 03:45 PM
Ok I found a solution, its quite limiting, but it works:

1. Edit this file: (make sure you have root rights)

/etc/default/grub

2. replace this line (preferably comment it out, so that just in case you can set it back in the future)
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

with this:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset acpi_backlight=vendor"

3. type
sudo update-grub


1. Restart your laptop
2. Press F2 at booting screen (in order to access BIOS)

3. I dont remember which tab it was, so you have to check them all, but there is a setting like this:
Brightness Control: [Auto]
change it to
Brightness Control: [User Controlled]

4. Save and Exit

Now when your computer is at the GRUB boot loader, use your function keys FN-Arrow down or Up
to change the screen brightness

The settings will persist and will stay in Linux once it loads.

this did not work for me. i have ubuntu 10.04 64 bit with ati mobility radeon 3450. worked fine in 9.10...
any other ideas?

nyash
May 6th, 2010, 04:11 PM
this did not work for me. i have ubuntu 10.04 64 bit with ati mobility radeon 3450. worked fine in 9.10...
any other ideas?

Note that you can dim the brightness down with FN keys at the GRUB loading screen only. The function keys or the slider won't work in Linux.

Personaly for me that's a decent compromise - at least the brightness doesn't kill my eyes.

metallus
May 6th, 2010, 07:58 PM
Note that you can dim the brightness down with FN keys at the GRUB loading screen only. The function keys or the slider won't work in Linux.

Personally for me that's a decent compromise - at least the brightness doesn't kill my eyes.

i can "sudo echo 100 > /proc/acpi/video/VGA/LCD/brightness" or any value i want for the brightness after i sudo chmod 646 that file, but that is not a normal(or sane) way to change the brightness. the shortcut keys worked for me in 9.10 . if I do the vendor edit in grub than the echo trick does not work anymore. clearly the fault is with the ati proprietary driver. i upgraded to .33 kernel and the problem persists. I will probably upgrade to .34rc kernel and post results tomorrow.
Cheers!

Oweran
May 6th, 2010, 08:56 PM
Yeah ! It works !
I already tried this, but it didn't worked because I hadn't made the change in the bios.
(I've got a Samsung R620, but it's the same)

Thanks a lot !

afyoco
May 16th, 2010, 04:47 PM
I cannot believe that this is the solution for the problem. Come on, do I need to reboot whenever I want to change the screen brightness? It doesn't seem logical...

Is it a problem with the Samsung LCD?

krige
June 22nd, 2010, 02:32 PM
Ok I found a solution, its quite limiting, but it works:

1. Edit this file: (make sure you have root rights)

/etc/default/grub

2. replace this line (preferably comment it out, so that just in case you can set it back in the future)
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

with this:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset acpi_backlight=vendor"

3. type
sudo update-grub


1. Restart your laptop
2. Press F2 at booting screen (in order to access BIOS)

3. I dont remember which tab it was, so you have to check them all, but there is a setting like this:
Brightness Control: [Auto]
change it to
Brightness Control: [User Controlled]

4. Save and Exit

Now when your computer is at the GRUB boot loader, use your function keys FN-Arrow down or Up
to change the screen brightness

The settings will persist and will stay in Linux once it loads.

I also have Samsung R522 with the same brightness control problem.

I have followed the previous instructions and they did work but I didn't need to change the "Brightness Control" option in the BIOS (also because I could not find it).

Now I am able to change the brightness at boot time. It would be nice to be able to do that also while the OS is running.

krige
June 23rd, 2010, 09:54 AM
By the way, the brightness control function keys are not the only ones not working. Please see the following post:
http://ubuntuforums.org/showthread.php?t=1470043