View Full Version : [ubuntu] 10.04 Lucid Touchpad only enabled at login

April 29th, 2010, 06:40 PM
Hi folks, got an odd problem. I've upgraded to lucid on an HP DV6000 series laptop, and my touchpad was working ok. I had WoW running under WINE and I pressed the touchpad toggle button. It froze the keyboard and touchpad completely. After a restart, my keyboard is back and the touchpad works fine (with the enable/disable toggle button) at the login screen, but as soon as I log in and get to my desktop the touchpad is disabled. Anything I can check or reset?



April 29th, 2010, 08:39 PM
sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps
seems to fix this once I'm logged in, how should I be running this?

May 7th, 2010, 11:34 AM
Hello. I am facing the same problem as well. Someone please shed some light on this.


May 7th, 2010, 08:37 PM
Here is another thread on the subject showing where to put this work around so it loads on its own.


I need more touchpad configuration though. As it stands, my wife laptop touchpad is about twice as sensitive in the vertical movements than it is for horizontal movements and she is going to make me take this off her machine (it is dual booting with vista) if I don't sort it out soon.

May 8th, 2010, 02:35 AM
Thanks. That fixes the issue. However, I'm not able to locate /etc/modprobe.d/options.

May 17th, 2010, 07:36 PM
On my laptop, the issue was a touchpad_enabled key in gconf which was set to false.

With the command line it can be fixed using:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

May 17th, 2010, 07:48 PM
I would venture a guess that the issue which m_kelly experienced is what is affecting the OP and others in this thread. After all, it is something happening upon logging in which means it is a setting issue, and gconf handles all the settings in GNOME. His fix should be permanent and not a work-around requiring constant loading. Cheers.

May 20th, 2010, 08:17 AM
On my laptop, the issue was a touchpad_enabled key in gconf which was set to false.

With the command line it can be fixed using:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true

June 10th, 2010, 09:04 PM
Thanks m_kelly (http://ubuntuforums.org/member.php?u=871656) it worked! :popcorn:

June 12th, 2010, 08:09 PM
Thank you m_kelly, it worked for me also :d

June 27th, 2010, 08:45 AM
Hi guys, I was wondering about this problem. I happened to turn my touchpad off from the BIOS but now that I want to turn it on again from there I am unable to. i tried following the directions posted here but it still doesn't work.

I posted this in another forum topic too but I was wondering if it would fit in this thread as well.

I know there's a solution but I'm just not that well versed in Ubuntu Linux to find a workaround myself.

Hope someone could help me. Thanks in advance.

June 27th, 2010, 04:03 PM
spike_naples, if you have turned off the touchpad from the BIOS, then your best (possibly only) solution is to turn it on from the BIOS. The fix that was posted will only work if the problem was the touchpad_enabled gconf key being set to false. It's kind of like trying to turn on a light with a light switch during a power outage; no matter how many times you flip the switch, it won't work until the the power outage has been fixed.

From a command line, try running:

gconftool-2 --get /desktop/gnome/peripherals/touchpad/touchpad_enabled

If it outputs "false", then you should try the fix. If the output is "true", then the change that the fix makes has already been made.

July 5th, 2010, 08:54 AM
Thanks. I've turned it on and off from the BIOS several times but it just doesn't work anymore.

I'm thinking of reinstalling again though as I feel this is the only solution. Have that one problem about auto login too as it displays an error but this concern belongs to another thread.

Anyway, I appreciate all the help you guys do for noob users like myself. Don't get tired of us.

January 1st, 2011, 01:21 PM
The command indicated in an earlier post in this thread fixed it for me:

gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true
If not done, could you mark your post as "Solved" to facilitate other people trying to fix the same problem?