PDA

View Full Version : [SOLVED] SPDIF on M4A78-HTPC



Solsiden
April 28th, 2010, 08:36 AM
I am trying to switch from Windows XP to Ubuntu 9.04 (10.04) for my HTPC, but cannot get sound out of the SPDIF/IEC958.

The motherboard is Asus M4A78-HTPC it works under Windows, but I can only get ”digital” sound out through the HDMI. Windows uses a HDA ATI 791A driver and a VIA VT 1718S codec. As soon as Ubuntu is booting the Optical signal is disabled. Ubuntu does show the sound card as ATI RS690/780 HDMI. GNOME-ALSA Mixer has a button titled IEC959, but nothing happens when it is activated.

I am a beginner concerning Linux. What can I do? I would like to give Linux a chance before switching to Win 7.

lidex
April 29th, 2010, 07:41 PM
Have a look here:
http://ubuntuforums.org/showthread.php?t=877811

Solsiden
May 5th, 2010, 08:37 AM
Thank you, but I am still missing the sound through IEC958. I have tried to follow the instructions in http://alsa.opensrc.org/index.php/DigitalOut#Find_your_device (http://alsa.opensrc.org/index.php/DigitalOut#Find_your_device). May be I have misunderstood something, but I cannot figure out what. I get the following using aplay and iecset:
per@music:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: HDA Generic [HDA Generic]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
per@music:~$ iecset
control "IEC958 Playback Default" (index -1) not found

Any suggestions?

lidex
May 5th, 2010, 03:52 PM
Make sure you spdif's are not muted in alsamixer.
alsamixer
Press F6 to select the correct soundcard.
Press F3 to show playback levels. F4 selects capture levels [or use <Tab>]
Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.

Solsiden
May 7th, 2010, 02:17 PM
I have tried running alsamixer and chosen all soundcards, but no change. The sound played with aplay or other players, all come through the HDMI, not the SPDIF!

The SPDIF output is inactive – no light! How can it be enabled?

I have looked in the file /proc/asound/cards:

0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xfbbf4000 irq 16
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xfbde8000 irq 19
2 [SAA7134 ]: SAA7134 - SAA7134
saa7133[0] at 0xfbfff800 irq 20

It does not show any IEC958/SPDIF options.

schildpad
May 7th, 2010, 06:29 PM
I have the same problem, my board is m4a785g :)
Tried the suggested solutions, but still no luck with sound over spdif.

This is very frustrating because i want all sound routed over SDDIF to my Sony receiver (which doesnt have HDMI).

Any help is welcome.

lidex
May 8th, 2010, 05:21 AM
Can you post the output of these terminal commands for me please:

uname -a
aplay -l
cat /proc/asound/version
head -n 1 /proc/asound/card*/codec#*
Terminal="Applications->Accessories->Terminal"
Please post text output using code tags. Also helpful is the make/model of your PC/Laptop.

Solsiden
May 9th, 2010, 10:00 PM
per@music:~$ uname -a
Linux music 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686 GNU/Linux
per@music:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: HDA Generic [HDA Generic]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
per@music:~$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.21.
per@music:~$ head -n 1 /proc/asound/card*/codec#*
==> /proc/asound/card0/codec#0 <==
Codec: VIA ID 4428

==> /proc/asound/card1/codec#0 <==
Codec: ATI RS690/780 HDMI
per@music:~$



-------------------
The Pc is home build based on the Asus M4A78-HTPC motherboard. Bios version 0302 build 04/02/09. As mentioned earlier – under Windows XP the SPDIF works fine.

BR

lidex
May 12th, 2010, 01:01 AM
Try an alsa upgrade. Use the link in my sig.

schildpad
May 12th, 2010, 02:35 PM
Thanks man!

I upgraded Alsa according to your post (follow the link "Alsa Upgrade Script" in the signature from Lidex:)
Then i runned "alsamixer" and unmuted the SPDID and IEC958 and voila, sound all the way.

Did I say Thank You already?

No?

THANKS!!!

Greetings Sven

stunted
May 13th, 2010, 03:10 AM
If you're reluctant to upgrade alsa post the output of these 4 commands.


cat /proc/asound/cards
cat /proc/asound/pcm
aplay -l
aplay -L

you probably need a line like

options snd-hda-intel model=6stack-dig position_fix=1
near the bottom of your /etc/modprobe.d/alsa-base file, and lines like
load-module module-alsa-sink device="iec958:CARD=SB,DEV=0" sink_name=digital_out
load-module module-alsa-sink device="front:CARD=SB,DEV=0" sink_name=analog_out
load-module module-combine sink_name=combined master=digital_out slaves=analog_out
in /etc/pulse/default.pa

Please note I don't have the HDMI output enabled in BIOS so not using that wasn't an issue for me.

Also I hate software mixing and in fact have gone back to my old and trusty SBLive! Value with hardware mixing, the only reason I use pulse on one machine is a power spike zapped the on-board NIC and my graphics cooler covers all bar one of the pci and pci/e slots which I need for a network card, but that PC's running Debian Lenny, so maybe pulse has improved a lot in the last 2 years.

Sepepe
May 14th, 2010, 12:50 AM
I have ASUS M4A77 motherboard and also have problem with S/PDIF output. Motherboards soundchip is VIA VT1818S. I read this thread and did the alsa upgrade.

Speaker test worked with this line

speaker-test -Dplughw:0,1 -c2
Other than that the computer stays silent. I also tried every profile option from the sound preferences tool next to the clock but no success. In alsamixer S/PDIF is unmuted and it recognizes the card as HDA ATI SB and the chip as VIA VT1818S.

Should I add some lines to alsa-base.conf and default.pa? Since the speaker test works I think the solution is quite easy but as a total Ubuntu noob I'm still baffled.

Here's also commands and outputs asked earlier from others

uname -l:

Linux ubuntu 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010 x86_64 GNU/Linuxaplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: VT1818S Analog [VT1818S Analog]
Subdevices: 2/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
card 0: SB [HDA ATI SB], device 1: VT1818S Digital [VT1818S Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
cat /proc/asound/version:

Advanced Linux Sound Architecture Driver Version 1.0.23.
Compiled on May 13 2010 for kernel 2.6.32-21-generic (SMP).

Sepepe
May 14th, 2010, 01:36 AM
OK, solved this simply by just booting my DAC :P

Solsiden
May 16th, 2010, 04:42 PM
I did run the "Alsa Upgrade Script" and are now running Alsa version 1.0.23. This works!!! :P All the build-in soundcard options are now available in "Sound properties" in Ubuntu.

Thank you!!

I just wonder why Alsa Version 1.0.23 is not includ ed in the newest release of Ubuntu:confused:

BR

lidex
May 16th, 2010, 07:06 PM
I did run the "Alsa Upgrade Script" and are now running Alsa version 1.0.23. This works!!! :P All the build-in soundcard options are now available in "Sound properties" in Ubuntu.

Thank you!!

I just wonder why Alsa Version 1.0.23 is not included in the newest release of Ubuntu:confused:
BR
Then it would be like a party. You know geeks don't get invited to parties. :rolleyes:

schildpad
May 16th, 2010, 07:42 PM
Did I say thank you already?
No?

THANK YOU :)

lidex
May 16th, 2010, 10:45 PM
Solsiden,
Can you mark this thread as solved so I can quit looking at it? ;)

Paullus_N
August 22nd, 2010, 04:45 PM
Hi all,

I've been working on this problem for a couples of days now.
I have an Asus M4A77D motherboard and a Asus EN9500GT VGA.
The SPDIF cable is connected to the VGA as instructed.

I have updated Alsa to the latest version:

server@HomeServer:~$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.23.
Compiled on Aug 22 2010 for kernel 2.6.32-21-generic (SMP).
The SPDIF en SPDIF Default PCM devices are unmuted in alsamixer. I have selected Analog Stereo Duplex in the sound configuration tool, and done the gstreamer-properties setting as instructed, tot Alsa with the digital output.

And this results in no sound at all over the HDMI connection to my tv.
I've rebooted, pc and tv

Speaker-test is silent.
It worked with analog connection to my amplifier, but since my tv does some extra stuff the sound is playing ahead of the image. So, I *need* to get sound over the HDMI so both audio and video are in sync.

Any help is welcome.

note: I'm not a total noob in linux, but I do love to know all the commands if I need to do stuff :D

Thanks!

[edit]
for those who want to know:


server@HomeServer:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: VT1818S Analog [VT1818S Analog]
Subdevices: 2/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
card 0: SB [HDA ATI SB], device 1: VT1818S Digital [VT1818S Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0



server@HomeServer:~$ aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=SB
HDA ATI SB, VT1818S Analog
Default Audio Device
front:CARD=SB,DEV=0
HDA ATI SB, VT1818S Analog
Front speakers
surround40:CARD=SB,DEV=0
HDA ATI SB, VT1818S Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=SB,DEV=0
HDA ATI SB, VT1818S Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=SB,DEV=0
HDA ATI SB, VT1818S Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=SB,DEV=0
HDA ATI SB, VT1818S Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=SB,DEV=0
HDA ATI SB, VT1818S Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=SB,DEV=0
HDA ATI SB, VT1818S Digital
IEC958 (S/PDIF) Digital Audio Output

lidex
August 23rd, 2010, 11:37 PM
You're using the hdmi port on the 9500gt? What nvidia driver are you using?

Have you looked here:
http://www.nvnews.net/vbulletin/forumdisplay.php?f=14

Exxplicit
September 28th, 2010, 08:03 AM
Using a M4A77D mobo did the Alsa update and BAM I have sound! It took me an eternity to find this solution but much thanks is appreciated!