PDA

View Full Version : [ubuntu] Multi Touch on trackpad.



Kisame
April 27th, 2010, 11:21 AM
If I understand correctly then lucid lynx is now multitouch compatible, after about 20 minutes of searching I still haven found any leads on how to get that working on my laptop. Im still not even sure if its a possibility, so if i could get some help it would be much appreciated

demetrius2009
April 27th, 2010, 09:28 PM
Hey, on my Asus k52JR multi-touch works out of the box in Lucid RC (2, 3 fingers, zoom in, zoom out) am I doing something wrong?:lolflag:

Kisame
April 28th, 2010, 12:38 PM
I found the option in the preferences - mouse then Trackpad, there are options for disabling, using the side thing for scrolling or 2 finger scrolling, which ive seen work on my dads laptop but is greyed out on mine, any ideas?

pi/roman
April 28th, 2010, 06:23 PM
I don't know if there is a differnece between trackpad and touchpad but if there is maybe someone can explain it to me. The following instructions for changing touchpad options in Lucid are from my tuochpad guide:

b: udev configuration
This is the only way I have found to configure the touchpad in Lucid but it may not work with ealier releases.
You will need to create a file to include udev rules so use Alt/F2:
gksudo gedit /etc/udev/rules.d/touchpad.rulesNow you should have a blank slate here so here is what you need to put in it:

ACTION!="add|change", GOTO="touchpad_end"
KERNEL!="event*", GOTO="touchpad_end"
ENV{ID_INPUT_TOUCHPAD}!="1", GOTO="touchpad_end"
ENV{x11_options.OPTION}="VALUE"
LABEL="touchpad_end" In this line: "ENV{x11_options.OPTION}="VALUE" you want to change the option and value to the ones you found to work in step 3 and recreate as many more of these lines as you need to cover all of the settings you want.

section 3:
Open a terminal and type:



synclient -lYou should see some values assigned to your touchpad options here. If you are getting an SHMconfig error then you need to enable it through hal.
You can adjust settings temporarily through synclient by typing in terminal


synclient OPTION=VALUE