PDA

View Full Version : .23 backend respawning loop



tommyp
April 18th, 2010, 05:14 AM
Upon upgrade to .23, my backend does not start up unless i type "mythbackend" in a terminal. My logs are showing an endless loop of the following:


Apr 18 00:08:19 krimpet init: mythtv-backend main process (8653) terminated with status 254
Apr 18 00:08:19 krimpet init: mythtv-backend main process ended, respawning
Apr 18 00:08:22 krimpet init: mythtv-backend main process (8660) terminated with status 254
Apr 18 00:08:22 krimpet init: mythtv-backend main process ended, respawning
Apr 18 00:08:26 krimpet init: mythtv-backend main process (8667) terminated with status 254
Apr 18 00:08:26 krimpet init: mythtv-backend main process ended, respawning

Any idea what is causing this? How do I fix it?

ian dobson
April 18th, 2010, 01:29 PM
Hi,

What do you see in your backend log (/var/log/mythbackend.log).

In mythbuntu 9.10 they've gone over to using upstart to control startup scripts, and upstart will restart a process if it dies/stops for any reason.

I imagine you have a permissions problem, as the backend starts if you start it manually or maybe a timing problem (backend starting before mysql running).

Regards
Ian Dobson

rich mason
April 19th, 2010, 12:49 AM
I was having this problem.

in /var/log/mythbackend.log i found:


010-04-19 08:21:34.967 UPnPautoconf() - Found one UPnP backend
2010-04-19 08:21:35.115 MythXMLClient::GetConnectionInfo Failed - (606) Action Not Authorized
2010-04-19 08:21:35.126 Testing network connectivity to '10.1.1.4'
2010-04-19 08:21:35.148 Closing DB connection named 'DBManager0'
2010-04-19 08:21:35.278 Unable to connect to database!
2010-04-19 08:21:35.324 Driver error was [1/1045]:
QMYSQL: Unable to connect
Database error was:
Access denied for user 'mythtv'@'10.1.1.4' (using password: YES)

2010-04-19 08:21:35.341 Cannot login to database?

I fixed it by setting the mythtv users mysql password to "mythtv":

# mysql -u root -p mysql
myqsl> GRANT ALL PRIVILEGES ON *.* TO 'mythtv'@'localhost'
-> IDENTIFIED BY 'mythtv' WITH GRANT OPTION;
mysql> UPDATE user SET Password=PASSWORD('mythtv') WHERE user='mythtv';
mysql> FLUSH PRIVILEGES;
mysql> quit

then changing the password in /etc/mythtv/config.xml and /etc/mythtv/mysql.txt to mythtv as well

There is probably an easier way to fix it but this worked ok for me.

mars76
April 19th, 2010, 01:09 AM
Thanks a lot that worked for me as well..

I am not sure why the old password didn't work !!

Now my mythweb is not working..

Warning: require(modules/_shared/tmpl/tmpl/header.php) [function.require (http://localhost/mythweb/function.require)]: failed to open stream: No such file or directory in /usr/share/mythtv/mythweb/modules/_shared/tmpl/_errors/fatal.php on line 23

Fatal error: require() [function.require (http://localhost/mythweb/function.require)]: Failed opening required 'modules/_shared/tmpl/tmpl/header.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/share/mythtv/mythweb/modules/_shared/tmpl/_errors/fatal.php on line 23

ian dobson
April 19th, 2010, 04:50 AM
Hi,

Just reinstall mythweb then reinstall it.

Regards
Ian Dobson