PDA

View Full Version : 10.04 Samba



uncle hammy
April 18th, 2010, 12:33 AM
My first 10.04 Beta 2 install was done today on one front end machine. I used MCC to enable Samaba, however I have a few issues....

1. There is no "Shared Folders" option under Applications>Settings. Where'd it go? I usually just use it to set up samba, because it used to do it as part of the shared folders set up.

2. The usual "sudo service samba start|stop|restart" no longer works. Has it been replaced with "smbd"?

3. I have several shares on my backend machine that I have always mounted in fstab on this frontend machine. I copied my fstab settings from the old 9.10 install to the new 10.04 install, and they mount fine. However if I do a "ls -a" on the files in my shares, they all show up with ownership "dmessagebus:mysql" instead of the "mythtv:mythtv" they are actually owned by on the remote machine. They always used to show up properly.

4. I also can't do a "chmod" or "chown" on these files from the 10.04 install, because I keep getting a "permission denied" error.

Any help with any of this? Does it have anything to do with the shares being housed on a 9.10 machine being accessed by a 10.04 machine?

Flecko
May 4th, 2010, 01:04 AM
I'm having a similar problem. Samba shares worked fine on the 10.04 beta, but upon upgrading to final, they seem to have disappeared. Anyone else noticing this phenomenon?

uncle hammy
May 4th, 2010, 01:59 AM
Now that all my machines are on 10.04 (most notably the actual machine hosting the shares), everything is back to normal. Ownership shows up properly, etc. Though the "samba" service is no longer, there it seems to have been replaced by two services, smbd and nmbd.

neutron68
May 4th, 2010, 05:44 AM
I am also looking for the Shared Folders controls after upgrading from 9.10 to 10.04. Are they gone or were they just moved on us?

This is the only problem I see after the upgrade. Hopefully there aren't more "oh yeah, we moved that on you" surprises.

Eric

beregu
May 8th, 2010, 03:10 AM
I have a bit different problem.

Sharing for local computers working fine in read-only, but local computers are only able to upload a file smaller than 40KB per try.

I clean installed Ubuntu 10.04 and samba. I also used fstab via 'Storage Device Manager' and Samba GUI tool.

Any idea?