PDA

View Full Version : [gnome] Window Manager Ubuntu 10.04



zjagannatha
April 17th, 2010, 05:48 PM
I upgraded to Ubuntu 10.04 (wiped root partition, so it's a clean install) and I'm having issues with my window manager.

It displays all my windows without the toolbar at the top with the Close, Maximize and Minimize Buttons. (Screen shot below)

It might have something to do with the fact that I used to run Emerald before I upgraded, but I deleted the "~/.emerald" folder and it didn't help.

howefield
April 17th, 2010, 05:56 PM
Do the window decorations return with


metacity --replace

zjagannatha
April 17th, 2010, 06:23 PM
That turns the toolbars back on, but turns off Desktop Effects.

howefield
April 17th, 2010, 06:56 PM
It is so long since I used Emerald for window decoration.

What does it say in Compizconfig Settings Manager > Effects > Window Decoration > Command ?

If it references emerald, try changing it to compiz-decorator, eg mine says /usr/bin/compiz-decorator

mcduck
April 17th, 2010, 06:59 PM
I upgraded to Ubuntu 10.04 (wiped root partition, so it's a clean install) and I'm having issues with my window manager.

It displays all my windows without the toolbar at the top with the Close, Maximize and Minimize Buttons. (Screen shot below)

It might have something to do with the fact that I used to run Emerald before I upgraded, but I deleted the "~/.emerald" folder and it didn't help.

How did you set emerald to run automatically when you installed it? Undo that change and things will start to work agan.

If you added "emerald --replace" to startup comamnds in System/PReferences/Startup Applications, then remove it.

R, if you did it properly and configured Compiz to use Emerald as it's decorator, then open CompizConfig Settings Manager, go to Window Decoration-plugin's settings and set the command to "/usr/bin/compiz-decorator" (or just click the brush icon next to this option to automatically reset it to defaults).

zjagannatha
April 17th, 2010, 07:02 PM
That fixed it, thanks a bunch!

Eredeath
April 26th, 2010, 05:58 PM
I know this thread is a tad old but i'm having the same issue. I never used emerald but did use compiz. I can get the window boarders and desktop effects working but after a re-start I loose the window boarders and desktop effects.Any suggestions on how to keep them on?

zjagannatha
April 26th, 2010, 09:08 PM
Are you using compiz now?

Eredeath
April 26th, 2010, 09:33 PM
yes

Eredeath
April 26th, 2010, 09:50 PM
I figured it out. I had to add Compiz to my startup programs. I didn't have any window managers running at startup.

MrByte1
April 30th, 2010, 06:12 PM
@Eredeath
what command did you add to the startup?
For some reason I keep having the same issue, no title bar after login. I open the Compiz Fusion Icon and do a Reload Windows manager and all is backup to normal.... But I shouldn't have to do this after every login .....
Thanks!

mathfreak123
April 30th, 2010, 07:43 PM
@Eredeath
what command did you add to the startup?
For some reason I keep having the same issue, no title bar after login. I open the Compiz Fusion Icon and do a Reload Windows manager and all is backup to normal.... But I shouldn't have to do this after every login .....
Thanks!

Hello. I have my windows back to normal after the upgrade by adding a new entry that uses the command
/usr/bin/compiz

Hope this helps!

MrByte1
April 30th, 2010, 07:54 PM
Hey thanks!!! That fixed it. I could swear I had tried that, but evidently that wasn't it. Now after Log in, all is it should be ...
Thanks again...

mathfreak123
April 30th, 2010, 08:32 PM
Hey thanks!!! That fixed it. I could swear I had tried that, but evidently that wasn't it. Now after Log in, all is it should be ...
Thanks again...

You're welcome! Are you sure you didn't try /usr/bin/compiz-decorator first instead of just /usr/bin/compiz?

MrByte1
April 30th, 2010, 08:45 PM
You're welcome! Are you sure you didn't try /usr/bin/compiz-decorator first instead of just /usr/bin/compiz?

That's quite possible. I tried so many things.....

peterpan7191
May 1st, 2010, 07:59 PM
even - 'compiz --replace' can be added to the startups....

but isnt there ny bettr wrk around ovr this. ??
i simply cant do that bcoz i smtimes boot into kde session (n startup items r shared between sessions donno y it happens like dat)
compiz --replace (or any other compiz related command) there is sure 2 crash the 'kwin' (window manager 4 kde) ??
hopelessy sad as it is a choice btween my 2 beautiful desktop sessions :( ..

zjagannatha
May 1st, 2010, 08:40 PM
even - 'compiz --replace' can be added to the startups....

but isnt there ny bettr wrk around ovr this. ??
i simply cant do that bcoz i smtimes boot into kde session (n startup items r shared between sessions donno y it happens like dat)
compiz --replace (or any other compiz related command) there is sure 2 crash the 'kwin' (window manager 4 kde) ??
hopelessy sad as it is a choice btween my 2 beautiful desktop sessions :( ..

One could theoretically write a simple script that detects if you're using Gnome or KDE, and starts compiz accordingly. I'm not really familiar with Bash, but I'll see what I can dig up.

zjagannatha
May 1st, 2010, 11:56 PM
One could theoretically write a simple script that detects if you're using Gnome or KDE, and starts compiz accordingly. I'm not really familiar with Bash, but I'll see what I can dig up.

Ok. Here's a simple script that detects if you're using gnome and starts compiz if you are.

You should save it to (for example) ~/bin and add it to the startup programs list.

peterpan7191
May 2nd, 2010, 10:06 AM
thanx a lot ... :)

Xanthomryr
May 2nd, 2010, 03:15 PM
Bug report ahoi: https://bugs.launchpad.net/ubuntu/+bug/563161

naitsirhc
May 3rd, 2010, 06:52 PM
Thanks to Christophe Weis responding to the bug reported here:
https://bugs.launchpad.net/ubuntu/+bug/563161

to fix the issue, you can simply add a symlink to get things working:
sudo ln -s /usr/bin/compiz /usr/bin/compiz.real

Apparently after upgrading to 10.04, the file /usr/bin/compiz.real is missing as Christophe points out is mentioned in syslog.

cudaboy
May 4th, 2010, 07:15 AM
I had a similar issue, but with the Compiz Fusion Icon app I was using with 9.10 and something similar to this fixed it. Old command in the Start Apps was grey (unavailable) so I just removed it and created a new one with the command:

/usr/bin/compiz-decorator


thanks!




Hello. I have my windows back to normal after the upgrade by adding a new entry that uses the command
/usr/bin/compiz

Hope this helps!

felixq78
May 5th, 2010, 01:50 AM
I've just upgraded to Ubuntu 10.04 and my window manager icons are on the LEFT HS of the window not on the right as usual. How do I change it back to normal.

mathfreak123
May 5th, 2010, 03:34 AM
I've just upgraded to Ubuntu 10.04 and my window manager icons are on the LEFT HS of the window not on the right as usual. How do I change it back to normal.

Easiest solution (or it worked for me):
System -> preferences -> Appearance. Select "Human-Clearlooks", then customize based off of that theme.

bancs
May 5th, 2010, 06:20 AM
have a try to turn the toolbars back on, but turn off Desktop Effects.

Xanthomryr
May 5th, 2010, 09:42 PM
I've just upgraded to Ubuntu 10.04 and my window manager icons are on the LEFT HS of the window not on the right as usual. How do I change it back to normal.

As normal user type into the terminal:

gconftool-2 --type string --set /apps/metacity/general/button_layout "menu:minimize,maximize,close"

MrByte1
May 5th, 2010, 10:13 PM
I had a similar issue, but with the Compiz Fusion Icon app I was using with 9.10 and something similar to this fixed it. Old command in the Start Apps was grey (unavailable) so I just removed it and created a new one with the command:

/usr/bin/compiz-decorator
thanks!


I was also able to solve this by placing the Compiz Fusion Icon in the startup (fusion-icon). It causes a) the Icon to be in the Panel and b) to have it accesible anytime and most importantly c) the windows manager on startup fixes the windows decorator issue.....

milesnapue
May 9th, 2010, 02:46 PM
Hello. I have my windows back to normal after the upgrade by adding a new entry that uses the command
/usr/bin/compiz

Hope this helps!


Perfect, thanks, this fixed my small problem perfectly!

leona
May 9th, 2010, 03:56 PM
How did you set emerald to run automatically when you installed it? Undo that change and things will start to work agan.

If you added "emerald --replace" to startup comamnds in System/PReferences/Startup Applications, then remove it.

R, if you did it properly and configured Compiz to use Emerald as it's decorator, then open CompizConfig Settings Manager, go to Window Decoration-plugin's settings and set the command to "/usr/bin/compiz-decorator" (or just click the brush icon next to this option to automatically reset it to defaults).

Oh thank you, thank you , thank you so much, that fixed my problem too, great.

AbeJarano
November 29th, 2010, 05:49 PM
Thanks, that worked for me, also.

noletolucas
July 3rd, 2011, 05:10 AM
same problem. :(


doing the "metacity --restart" on console only works while the terminal remains opened.

setting "system -> appearences -> effects -> normal" only works until reboot.