PDA

View Full Version : [ubuntu] Internet connection



JFDsouza
April 16th, 2010, 07:09 AM
I see the network applet in the panel which shows that I am connected but I cannot access the net. I found out that I had to do this in firefox
about:config --> IPv6 --> disable.IPv6 true
With this tweak I was able to connect to the net. But when I use the Update Manager or Synaptic I am not getting connected, even if I use the cli and do
apt-get update I cannot connect. When I do
ping -c3 192.168.1.1 I get 0% loss.:confused:

dineshs
April 16th, 2010, 08:04 AM
What do you get for

ping 8.8.8.8

cat /etc/resolv.conf
and

route -n

JFDsouza
April 16th, 2010, 09:41 AM
For ping 8.8.8.8
I get pinging 8.8.8.8 and all the lines that you normally get. No loss there

For cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 192.168.1.1

For route -n
There is a lot of out put. Which line do you want me to post? Which column?
Destination Gateway Genmask etc

dineshs
April 16th, 2010, 10:27 AM
Pl try this

gksudo gedit /etc/resolv.conf
And edit the file so that it looks like

# Generated by NetworkManager
nameserver 8.8.8.8
nameserver 8.8.4.4
nameserver 192.168.1.1

JFDsouza
April 16th, 2010, 05:16 PM
What should that do? and should I reboot or will I get the effect immediately?

terazen
April 16th, 2010, 06:59 PM
The resolv.conf file has your dns settings. It's possible that your local isp is having a problem with dns. If that's the case you can always setup opendns's settings on the router. Opendns is 208.67.220.220 and 208.67.222.222.

I've never seen 8.8.8.8 before, but I just looked it up and it's google's dns.

Also, if Dineshs's changes work (they should be immediate) then you would want to change your dns settings on your router. I always change to opendns on my computers and my family's...and I'd imagine google's service is probably just as good.

dineshs
April 17th, 2010, 05:44 AM
terazen is right.Also do you have problem only while running sudo apt-get update? Are you able to browse?

JFDsouza
May 27th, 2010, 12:50 PM
Sorry I have not come to forum for a while. I have upgraded to Lucid Lynx and I am not having the problem I had earlier. Thanks for the help.