PDA

View Full Version : [ubuntu] connecting with remote desktop viewer by name instead of IP address



cedardoc
April 15th, 2010, 11:40 PM
The computers on my network change IP address from day to day, so connecting through trial and error is becoming a pain. When I used to use UltraVNC in windows you could just enter the computer name and it would just find it. Is there a way to do this with Remote Desktop Viewer 2.28.1 (on Ubuntu 9.1)

I've tried "smb://computername/", and just "computername"

there doesn't seem to be a lot of documentation for this application (or at least I haven't been able to find it - other than the Vinage Manual which didn't help)

I am pretty much samba-illiterate... I wonder if it has to do with that.

anyone have any ideas?

Thanks,
Dave

n2stc
April 18th, 2010, 02:53 AM
I am looking for an answer to this also.:confused:

howefield
April 18th, 2010, 03:01 AM
The computers on my network change IP address from day to day, so connecting through trial and error is becoming a pain.

Can't you assign specific IPs to your computers via your router settings ?

Iowan
April 18th, 2010, 03:22 AM
I use DNSMasq for DHCP/DNS on my network. It allows me to ping/ssh/etc via hostname rather than IP address - even to DHCP clients. However, the clients must provide their hostname. I needed to edit /etc/dhcp3/dhclient.conf and change the line:
send host-name "<hostname>";
to the machine's actual name.