PDA

View Full Version : [ubuntu] Booting resolution problem in 10.4



gall
April 9th, 2010, 09:54 AM
Just after installing Ubuntu 10.4 I had plymuth and console resolution set to my screen native resolution, like 1920x1200. After updates and Nvidia drivers installation i have only 80x30 console:
from kern.log:


Console: switching to colour frame buffer device 80x30
so splash screen looks ugly and console is useless for me. How can i set right resolution?

Phentis
April 9th, 2010, 01:26 PM
Step 1


You must edit the /etc/default/grub file.

Open a terminal and paste this:


$ sudo gedit /etc/default/grub

On line #18, uncomment (uncomment = remove the # in front of the line #GRUB_GFXMODE=640480 and change the resolution to whatever you want (in my particular case, I changed it to 1680x1050). Here is how it should look:


GRUB_GFXMODE=1680x1050


Step 2


edit the /etc/grub.d/00_header file.


$ sudo gedit /etc/grub.d/00_header

And find the following line: gfxmode=${GRUB_GFXMODE} (its line 103 on my computer) and under it, paste this:


set gfxpayload=keep


Step 3


update Grub 2:

To update the GRUB, simply run the following command:


$ sudo update-grub

Once you complete the above steps, restart the computer and you should see the nice Plymouth screen.

endtroducing
April 19th, 2010, 02:14 AM
Thank you!

Bodai
May 1st, 2010, 11:34 AM
Many thanks Phentis =D>

yeleek
May 18th, 2010, 10:28 AM
Thanks :)

untitled_o
May 18th, 2010, 11:16 PM
hey, im new here and i have one question, when im trying do what u said Phentis appears on my console onething like " [sudo] password for untitled : "
and after i cant do anything :\

any help?

josarn
May 20th, 2010, 08:46 AM
Hi there everyone. I would like to comment the behavior of my computer when i applied the changes to the config files mentioned in this thread . When I rebooted I found that the splash screen had the correct resolution but it was not centered and when I checked the terminal with Ctrl + Alt + F1 I found myself staring at black screen. I did some googling and found that setting the resoultion in the 00_header file was supposed to work too, so I tried that and it set things straight. So in my case the line to add to /etc/grub.d/00_header looks like this:


set gfxpayload=1680x1050

spraitas
May 30th, 2010, 07:02 PM
Like in josarn case i had same problem, everything not being centered. The quick update to /etc/grub.d/00_header solved eveything. Thanks all.

Beckman
October 22nd, 2010, 06:19 PM
This was very helpful, thank you.