PDA

View Full Version : Lucid beta 1, Intel D510MO no network



igadgetman
April 7th, 2010, 06:58 PM
After working with 9.10 I did a distribution upgrade some time ago to Lucid alpha 2 and 3. Two weeks ago I did the same again with beta 1. Then I downloaded and installed the 10.04 beta1 cd. Last saturday I installed all the available updates. No problems at that moment. After a restart it seemed that my network is unreachable. Doing an 'ifconfig' I discover that eth0 and lo0 is available. But can't go onto my network and internet. The NetworkManager is telling me I have a eth0 configured. Removing the line and adding it again, still nothing worked. I replaced the networkcable and position in my 100Mbit switch.

So I went back to the official 9.10 cd, installed ubuntu again and everything worked again. Installing 10.04beta1 with updates , network gone again. In desperation I installed fedora 12, network worked again. After upgrading to latest files, network gone. Even tried a copy of Windows 7. No network. Installed the realtek windows 7 driver. No network.

Getting a bit desperate now. I suspect a kernel update and even my D510MO atom board. But why is it working with the official 9.10 release? Is the speed automatically set to 1Gbit and thus choking my switch? Oh yeah, latest BIOS is installed. I reset bios to default.

iGadgetman

lisati
April 7th, 2010, 08:27 PM
Thread moved

10.04 hasn't been officially released yet.

powder
April 7th, 2010, 09:03 PM
You could try editing /etc/network/interfaces.

gksudo gedit /etc/network/interfaces

Then add:

allow-hotplug eth0
iface eth0 inet dhcp

Now reboot and it should connect automatically.

Note that this method will bypass Network Manager so it will probably report that you are disconnected. If you still have a problem it is likely driver related.

cariboo907
April 7th, 2010, 11:19 PM
Are you sure you aren't suffering from a dns problem? Do you get an ip address, to check, open a terminal and type:


ifconfig

If you get an ip address check resolv.conf


cat /etc/resolv.conf

it should look similar to this:


cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 64.59.168.13

If you see your router ip address in the output, you can change the dns settings on the IPv4 tab of edit connections.