PDA

View Full Version : 10.04 and Ati Radeon Xpress 1250 = NO VIDEO



yardo
April 6th, 2010, 10:06 PM
I cant get video working on this laptop setup (no video at all, either the shells):

Intel Core2 Duo Processor T7250 2.0 Ghz
ATI RS600ME Chipset
ATI Radeon Xpress 1250

The complete specs here: http://www.notebook-driver.com/laptops-information/lg-xnote-e200-notebook-specifications/

What can I do for solve my video problem? devs are working on this problem? No problems and 100% working with this setup and older versions 9.04, 9.10...


Sorry, my english isnt perfect, Im from Spain, thanks in advance

yardo
April 7th, 2010, 02:24 PM
No one can help me? :(

Mark Phelps
April 8th, 2010, 11:05 PM
That's because 10.04 is still in beta testing and you should be posting your beta-related questions in the proper beta testing forum: Development & Programming, Lucid Lynx Testing.

yardo
April 11th, 2010, 11:14 AM
That's because 10.04 is still in beta testing and you should be posting your beta-related questions in the proper beta testing forum: Development & Programming, Lucid Lynx Testing.

Thank you ;)

drBouvierLeduc
April 23rd, 2010, 04:10 PM
I have exactly the same problem, with the same video card, and now that the Release Candidate is out, I'm starting to doubt it will be working when the final version will be here.
I thought it was connected with this bug mentionned in launchpad : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/509273 (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/509273), but the fix is already supposed to be released (so it should be part of the RC I guess ?), but it's still not working.
Well, let's wait and see...

Untitled_No4
April 23rd, 2010, 05:01 PM
http://ubuntuforums.org/showthread.php?t=1460746
(solution is in last post)

Lollerke
April 23rd, 2010, 05:48 PM
drBouvierLeduc: That patch only fixes the problem for ATI X200M.

drBouvierLeduc
April 25th, 2010, 08:22 PM
Well, I didn't see the solution in the post you mention (maybe I didn't look carefully though).
So here's the solution/workaround I found in the relevant bug report here : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/558378

1/ Soon after booting the computer, enter the grub menu by pressing the 'shift' key
2/ Choose the Kernel you want too boot (should be 2.6.32), and press 'e' to edit the parameters
3/ Add radeon.modeset=0 at the end of the GRUB_CMDLINE_LINUX_DEFAULT="..."
It should look like this :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=0"
4/ Press 'Ctrl+X' to finish the boot.

Now it should be working fine. Don't forget afterward to edit the file /etc/default/grub to make this workaround permanent.
As mentioned in the bug report, this card should be blacklisted from Kernel-mode setting, as it will certainly confuse a lot of poeple (like it confused me !)

sdowney717
April 25th, 2010, 08:35 PM
sometimes you can get a clue by looking at the xorg.0.log file
for errors

yardo
April 25th, 2010, 10:31 PM
Well, I didn't see the solution in the post you mention (maybe I didn't look carefully though).
So here's the solution/workaround I found in the relevant bug report here : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/558378

1/ Soon after booting the computer, enter the grub menu by pressing the 'shift' key
2/ Choose the Kernel you want too boot (should be 2.6.32), and press 'e' to edit the parameters
3/ Add radeon.modeset=0 at the end of the GRUB_CMDLINE_LINUX_DEFAULT="..."
It should look like this :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=0"
4/ Press 'Ctrl+X' to finish the boot.

Now it should be working fine. Don't forget afterward to edit the file /etc/default/grub to make this workaround permanent.
As mentioned in the bug report, this card should be blacklisted from Kernel-mode setting, as it will certainly confuse a lot of poeple (like it confused me !)

Thanks, now is working with this tip! :)